summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2013-07-04 08:20:28 +0000
committerMarc Schiffbauer <mschiff@gentoo.org>2013-07-04 08:20:28 +0000
commit137235d3f0154a794e76c3908a5a6f5d3f0a6a4b (patch)
tree989aa389e1eb92f966b1542f6036d5eca81ebdf4 /kde-base/kdepim-runtime/kdepim-runtime-4.10.5-r1.ebuild
parentversion bump, drop old (diff)
downloadgentoo-2-137235d3f0154a794e76c3908a5a6f5d3f0a6a4b.tar.gz
gentoo-2-137235d3f0154a794e76c3908a5a6f5d3f0a6a4b.tar.bz2
gentoo-2-137235d3f0154a794e76c3908a5a6f5d3f0a6a4b.zip
Fix accountwizard autoconfig feature. Backport patch from 4.11 (KDE bug #321927)
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key 0x296C6CCA35A64134)
Diffstat (limited to 'kde-base/kdepim-runtime/kdepim-runtime-4.10.5-r1.ebuild')
-rw-r--r--kde-base/kdepim-runtime/kdepim-runtime-4.10.5-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/kde-base/kdepim-runtime/kdepim-runtime-4.10.5-r1.ebuild b/kde-base/kdepim-runtime/kdepim-runtime-4.10.5-r1.ebuild
new file mode 100644
index 000000000000..fe9350b02c0a
--- /dev/null
+++ b/kde-base/kdepim-runtime/kdepim-runtime-4.10.5-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/kdepim-runtime-4.10.5-r1.ebuild,v 1.1 2013/07/04 08:20:28 mschiff Exp $
+
+EAPI=5
+
+KMNAME="kdepim-runtime"
+inherit kde4-base
+
+DESCRIPTION="KDE PIM runtime plugin collection"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug google kolab"
+
+RESTRICT="test"
+# Would need test programs _testrunner and akonaditest from kdepimlibs, see bug 313233
+
+DEPEND="
+ app-misc/strigi
+ >=app-office/akonadi-server-1.9.0
+ dev-libs/boost:=
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ >=dev-libs/shared-desktop-ontologies-0.10.0
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop(+)')
+ x11-misc/shared-mime-info
+ google? ( >=net-libs/libkgapi-0.4.3 )
+ kolab? ( net-libs/libkolab )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kdepim-icons)
+ !kde-misc/akonadi-google
+"
+
+# nepomuk_email_feeder moved here in 4.8
+add_blocker kdepim-common-libs 4.7.50
+
+src_configure() {
+ epatch "${FILESDIR}/${PN}-4.10.5-fix-autoconfig.patch"
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package google LibKGAPI)
+ $(cmake-utils_use_find_package kolab Libkolab)
+ $(cmake-utils_use_find_package kolab Libkolabxml)
+ )
+
+ kde4-base_src_configure
+}