summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-12-18 19:58:23 +0000
committerJohannes Huber <johu@gentoo.org>2013-12-18 19:58:23 +0000
commit885ecb4a69485d6d2cbb21c20f0dc4cf4f20995c (patch)
treea746d61b035d298b8c5f5bdb7a403546a6c68fe7 /kde-base/kdepim-runtime
parentMask >=kde-base/kopete-4.12.0[otr] because of package mask on >=net-libs/libo... (diff)
downloadgentoo-2-885ecb4a69485d6d2cbb21c20f0dc4cf4f20995c.tar.gz
gentoo-2-885ecb4a69485d6d2cbb21c20f0dc4cf4f20995c.tar.bz2
gentoo-2-885ecb4a69485d6d2cbb21c20f0dc4cf4f20995c.zip
Version bump KDE SC 4.12.0
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/kdepim-runtime')
-rw-r--r--kde-base/kdepim-runtime/ChangeLog7
-rw-r--r--kde-base/kdepim-runtime/kdepim-runtime-4.12.0.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/kde-base/kdepim-runtime/ChangeLog b/kde-base/kdepim-runtime/ChangeLog
index 564f4500abf7..7307ce333c61 100644
--- a/kde-base/kdepim-runtime/ChangeLog
+++ b/kde-base/kdepim-runtime/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdepim-runtime
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/ChangeLog,v 1.175 2013/12/15 14:04:09 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/ChangeLog,v 1.176 2013/12/18 19:57:56 johu Exp $
+
+*kdepim-runtime-4.12.0 (18 Dec 2013)
+
+ 18 Dec 2013; Johannes Huber <johu@gentoo.org> +kdepim-runtime-4.12.0.ebuild:
+ Version bump KDE SC 4.12.0
15 Dec 2013; Andreas K. Huettel <dilfridge@gentoo.org>
kdepim-runtime-4.4.11.1-r1.ebuild:
diff --git a/kde-base/kdepim-runtime/kdepim-runtime-4.12.0.ebuild b/kde-base/kdepim-runtime/kdepim-runtime-4.12.0.ebuild
new file mode 100644
index 000000000000..b27ad69288b4
--- /dev/null
+++ b/kde-base/kdepim-runtime/kdepim-runtime-4.12.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/kdepim-runtime-4.12.0.ebuild,v 1.1 2013/12/18 19:57:56 johu Exp $
+
+EAPI=5
+
+KMNAME="kdepim-runtime"
+inherit kde4-base
+
+DESCRIPTION="KDE PIM runtime plugin collection"
+KEYWORDS=" ~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug facebook google kolab"
+
+RESTRICT="test"
+# Would need test programs _testrunner and akonaditest from kdepimlibs, see bug 313233
+
+DEPEND="
+ app-misc/strigi
+ >=app-office/akonadi-server-1.10.43
+ dev-libs/boost:=
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ >=dev-libs/shared-desktop-ontologies-0.11.0
+ $(add_kdebase_dep kdepimlibs)
+ x11-misc/shared-mime-info
+ facebook? ( net-libs/libkfbapi )
+ google? ( >=net-libs/libkgapi-2.0 )
+ kolab? ( net-libs/libkolab )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kdepim-icons)
+ !kde-misc/akonadi-google
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package facebook LibKFbAPI)
+ $(cmake-utils_use_find_package google LibKGAPI2)
+ $(cmake-utils_use_find_package kolab Libkolab)
+ $(cmake-utils_use_find_package kolab Libkolabxml)
+ )
+
+ kde4-base_src_configure
+}