summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-01-11 15:01:54 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-01-11 15:01:54 +0000
commit437ca9dd173959807f295ff404294da8502874f9 (patch)
treed49e972f4338a3d6eefc319ffd24eb26bf86976a /kde-base/kdepim-wizards
parentFix build failure against latest monadcatchio-mtl-0.3.1.0 (bug #497496 by Jas... (diff)
downloadgentoo-2-437ca9dd173959807f295ff404294da8502874f9.tar.gz
gentoo-2-437ca9dd173959807f295ff404294da8502874f9.tar.bz2
gentoo-2-437ca9dd173959807f295ff404294da8502874f9.zip
Add more libraries in underlinking patch, bug 497788; thanks to Bernhard Stiftner
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'kde-base/kdepim-wizards')
-rw-r--r--kde-base/kdepim-wizards/ChangeLog9
-rw-r--r--kde-base/kdepim-wizards/files/kdepim-wizards-4.4.11.1-underlinking.patch8
2 files changed, 11 insertions, 6 deletions
diff --git a/kde-base/kdepim-wizards/ChangeLog b/kde-base/kdepim-wizards/ChangeLog
index d25d389bb19e..8e1a694f39df 100644
--- a/kde-base/kdepim-wizards/ChangeLog
+++ b/kde-base/kdepim-wizards/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdepim-wizards
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-wizards/ChangeLog,v 1.198 2013/10/10 05:26:53 creffett Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-wizards/ChangeLog,v 1.199 2014/01/11 15:01:53 dilfridge Exp $
+
+ 11 Jan 2014; Andreas K. Huettel <dilfridge@gentoo.org>
+ files/kdepim-wizards-4.4.11.1-underlinking.patch:
+ Add more libraries in underlinking patch, bug 497788; thanks to Bernhard
+ Stiftner
*kdepim-wizards-4.4.11.1 (10 Oct 2013)
diff --git a/kde-base/kdepim-wizards/files/kdepim-wizards-4.4.11.1-underlinking.patch b/kde-base/kdepim-wizards/files/kdepim-wizards-4.4.11.1-underlinking.patch
index 780c5d6a5afa..2ec6c7a499e0 100644
--- a/kde-base/kdepim-wizards/files/kdepim-wizards-4.4.11.1-underlinking.patch
+++ b/kde-base/kdepim-wizards/files/kdepim-wizards-4.4.11.1-underlinking.patch
@@ -6,7 +6,7 @@ diff -ruN kdepim-wizards-4.4.11.1.orig/wizards/CMakeLists.txt kdepim-wizards-4.4
kde4_add_executable(groupwarewizard ${groupwarewizard_SRCS})
- target_link_libraries(groupwarewizard ${QT_QT3SUPPORT_LIBRARY} ${KDE4_KDECORE_LIBS}
-+ target_link_libraries(groupwarewizard ${QT_QTGUI_LIBRARY} ${QT_QT3SUPPORT_LIBRARY} ${KDE4_KDECORE_LIBS}
++ target_link_libraries(groupwarewizard ${QT_QTGUI_LIBRARY} ${QT_QT3SUPPORT_LIBRARY} ${KDE4_KDECORE_LIBS} kio kdeui kpimutils
kabcgroupwise kcalgroupwise
kcal_slox kabc_slox
kabckolab knoteskolab
@@ -16,7 +16,7 @@ diff -ruN kdepim-wizards-4.4.11.1.orig/wizards/CMakeLists.txt kdepim-wizards-4.4
- target_link_libraries(groupwisewizard ${KDEPIMLIBS_KPIMIDENTITIES_LIBS} ${QT_QT3SUPPORT_LIBRARY} ${KDE4_KDECORE_LIBS} ${KDE4_KIDENTITIES_LIBS} kabcgroupwise kcalgroupwise ${KDEPIMLIBS_KCAL_LIBS} kdepim )
+ target_link_libraries(groupwisewizard ${KDEPIMLIBS_KPIMIDENTITIES_LIBS} ${QT_QTGUI_LIBRARY}
-+ ${QT_QT3SUPPORT_LIBRARY} ${KDE4_KDECORE_LIBS} ${KDE4_KIDENTITIES_LIBS} kabcgroupwise kcalgroupwise ${KDEPIMLIBS_KCAL_LIBS} kdepim )
++ ${QT_QT3SUPPORT_LIBRARY} ${KDE4_KDECORE_LIBS} ${KDE4_KIDENTITIES_LIBS} kabcgroupwise kcalgroupwise ${KDEPIMLIBS_KCAL_LIBS} kdepim kpimutils kio )
install(TARGETS groupwisewizard ${INSTALL_TARGETS_DEFAULT_ARGS})
@@ -26,7 +26,7 @@ diff -ruN kdepim-wizards-4.4.11.1.orig/wizards/CMakeLists.txt kdepim-wizards-4.4
- target_link_libraries(sloxwizard ${QT_QT3SUPPORT_LIBRARY} ${KDE4_KDECORE_LIBS} kcal_slox kabc_slox ${KDEPIMLIBS_KCAL_LIBS} ${KDEPIMLIBS_KABC_LIBS} kdepim )
+ target_link_libraries(sloxwizard ${QT_QTGUI_LIBRARY} ${QT_QT3SUPPORT_LIBRARY} ${KDE4_KDECORE_LIBS} kcal_slox kabc_slox ${KDEPIMLIBS_KCAL_LIBS}
-+ ${KDEPIMLIBS_KABC_LIBS} kdepim )
++ ${KDEPIMLIBS_KABC_LIBS} kdepim kio )
install(TARGETS sloxwizard ${INSTALL_TARGETS_DEFAULT_ARGS})
@@ -34,7 +34,7 @@ diff -ruN kdepim-wizards-4.4.11.1.orig/wizards/CMakeLists.txt kdepim-wizards-4.4
kde4_add_executable(kolabwizard ${kolabwizard_SRCS})
target_link_libraries(kolabwizard
-+ ${QT_QTGUI_LIBRARY}
++ ${QT_QTGUI_LIBRARY} kio
${QT_QT3SUPPORT_LIBRARY}
${KDEPIMLIBS_KCAL_LIBS}
${KDEPIMLIBS_KABC_LIBS}