summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-12-17 00:17:19 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-12-17 00:17:19 +0000
commit5a1cbb49b0531044c16a4eed5b671d4e70221bd4 (patch)
tree67356dae970f81e02ea7df82cefa52d78d25a24c /kde-base/kdepimlibs
parentMinor cleanup to ebuilds (diff)
downloadgentoo-2-5a1cbb49b0531044c16a4eed5b671d4e70221bd4.tar.gz
gentoo-2-5a1cbb49b0531044c16a4eed5b671d4e70221bd4.tar.bz2
gentoo-2-5a1cbb49b0531044c16a4eed5b671d4e70221bd4.zip
Also add 4.7.3 revision of the imap4 protocol regression fix, bug 382411.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kdepimlibs')
-rw-r--r--kde-base/kdepimlibs/ChangeLog8
-rw-r--r--kde-base/kdepimlibs/kdepimlibs-4.7.3-r1.ebuild73
2 files changed, 80 insertions, 1 deletions
diff --git a/kde-base/kdepimlibs/ChangeLog b/kde-base/kdepimlibs/ChangeLog
index 1b51ff6af646..a3b140303417 100644
--- a/kde-base/kdepimlibs/ChangeLog
+++ b/kde-base/kdepimlibs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdepimlibs
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.121 2011/12/15 23:59:19 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.122 2011/12/17 00:17:19 dilfridge Exp $
+
+*kdepimlibs-4.7.3-r1 (17 Dec 2011)
+
+ 17 Dec 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kdepimlibs-4.7.3-r1.ebuild:
+ Also add 4.7.3 revision of the imap4 protocol regression fix, bug 382411.
*kdepimlibs-4.7.4-r1 (15 Dec 2011)
diff --git a/kde-base/kdepimlibs/kdepimlibs-4.7.3-r1.ebuild b/kde-base/kdepimlibs/kdepimlibs-4.7.3-r1.ebuild
new file mode 100644
index 000000000000..b9d182ab4ff6
--- /dev/null
+++ b/kde-base/kdepimlibs/kdepimlibs-4.7.3-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/kdepimlibs-4.7.3-r1.ebuild,v 1.1 2011/12/17 00:17:19 dilfridge Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+CPPUNIT_REQUIRED="optional"
+KDE_SCM="git"
+inherit kde4-base
+
+DESCRIPTION="Common library for KDE PIM apps."
+HOMEPAGE="http://www.kde.org/"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="LGPL-2.1"
+IUSE="debug ldap semantic-desktop"
+
+# some akonadi tests timeout, that probaly needs more work as its ~700 tests
+RESTRICT="test"
+
+COMMON_DEPEND="
+ >=app-crypt/gpgme-1.1.6
+ dev-libs/libgpg-error
+ >=dev-libs/libical-0.43
+ dev-libs/cyrus-sasl
+ $(add_kdebase_dep kdelibs 'semantic-desktop=')
+ semantic-desktop? (
+ >=app-office/akonadi-server-1.5.80
+ media-libs/phonon
+ x11-misc/shared-mime-info
+ )
+ ldap? ( net-nds/openldap )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/boost-1.35.0-r5
+"
+RDEPEND="${COMMON_DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.7.4-size.patch"
+)
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ # Disable hardcoded checks
+ sed -r -e '/find_package\((Akonadi|SharedDesktopOntologies|Soprano|Nepomuk)/{/macro_optional_/!s/find/macro_optional_&/}' \
+ -e '/macro_log_feature\((Akonadi|SHAREDDESKTOPONTOLOGIES|Soprano|Nepomuk)_FOUND/s/ TRUE / FALSE /' \
+ -e '/add_subdirectory\((akonadi|mailtransport)/{/macro_optional_/!s/add/macro_optional_&/}' \
+ -i CMakeLists.txt || die
+ if ! use semantic-desktop; then
+ sed -e '/include(SopranoAddOntology)/s/^/#DISABLED /' \
+ -i CMakeLists.txt || die
+ # More reliable than -DBUILD_akonadi=OFF
+ rm -r akonadi mailtransport || die
+ fi
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build handbook doc)
+ $(cmake-utils_use_with ldap)
+ $(cmake-utils_use_with semantic-desktop Akonadi)
+ $(cmake-utils_use_with semantic-desktop SharedDesktopOntologies)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ # $(cmake-utils_use_with prison)
+ -DWITH_Prison=NO
+ )
+
+ kde4-base_src_configure
+}