summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-03-02 17:00:07 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-03-02 17:00:07 +0000
commite89a47da0a17b1b1f4fcf3d8806632a12bebbaf4 (patch)
treeffa713c639b4c6aa21c86a86ea465291d82310e4 /kde-base/kdepimlibs
parentVersion bump KDE 4.4.1 (diff)
downloadgentoo-2-e89a47da0a17b1b1f4fcf3d8806632a12bebbaf4.tar.gz
gentoo-2-e89a47da0a17b1b1f4fcf3d8806632a12bebbaf4.tar.bz2
gentoo-2-e89a47da0a17b1b1f4fcf3d8806632a12bebbaf4.zip
Version bump KDE 4.4.1
(Portage version: 2.2_rc63/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kdepimlibs')
-rw-r--r--kde-base/kdepimlibs/ChangeLog8
-rw-r--r--kde-base/kdepimlibs/kdepimlibs-4.4.1.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/kde-base/kdepimlibs/ChangeLog b/kde-base/kdepimlibs/ChangeLog
index df4c14c3a6e1..0c590a837e58 100644
--- a/kde-base/kdepimlibs/ChangeLog
+++ b/kde-base/kdepimlibs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdepimlibs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.65 2010/02/24 09:38:18 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/ChangeLog,v 1.66 2010/03/02 17:00:07 tampakrap Exp $
+
+*kdepimlibs-4.4.1 (02 Mar 2010)
+
+ 02 Mar 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +kdepimlibs-4.4.1.ebuild:
+ Version bump
*kdepimlibs-4.4.0-r1 (24 Feb 2010)
diff --git a/kde-base/kdepimlibs/kdepimlibs-4.4.1.ebuild b/kde-base/kdepimlibs/kdepimlibs-4.4.1.ebuild
new file mode 100644
index 000000000000..866776ad859c
--- /dev/null
+++ b/kde-base/kdepimlibs/kdepimlibs-4.4.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepimlibs/kdepimlibs-4.4.1.ebuild,v 1.1 2010/03/02 17:00:07 tampakrap Exp $
+
+EAPI="3"
+
+CPPUNIT_REQUIRED="optional"
+inherit kde4-base
+
+DESCRIPTION="Common library for KDE PIM apps."
+HOMEPAGE="http://www.kde.org/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+LICENSE="LGPL-2.1"
+IUSE="+akonadi debug +handbook ldap"
+
+# some akonadi tests timeout, that probaly needs more work as its ~700 tests
+RESTRICT="test"
+
+DEPEND="
+ >=app-crypt/gpgme-1.1.6
+ >=dev-libs/boost-1.35.0-r5
+ dev-libs/libgpg-error
+ >=dev-libs/libical-0.43
+ dev-libs/cyrus-sasl
+ akonadi? ( >=app-office/akonadi-server-1.3.1 )
+ ldap? ( net-nds/openldap )
+"
+RDEPEND="${DEPEND}"
+
+# libakonadi-kcal moved here from akonadi in 4.3.86
+add_blocker akonadi '<4.3.86'
+# @since 4.3 - libkholidays is in kdepimlibs now
+add_blocker libkholidays
+# @since 4.4 - kontactinterfaces is in kdepimlibs now
+add_blocker kontactinterfaces
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ if ! use akonadi; then
+ sed -e '/find_package(Akonadi/s/^/# DISABLED /' \
+ -e '/macro_log_feature(Akonadi_FOUND/s/TRUE/FALSE/' \
+ -e '/add_subdirectory(akonadi)/s/^/# DISABLED /' \
+ -e '/add_subdirectory(mailtransport)/s/^/# DISABLED /' \
+ -i CMakeLists.txt || die "failed to disable akonadi"
+ fi
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build handbook doc)
+ $(cmake-utils_use_with ldap)
+ )
+
+ kde4-base_src_configure
+}