summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-02-06 23:21:00 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-02-06 23:21:00 +0000
commit4cba78c8fcd56c326a180b231d15e11076652ab8 (patch)
tree2c17ca88ed78d7e028d5db315475f32581f8ef0d /kde-base/kdeplasma-addons
parentVersion bump. (diff)
downloadgentoo-2-4cba78c8fcd56c326a180b231d15e11076652ab8.tar.gz
gentoo-2-4cba78c8fcd56c326a180b231d15e11076652ab8.tar.bz2
gentoo-2-4cba78c8fcd56c326a180b231d15e11076652ab8.zip
Version bump KDE SC 4.12.2
(Portage version: 2.2.8-r1/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'kde-base/kdeplasma-addons')
-rw-r--r--kde-base/kdeplasma-addons/ChangeLog8
-rw-r--r--kde-base/kdeplasma-addons/kdeplasma-addons-4.12.2.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/kde-base/kdeplasma-addons/ChangeLog b/kde-base/kdeplasma-addons/ChangeLog
index 86250356f6cd..37e9a1d87055 100644
--- a/kde-base/kdeplasma-addons/ChangeLog
+++ b/kde-base/kdeplasma-addons/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdeplasma-addons
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/ChangeLog,v 1.232 2014/01/20 14:59:39 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/ChangeLog,v 1.233 2014/02/06 23:20:58 dilfridge Exp $
+
+*kdeplasma-addons-4.12.2 (06 Feb 2014)
+
+ 06 Feb 2014; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kdeplasma-addons-4.12.2.ebuild:
+ Version bump KDE SC 4.12.2
20 Jan 2014; Michael Palimaka <kensington@gentoo.org>
-kdeplasma-addons-4.12.0.ebuild:
diff --git a/kde-base/kdeplasma-addons/kdeplasma-addons-4.12.2.ebuild b/kde-base/kdeplasma-addons/kdeplasma-addons-4.12.2.ebuild
new file mode 100644
index 000000000000..5b96f7aa1d96
--- /dev/null
+++ b/kde-base/kdeplasma-addons/kdeplasma-addons-4.12.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/kdeplasma-addons-4.12.2.ebuild,v 1.1 2014/02/06 23:20:58 dilfridge Exp $
+
+EAPI=5
+
+inherit kde4-base
+
+DESCRIPTION="Extra Plasma applets and engines"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="attica debug desktopglobe exif fcitx ibus json oauth qalculate qwt scim
+semantic-desktop"
+
+RESTRICT=test
+# tests hang
+
+# krunner is only needed to generate dbus interface for lancelot
+COMMON_DEPEND="
+ app-crypt/qca:2
+ app-crypt/qca-ossl:2
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ $(add_kdebase_dep krunner '' 4.11)
+ $(add_kdebase_dep plasma-workspace 'semantic-desktop?' 4.11)
+ x11-misc/shared-mime-info
+ attica? ( dev-libs/libattica )
+ desktopglobe? ( $(add_kdebase_dep marble) )
+ exif? ( $(add_kdebase_dep libkexiv2) )
+ fcitx? ( app-i18n/fcitx[dbus(+)] )
+ ibus? ( app-i18n/ibus )
+ json? ( dev-libs/qjson )
+ oauth? ( dev-libs/qoauth )
+ qalculate? ( sci-libs/libqalculate )
+ qwt? ( x11-libs/qwt:5 )
+ scim? ( app-i18n/scim )
+ semantic-desktop? (
+ $(add_kdebase_dep kdepimlibs)
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-cpp/eigen:2
+"
+RDEPEND="${COMMON_DEPEND}
+"
+
+src_configure() {
+ mycmakeargs=(
+ -DDBUS_INTERFACES_INSTALL_DIR="${EPREFIX}/usr/share/dbus-1/interfaces/"
+ $(cmake-utils_use_with attica LibAttica)
+ $(cmake-utils_use_with desktopglobe Marble)
+ $(cmake-utils_use_with exif Kexiv2)
+ $(cmake-utils_use_build ibus)
+ $(cmake-utils_use_with json QJSON)
+ $(cmake-utils_use_with oauth QtOAuth)
+ $(cmake-utils_use_with qalculate)
+ $(cmake-utils_use_with qwt)
+ $(cmake-utils_use_build scim)
+ $(cmake-utils_use_with semantic-desktop KdepimLibs)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ )
+
+ kde4-base_src_configure
+}