summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-10-19 22:47:05 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-10-19 22:47:05 +0000
commit723976c60cb40b693b3af24931152025d65e8e8a (patch)
treeb404b2d76488d95a1c656634c94072a9922a18e2 /kde-base/kdeutils
parentremove qmail-mysql, #20899 (diff)
downloadgentoo-2-723976c60cb40b693b3af24931152025d65e8e8a.tar.gz
gentoo-2-723976c60cb40b693b3af24931152025d65e8e8a.tar.bz2
gentoo-2-723976c60cb40b693b3af24931152025d65e8e8a.zip
Bump to KDE 3.5.8.
(Portage version: 2.1.3.15)
Diffstat (limited to 'kde-base/kdeutils')
-rw-r--r--kde-base/kdeutils/ChangeLog8
-rw-r--r--kde-base/kdeutils/files/digest-kdeutils-3.5.86
-rw-r--r--kde-base/kdeutils/kdeutils-3.5.8.ebuild57
3 files changed, 70 insertions, 1 deletions
diff --git a/kde-base/kdeutils/ChangeLog b/kde-base/kdeutils/ChangeLog
index 428fce2fc704..f8f1c6a4514b 100644
--- a/kde-base/kdeutils/ChangeLog
+++ b/kde-base/kdeutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdeutils
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeutils/ChangeLog,v 1.213 2007/08/17 08:57:02 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeutils/ChangeLog,v 1.214 2007/10/19 22:47:05 philantrop Exp $
+
+*kdeutils-3.5.8 (19 Oct 2007)
+
+ 19 Oct 2007; Wulf C. Krueger <philantrop@gentoo.org>
+ +kdeutils-3.5.8.ebuild:
+ Bump to KDE 3.5.8.
*kdeutils-3.5.7-r1 (17 Aug 2007)
diff --git a/kde-base/kdeutils/files/digest-kdeutils-3.5.8 b/kde-base/kdeutils/files/digest-kdeutils-3.5.8
new file mode 100644
index 000000000000..d5ce5a414504
--- /dev/null
+++ b/kde-base/kdeutils/files/digest-kdeutils-3.5.8
@@ -0,0 +1,6 @@
+MD5 4a5500af2f0170c9f74501093d5393ad kdeutils-3.5-patchset-02.tar.bz2 3019
+RMD160 b4598488995ed7dc7a86349cd68da426e2238773 kdeutils-3.5-patchset-02.tar.bz2 3019
+SHA256 54ddfbec990e3bff3139abf42755be24a450a8969eb77d41a5b0da4dc72580d6 kdeutils-3.5-patchset-02.tar.bz2 3019
+MD5 d1a0fcc83f35428a76cf7523a04ba19c kdeutils-3.5.8.tar.bz2 3059172
+RMD160 94267b9c08339c7310d65106110c9b9ef133d6f8 kdeutils-3.5.8.tar.bz2 3059172
+SHA256 7dcbe3361cc53f9dac4c1bf6f45952d3d2518bec56cd8c07b8e07b4c4f12d0ac kdeutils-3.5.8.tar.bz2 3059172
diff --git a/kde-base/kdeutils/kdeutils-3.5.8.ebuild b/kde-base/kdeutils/kdeutils-3.5.8.ebuild
new file mode 100644
index 000000000000..36694a314439
--- /dev/null
+++ b/kde-base/kdeutils/kdeutils-3.5.8.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeutils/kdeutils-3.5.8.ebuild,v 1.1 2007/10/19 22:47:05 philantrop Exp $
+
+inherit kde-dist eutils
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdeutils-3.5-patchset-02.tar.bz2"
+
+DESCRIPTION="KDE utilities."
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="crypt kdehiddenvisibility pbbuttonsd snmp xscreensaver"
+
+BOTH_DEPEND="~kde-base/kdebase-${PV}
+ snmp? ( net-analyzer/net-snmp )
+ pbbuttonsd? ( app-laptop/pbbuttonsd )
+ dev-lang/python
+ dev-libs/gmp
+ x11-libs/libXtst"
+
+RDEPEND="${BOTH_DEPEND}
+ crypt? ( app-crypt/gnupg )"
+
+DEPEND="${BOTH_DEPEND}
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ x11-libs/libX11
+ x11-proto/xproto
+ virtual/os-headers"
+
+PATCHES="${FILESDIR}/superkaramba-3.5.7-network_sensor.patch
+ ${FILESDIR}/klaptopdaemon-3.5.7-has_acpi_sleep.patch"
+EPATCH_EXCLUDE="klaptopdaemon-3.5-suspend2+xsession-errors.diff
+ klaptopdaemon-3.5-lock-and-hibernate.diff"
+
+src_unpack() {
+ kde_src_unpack
+
+ # Fix some desktop files
+ sed -i -e "s:Hidden=true:Hidden=false:" "${S}/ksim/ksim.desktop" \
+ || die "sed (ksim) failed"
+ sed -i -e "s:\(^Type=\)Service:\1Application:" "${S}/kdelirc/irkick/irkick.desktop" \
+ || die "sed (irkick) failed"
+ sed -i -e "s:\(^Init=.*\):X-\1:" "${S}/klaptopdaemon/applnk/laptop.desktop" \
+ || die "sed (laptop) failed"
+}
+
+src_compile() {
+ local myconf="$(use_with snmp)
+ $(use_with pbbuttonsd powerbook)
+ $(use_with xscreensaver)
+ --without-xmms"
+
+ use crypt || export DO_NOT_COMPILE="${DO_NOT_COMPILE} kgpg"
+
+ kde_src_compile
+}