summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-11-20 22:00:10 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-11-20 22:00:10 +0000
commit193eeee3e075db8654335d17c6ebd434bda179a1 (patch)
tree9537c03ee1d8d284f3b6d8df689b18ac4eddc4ba /kde-base/kicker
parentCorrect path to unpacked sources (bug #247551). (diff)
downloadgentoo-2-193eeee3e075db8654335d17c6ebd434bda179a1.tar.gz
gentoo-2-193eeee3e075db8654335d17c6ebd434bda179a1.tar.bz2
gentoo-2-193eeee3e075db8654335d17c6ebd434bda179a1.zip
Fix bug 245541.
(Portage version: 2.2_rc14/cvs/Linux 2.6.28-rc4 x86_64)
Diffstat (limited to 'kde-base/kicker')
-rw-r--r--kde-base/kicker/ChangeLog8
-rw-r--r--kde-base/kicker/files/kicker-3.5.10-graphics-glitch.patch13
-rw-r--r--kde-base/kicker/kicker-3.5.10-r1.ebuild33
3 files changed, 53 insertions, 1 deletions
diff --git a/kde-base/kicker/ChangeLog b/kde-base/kicker/ChangeLog
index 84736a4fcdad..d896b6881473 100644
--- a/kde-base/kicker/ChangeLog
+++ b/kde-base/kicker/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kicker
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kicker/ChangeLog,v 1.100 2008/09/13 23:58:41 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kicker/ChangeLog,v 1.101 2008/11/20 22:00:10 loki_val Exp $
+
+*kicker-3.5.10-r1 (20 Nov 2008)
+
+ 20 Nov 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/kicker-3.5.10-graphics-glitch.patch, +kicker-3.5.10-r1.ebuild:
+ Fix bug 245541.
*kicker-3.5.10 (13 Sep 2008)
diff --git a/kde-base/kicker/files/kicker-3.5.10-graphics-glitch.patch b/kde-base/kicker/files/kicker-3.5.10-graphics-glitch.patch
new file mode 100644
index 000000000000..e078d8e2a7cc
--- /dev/null
+++ b/kde-base/kicker/files/kicker-3.5.10-graphics-glitch.patch
@@ -0,0 +1,13 @@
+Bug 245541. Patches imported from upstream SVN introduced a graphics glitch.
+
+
+--- branches/KDE/3.5/kdebase/kicker/taskbar/taskbar.cpp 2008/11/19 00:43:34 886333
++++ branches/KDE/3.5/kdebase/kicker/taskbar/taskbar.cpp 2008/11/19 00:45:13 886334
+@@ -304,6 +304,7 @@
+
+ Panner::resizeEvent(e);
+ reLayoutEventually();
++ setViewportBackground();
+ }
+
+ void TaskBar::add(Task::Ptr task)
diff --git a/kde-base/kicker/kicker-3.5.10-r1.ebuild b/kde-base/kicker/kicker-3.5.10-r1.ebuild
new file mode 100644
index 000000000000..6c9cb74b934b
--- /dev/null
+++ b/kde-base/kicker/kicker-3.5.10-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kicker/kicker-3.5.10-r1.ebuild,v 1.1 2008/11/20 22:00:10 loki_val Exp $
+
+KMNAME=kdebase
+EAPI="1"
+inherit kde-meta eutils
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdebase-3.5-patchset-13.tar.bz2"
+
+DESCRIPTION="Kicker is the KDE application starter panel, also capable of some useful applets and extensions."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kdehiddenvisibility xcomposite"
+
+DEPEND=">=kde-base/libkonq-${PV}:${SLOT}
+ >=kde-base/kdebase-data-${PV}:${SLOT}
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ x11-libs/libXtst
+ xcomposite? ( x11-libs/libXcomposite )"
+
+KMCOPYLIB="libkonq libkonq"
+KMEXTRACTONLY="libkonq
+ kdm/kfrontend/themer/"
+KMCOMPILEONLY="kdmlib/"
+
+PATCHES=( "${FILESDIR}/${P}-graphics-glitch.patch" )
+
+src_compile() {
+ myconf="$myconf $(use_with xcomposite composite)"
+ kde-meta_src_compile
+}