summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-12-03 22:36:09 +0000
committerJohannes Huber <johu@gentoo.org>2013-12-03 22:36:09 +0000
commit318092ea225b3d6ad7192e8ae024a631e482b266 (patch)
tree91df8808be8c8389bc73293ff837135ae83c78e3 /kde-base/kimono
parentUpdate init file /var/run/apcupsd directory > /run/apcupsd (diff)
downloadgentoo-2-318092ea225b3d6ad7192e8ae024a631e482b266.tar.gz
gentoo-2-318092ea225b3d6ad7192e8ae024a631e482b266.tar.bz2
gentoo-2-318092ea225b3d6ad7192e8ae024a631e482b266.zip
Version bump KDE SC 4.11.4
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/kimono')
-rw-r--r--kde-base/kimono/ChangeLog7
-rw-r--r--kde-base/kimono/kimono-4.11.4.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/kde-base/kimono/ChangeLog b/kde-base/kimono/ChangeLog
index 927bd3dd8868..ba723558b349 100644
--- a/kde-base/kimono/ChangeLog
+++ b/kde-base/kimono/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kimono
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kimono/ChangeLog,v 1.90 2013/11/05 22:22:41 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kimono/ChangeLog,v 1.91 2013/12/03 22:35:31 johu Exp $
+
+*kimono-4.11.4 (03 Dec 2013)
+
+ 03 Dec 2013; Johannes Huber <johu@gentoo.org> +kimono-4.11.4.ebuild:
+ Version bump KDE SC 4.11.4
*kimono-4.11.3 (05 Nov 2013)
diff --git a/kde-base/kimono/kimono-4.11.4.ebuild b/kde-base/kimono/kimono-4.11.4.ebuild
new file mode 100644
index 000000000000..d24502c298f2
--- /dev/null
+++ b/kde-base/kimono/kimono-4.11.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kimono/kimono-4.11.4.ebuild,v 1.1 2013/12/03 22:35:31 johu Exp $
+
+EAPI=5
+
+inherit mono-env kde4-base
+
+DESCRIPTION="C# bindings for KDE"
+KEYWORDS=" ~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="akonadi debug plasma semantic-desktop"
+
+DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep qyoto 'webkit')
+ $(add_kdebase_dep smokeqt)
+ $(add_kdebase_dep smokekde 'semantic-desktop?')
+ plasma? ( $(add_kdebase_dep smokeqt 'webkit') )
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ mono-env_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ sed -i "/add_subdirectory( examples )/ s:^:#:" plasma/CMakeLists.txt
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_disable plasma)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ -DWITH_Soprano=OFF
+ )
+ kde4-base_src_configure
+}