summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-10-06 18:11:13 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-10-06 18:11:13 +0000
commit9105207da0f7d5c2674846f47a99baf903903d3b (patch)
treed50899ea0ccfdaee04b35bfc24e0bc89b3d4c12a /kde-base/kimono
parentInitial import. New dependency for forthcoming Rails 3.1 release. (diff)
downloadgentoo-2-9105207da0f7d5c2674846f47a99baf903903d3b.tar.gz
gentoo-2-9105207da0f7d5c2674846f47a99baf903903d3b.tar.bz2
gentoo-2-9105207da0f7d5c2674846f47a99baf903903d3b.zip
[kde-base] KDE SC 4.7.2
(Portage version: 2.2.0_alpha61/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kimono')
-rw-r--r--kde-base/kimono/ChangeLog7
-rw-r--r--kde-base/kimono/kimono-4.7.2.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/kde-base/kimono/ChangeLog b/kde-base/kimono/ChangeLog
index 4d36345aee87..ab4af1282680 100644
--- a/kde-base/kimono/ChangeLog
+++ b/kde-base/kimono/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kimono
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kimono/ChangeLog,v 1.3 2011/09/07 20:13:45 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kimono/ChangeLog,v 1.4 2011/10/06 18:10:51 alexxy Exp $
+
+*kimono-4.7.2 (06 Oct 2011)
+
+ 06 Oct 2011; Alexey Shvetsov <alexxy@gentoo.org> +kimono-4.7.2.ebuild:
+ Version bump KDE SC 4.7.2
*kimono-4.7.1 (07 Sep 2011)
diff --git a/kde-base/kimono/kimono-4.7.2.ebuild b/kde-base/kimono/kimono-4.7.2.ebuild
new file mode 100644
index 000000000000..05e36ca3fb17
--- /dev/null
+++ b/kde-base/kimono/kimono-4.7.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kimono/kimono-4.7.2.ebuild,v 1.1 2011/10/06 18:10:51 alexxy Exp $
+
+EAPI=4
+
+KDE_SCM="git"
+inherit kde4-base mono
+
+DESCRIPTION="C# bindings for KDE"
+KEYWORDS="~amd64 ~x86"
+IUSE="akonadi debug plasma semantic-desktop"
+
+DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep qyoto 'webkit')
+ $(add_kdebase_dep smokeqt)
+ $(add_kdebase_dep smokekde 'akonadi?,semantic-desktop=')
+ plasma? ( $(add_kdebase_dep smokeqt 'webkit') )
+ semantic-desktop? ( >=dev-libs/soprano-2.6.51[clucene] )
+"
+RDEPEND="${DEPEND}"
+
+# Split from kdebindings-csharp in 4.7
+add_blocker kdebindings-csharp
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ sed -i "/add_subdirectory( examples )/ s:^:#:" plasma/CMakeLists.txt
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_disable plasma)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ )
+ kde4-base_src_configure
+}