summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-08-07 11:05:11 +0000
committerJohannes Huber <johu@gentoo.org>2012-08-07 11:05:11 +0000
commitc0c69592703d4bcb645ca889af281f6ad98e2d80 (patch)
treeb93e1ef3a3bc78eb187a28815fdcec5e0227568f /kde-base/kimono
parentStable arm, bug #428900 (diff)
downloadgentoo-2-c0c69592703d4bcb645ca889af281f6ad98e2d80.tar.gz
gentoo-2-c0c69592703d4bcb645ca889af281f6ad98e2d80.tar.bz2
gentoo-2-c0c69592703d4bcb645ca889af281f6ad98e2d80.zip
Version bump KDE SC 4.8.5
(Portage version: 2.2.0_alpha120/cvs/Linux i686)
Diffstat (limited to 'kde-base/kimono')
-rw-r--r--kde-base/kimono/ChangeLog7
-rw-r--r--kde-base/kimono/kimono-4.8.5.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/kde-base/kimono/ChangeLog b/kde-base/kimono/ChangeLog
index 853539cdef9e..43034aee6f5f 100644
--- a/kde-base/kimono/ChangeLog
+++ b/kde-base/kimono/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kimono
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kimono/ChangeLog,v 1.32 2012/08/01 22:16:58 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kimono/ChangeLog,v 1.33 2012/08/07 11:04:32 johu Exp $
+
+*kimono-4.8.5 (07 Aug 2012)
+
+ 07 Aug 2012; Johannes Huber <johu@gentoo.org> +kimono-4.8.5.ebuild:
+ Version bump KDE SC 4.8.5
*kimono-4.9.0 (01 Aug 2012)
diff --git a/kde-base/kimono/kimono-4.8.5.ebuild b/kde-base/kimono/kimono-4.8.5.ebuild
new file mode 100644
index 000000000000..76040404d8fd
--- /dev/null
+++ b/kde-base/kimono/kimono-4.8.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kimono/kimono-4.8.5.ebuild,v 1.1 2012/08/07 11:04:32 johu Exp $
+
+EAPI=4
+
+KDE_SCM="git"
+inherit kde4-base mono
+
+DESCRIPTION="C# bindings for KDE"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="akonadi debug plasma semantic-desktop"
+
+DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep qyoto 'webkit')
+ $(add_kdebase_dep smokeqt)
+ $(add_kdebase_dep smokekde 'semantic-desktop=')
+ plasma? ( $(add_kdebase_dep smokeqt 'webkit') )
+ semantic-desktop? ( >=dev-libs/soprano-2.7.6[clucene] )
+"
+RDEPEND="${DEPEND}"
+
+# Split from kdebindings-csharp in 4.7
+add_blocker kdebindings-csharp
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ sed -i "/add_subdirectory( examples )/ s:^:#:" plasma/CMakeLists.txt
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_disable plasma)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ )
+ kde4-base_src_configure
+}