summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2011-06-09 22:12:55 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2011-06-09 22:12:55 +0000
commit2f7db8725afe1a4fe42b507b7b7c6937cdb6d2b6 (patch)
tree3a8e5d6b3fda58fa0c1a3b43e236e0bdf5551fab /kde-base/kmail
parentAdded some patches for compiling on gcc-4.6, fixing fltk, and building packag... (diff)
downloadgentoo-2-2f7db8725afe1a4fe42b507b7b7c6937cdb6d2b6.tar.gz
gentoo-2-2f7db8725afe1a4fe42b507b7b7c6937cdb6d2b6.tar.bz2
gentoo-2-2f7db8725afe1a4fe42b507b7b7c6937cdb6d2b6.zip
Version bump KDEPIM 4.6.0
(Portage version: 2.2.0_alpha38/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kmail')
-rw-r--r--kde-base/kmail/ChangeLog7
-rw-r--r--kde-base/kmail/kmail-4.6.0.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/kde-base/kmail/ChangeLog b/kde-base/kmail/ChangeLog
index f5cb653c421b..9dc76854dd57 100644
--- a/kde-base/kmail/ChangeLog
+++ b/kde-base/kmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kmail
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.250 2011/06/02 22:05:14 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.251 2011/06/09 22:12:53 tampakrap Exp $
+
+*kmail-4.6.0 (09 Jun 2011)
+
+ 09 Jun 2011; Theo Chatzimichos <tampakrap@gentoo.org> +kmail-4.6.0.ebuild:
+ Version bump KDEPIM 4.6.0
02 Jun 2011; Andreas K. Huettel <dilfridge@gentoo.org> -kmail-4.4.9.ebuild,
-kmail-4.4.10.ebuild, -kmail-4.4.10-r1.ebuild:
diff --git a/kde-base/kmail/kmail-4.6.0.ebuild b/kde-base/kmail/kmail-4.6.0.ebuild
new file mode 100644
index 000000000000..b7f639be80d1
--- /dev/null
+++ b/kde-base/kmail/kmail-4.6.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/kmail-4.6.0.ebuild,v 1.1 2011/06/09 22:12:53 tampakrap Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kdepim"
+KDE_SCM="git"
+VIRTUALX_REQUIRED=test
+inherit kde4-meta
+
+DESCRIPTION="KMail is the email component of Kontact, the integrated personal information manager of KDE."
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop')
+ $(add_kdebase_dep korganizer)
+ $(add_kdebase_dep kdepim-common-libs)
+"
+RDEPEND="${DEPEND}"
+
+add_blocker kmailcvt
+add_blocker libksieve
+add_blocker mimelib
+
+KMEXTRACTONLY="
+ akonadi_next/
+ calendarsupport/
+ korganizer/
+ kresources/
+ libkleo/
+ libkpgp/
+ libkdepimdbusinterfaces/
+ kdgantt2/
+"
+KMCOMPILEONLY="
+ messagecomposer/
+ messagecore/
+ messagelist/
+ messageviewer/
+ templateparser/
+ incidenceeditor-ng/
+ calendarsupport/
+"
+KMEXTRA="
+ kmailcvt/
+ ksendemail/
+ libksieve/
+ mailcommon/
+ ontologies/
+"
+
+KMLOADLIBS="kdepim-common-libs"
+
+src_configure() {
+ # Bug 308903
+ use ppc64 && append-flags -mminimal-toc
+
+ kde4-meta_src_configure
+}
+
+src_compile() {
+ kde4-meta_src_compile kmail_xml
+ kde4-meta_src_compile
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kdepim-kresources:${SLOT}; then
+ echo
+ elog "For groupware functionality, please install kde-base/kdepim-kresources:${SLOT}"
+ echo
+ fi
+ if ! has_version kde-base/kleopatra:${SLOT}; then
+ echo
+ elog "For certificate management and the gnupg log viewer, please install kde-base/kleopatra:${SLOT}"
+ echo
+ fi
+}