summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-08-04 00:42:32 +0000
committerAlex Alexander <wired@gentoo.org>2009-08-04 00:42:32 +0000
commitd89bb48b60d4023eb55eaf69bb902f566461148a (patch)
treef444c778f3797238a89b16f6d2cee40ab0ba4a78 /kde-base/kmail
parentVersion bump KDE 4.3.0 (diff)
downloadgentoo-2-d89bb48b60d4023eb55eaf69bb902f566461148a.tar.gz
gentoo-2-d89bb48b60d4023eb55eaf69bb902f566461148a.tar.bz2
gentoo-2-d89bb48b60d4023eb55eaf69bb902f566461148a.zip
Version bump KDE 4.3.0
(Portage version: 2.2_rc33/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kmail')
-rw-r--r--kde-base/kmail/ChangeLog7
-rw-r--r--kde-base/kmail/kmail-4.3.0.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/kde-base/kmail/ChangeLog b/kde-base/kmail/ChangeLog
index c6bb90f70e58..8362dac46951 100644
--- a/kde-base/kmail/ChangeLog
+++ b/kde-base/kmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kmail
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.173 2009/07/12 13:20:43 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.174 2009/08/04 00:42:32 wired Exp $
+
+*kmail-4.3.0 (04 Aug 2009)
+
+ 04 Aug 2009; Alex Alexander <wired@gentoo.org> +kmail-4.3.0.ebuild:
+ Version bump
12 Jul 2009; Raúl Porcel <armin76@gentoo.org> kmail-3.5.10.ebuild:
alpha/ia64/sparc stable wrt #271889
diff --git a/kde-base/kmail/kmail-4.3.0.ebuild b/kde-base/kmail/kmail-4.3.0.ebuild
new file mode 100644
index 000000000000..91088a479c8b
--- /dev/null
+++ b/kde-base/kmail/kmail-4.3.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/kmail-4.3.0.ebuild,v 1.1 2009/08/04 00:42:32 wired Exp $
+
+EAPI="2"
+
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="KMail is the email component of Kontact, the integrated personal information manager of KDE."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug +handbook +semantic-desktop"
+
+DEPEND="
+ >=kde-base/kdelibs-${PV}:${SLOT}[kdeprefix=,semantic-desktop?]
+ >=kde-base/libkdepim-${PV}:${SLOT}[kdeprefix=]
+ >=kde-base/libkleo-${PV}:${SLOT}[kdeprefix=]
+ >=kde-base/libkpgp-${PV}:${SLOT}[kdeprefix=]
+ >=kde-base/libksieve-${PV}:${SLOT}[kdeprefix=]
+ >=kde-base/mimelib-${PV}:${SLOT}[kdeprefix=]
+"
+RDEPEND="${DEPEND}
+ >=kde-base/kmailcvt-${PV}:${SLOT}[kdeprefix=]
+ semantic-desktop? ( >=kde-base/nepomuk-${PV}:${SLOT}[kdeprefix=] )
+"
+
+KMEXTRACTONLY="
+ kaddressbook/org.kde.KAddressbook.Core.xml
+ korganizer/org.kde.Korganizer.Calendar.xml
+ libkleo
+ libkpgp
+ libksieve
+ mimelib
+"
+KMEXTRA="
+ plugins/kmail/
+"
+KMLOADLIBS="libkdepim"
+
+PATCHES=( "${FILESDIR}/${PN}-4.1.72-fix.patch" )
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with semantic-desktop Nepomuk)"
+
+ kde4-meta_src_configure
+}
+
+src_compile() {
+ # Bug #276377: kontact/ can build before kmail/, causing a dependency not to be built
+ # Upstream as KDE Bug #198807
+ # (setting via MAKEOPTS to trigger a repoman warning)
+ MAKEOPTS="${MAKEOPTS} -j1"
+ kde4-meta_src_compile
+}