summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-18 16:57:05 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-18 16:57:05 +0000
commiteee6d46e88874da2a9ec68cdfe4321bcc818a6ca (patch)
treea8b91b9c37a257ed014a0be04fcccbdd4d868336 /kde-base/kmail
parentVersion bump, p.masked though for ABI change without soname change (security ... (diff)
downloadgentoo-2-eee6d46e88874da2a9ec68cdfe4321bcc818a6ca.tar.gz
gentoo-2-eee6d46e88874da2a9ec68cdfe4321bcc818a6ca.tar.bz2
gentoo-2-eee6d46e88874da2a9ec68cdfe4321bcc818a6ca.zip
Allow replying to e-mails in "Sent" folder (bug #270099).
(Portage version: 13623-svn/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kmail')
-rw-r--r--kde-base/kmail/ChangeLog9
-rw-r--r--kde-base/kmail/files/4.2.0-kwallet.patch21
-rw-r--r--kde-base/kmail/files/kmail-4.2.3-allow_replying_to_messages_in_sent_folder.patch41
-rw-r--r--kde-base/kmail/kmail-4.2.3-r1.ebuild49
4 files changed, 98 insertions, 22 deletions
diff --git a/kde-base/kmail/ChangeLog b/kde-base/kmail/ChangeLog
index 6cccd1755cd9..1088efd0e120 100644
--- a/kde-base/kmail/ChangeLog
+++ b/kde-base/kmail/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/kmail
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.161 2009/05/06 23:35:24 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.162 2009/05/18 16:57:04 arfrever Exp $
+
+*kmail-4.2.3-r1 (18 May 2009)
+
+ 18 May 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -files/4.2.0-kwallet.patch, +kmail-4.2.3-r1.ebuild,
+ +files/kmail-4.2.3-allow_replying_to_messages_in_sent_folder.patch:
+ Allow replying to e-mails in "Sent" folder (bug #270099).
*kmail-4.2.3 (06 May 2009)
diff --git a/kde-base/kmail/files/4.2.0-kwallet.patch b/kde-base/kmail/files/4.2.0-kwallet.patch
deleted file mode 100644
index 2f5c93898f5b..000000000000
--- a/kde-base/kmail/files/4.2.0-kwallet.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- kmail/networkaccount.cpp 2008-05-21 10:33:40.000000000 +0200
-+++ ../networkaccount.cpp 2009-01-30 12:28:32.032158332 +0100
-@@ -205,16 +205,16 @@
-
- //If the password should be written to the wallet, do that
- if ( !mStorePasswdInConfig ) {
-- Wallet *wallet = kmkernel->wallet();
-
- //If the password is dirty, try to store it in the wallet
- if ( mPasswdDirty ) {
-+ Wallet *wallet = kmkernel->wallet();
- if ( wallet && wallet->writePassword( "account-" + QString::number(mId), passwd() ) == 0 )
- passwdStored = true;
- }
-
- //If the password isn't dirty, it is already stored in the wallet.
-- else if ( wallet )
-+ else
- passwdStored = true;
-
- //If the password is stored in the wallet, it isn't dirty or stored in the config
diff --git a/kde-base/kmail/files/kmail-4.2.3-allow_replying_to_messages_in_sent_folder.patch b/kde-base/kmail/files/kmail-4.2.3-allow_replying_to_messages_in_sent_folder.patch
new file mode 100644
index 000000000000..4b67e92a591d
--- /dev/null
+++ b/kde-base/kmail/files/kmail-4.2.3-allow_replying_to_messages_in_sent_folder.patch
@@ -0,0 +1,41 @@
+https://bugs.gentoo.org/show_bug.cgi?id=270099
+https://bugs.kde.org/show_bug.cgi?id=189464
+http://websvn.kde.org/?view=rev&revision=965008
+
+--- kmail/kmmainwidget.cpp
++++ kmail/kmmainwidget.cpp
+@@ -3450,9 +3450,7 @@
+ menu->addAction( mUseAction );
+ } else {
+
+- if ( !mFolder->isSent() ) {
+- menu->addAction( mMsgActions->replyMenu() );
+- }
++ menu->addAction( mMsgActions->replyMenu() );
+ menu->addAction( mForwardActionMenu );
+ }
+ menu->addAction(editAction());
+--- kmail/messageactions.cpp
++++ kmail/messageactions.cpp
+@@ -170,8 +170,7 @@
+ {
+ bool singleMsg = (mCurrentMessage != 0);
+ if ( mCurrentMessage && mCurrentMessage->parent() ) {
+- if ( mCurrentMessage->parent()->isSent() ||
+- mCurrentMessage->parent()->isTemplates())
++ if ( mCurrentMessage->parent()->isTemplates() )
+ singleMsg = false;
+ }
+ const bool multiVisible = mVisibleSernums.count() > 0 || mCurrentMessage;
+--- kmail/messagelistview/widget.cpp
++++ kmail/messagelistview/widget.cpp
+@@ -618,8 +618,7 @@
+ menu.addAction( mMainWidget->useAction() );
+ } else {
+ // show most used actions
+- if( !folder()->isSent() )
+- menu.addAction( mMainWidget->messageActions()->replyMenu() );
++ menu.addAction( mMainWidget->messageActions()->replyMenu() );
+ menu.addAction( mMainWidget->forwardMenu() );
+ if( mMainWidget->sendAgainAction()->isEnabled() )
+ menu.addAction( mMainWidget->sendAgainAction() );
diff --git a/kde-base/kmail/kmail-4.2.3-r1.ebuild b/kde-base/kmail/kmail-4.2.3-r1.ebuild
new file mode 100644
index 000000000000..8abaa9f4169a
--- /dev/null
+++ b/kde-base/kmail/kmail-4.2.3-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/kmail-4.2.3-r1.ebuild,v 1.1 2009/05/18 16:57:04 arfrever Exp $
+
+EAPI="2"
+
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="KMail is the email component of Kontact, the integrated personal information manager of KDE."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug doc +semantic-desktop"
+
+DEPEND="
+ >=kde-base/kdelibs-${PV}:${SLOT}[kdeprefix=,semantic-desktop?]
+ >=kde-base/libkdepim-${PV}:${SLOT}[kdeprefix=]
+ >=kde-base/libkleo-${PV}:${SLOT}[kdeprefix=]
+ >=kde-base/libkpgp-${PV}:${SLOT}[kdeprefix=]
+ >=kde-base/libksieve-${PV}:${SLOT}[kdeprefix=]
+ >=kde-base/mimelib-${PV}:${SLOT}[kdeprefix=]
+"
+RDEPEND="${DEPEND}
+ >=kde-base/kmailcvt-${PV}:${SLOT}[kdeprefix=]
+ semantic-desktop? ( >=kde-base/nepomuk-${PV}:${SLOT}[kdeprefix=] )
+"
+
+KMEXTRACTONLY="
+ kaddressbook/org.kde.KAddressbook.Core.xml
+ korganizer/org.kde.Korganizer.Calendar.xml
+ libkleo
+ libkpgp
+ mimelib
+"
+KMEXTRA="
+ plugins/kmail/
+"
+KMLOADLIBS="libkdepim"
+
+PATCHES=( "${FILESDIR}/${PN}-4.1.72-fix.patch"
+ "${FILESDIR}/${P}-allow_replying_to_messages_in_sent_folder.patch" )
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with semantic-desktop Nepomuk)"
+
+ MAKEOPTS="${MAKEOPTS} -j1"
+
+ kde4-meta_src_configure
+}