summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-04-01 18:10:05 +0000
committerJohannes Huber <johu@gentoo.org>2014-04-01 18:10:05 +0000
commitb0c8c41397c5a2e84e4a1126a6ac202205014ee7 (patch)
tree1c82eef4e9829216eda4b7a814332e668a7afcea /kde-base/konq-plugins
parentVersion bump to snapshot version since there are a lot of fixes and upstream ... (diff)
downloadgentoo-2-b0c8c41397c5a2e84e4a1126a6ac202205014ee7.tar.gz
gentoo-2-b0c8c41397c5a2e84e4a1126a6ac202205014ee7.tar.bz2
gentoo-2-b0c8c41397c5a2e84e4a1126a6ac202205014ee7.zip
Version bump KDE SC 4.12.4
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/konq-plugins')
-rw-r--r--kde-base/konq-plugins/ChangeLog7
-rw-r--r--kde-base/konq-plugins/konq-plugins-4.12.4.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/kde-base/konq-plugins/ChangeLog b/kde-base/konq-plugins/ChangeLog
index 77a2737c4f42..60fea0cfb2ae 100644
--- a/kde-base/konq-plugins/ChangeLog
+++ b/kde-base/konq-plugins/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/konq-plugins
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/konq-plugins/ChangeLog,v 1.233 2014/03/11 13:06:44 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/konq-plugins/ChangeLog,v 1.234 2014/04/01 18:09:53 johu Exp $
+
+*konq-plugins-4.12.4 (01 Apr 2014)
+
+ 01 Apr 2014; Johannes Huber <johu@gentoo.org> +konq-plugins-4.12.4.ebuild:
+ Version bump KDE SC 4.12.4
11 Mar 2014; Johannes Huber <johu@gentoo.org> -konq-plugins-4.12.2.ebuild:
Remove KDE SC 4.12.2
diff --git a/kde-base/konq-plugins/konq-plugins-4.12.4.ebuild b/kde-base/konq-plugins/konq-plugins-4.12.4.ebuild
new file mode 100644
index 000000000000..9cca33fa5550
--- /dev/null
+++ b/kde-base/konq-plugins/konq-plugins-4.12.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/konq-plugins/konq-plugins-4.12.4.ebuild,v 1.1 2014/04/01 18:09:53 johu Exp $
+
+EAPI=5
+
+KMNAME="kde-baseapps"
+inherit kde4-meta
+
+DESCRIPTION="Various plugins for konqueror"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug tidy"
+
+DEPEND="
+ $(add_kdebase_dep libkonq)
+ tidy? ( app-text/htmltidy )
+"
+RDEPEND="${DEPEND}
+ !kde-misc/konq-plugins
+ $(add_kdebase_dep kcmshell)
+ $(add_kdebase_dep konqueror)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DKdeWebKit=OFF
+ -DWebKitPart=OFF
+ $(cmake-utils_use_with tidy LibTidy)
+ )
+
+ kde4-meta_src_configure
+}