summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2010-12-14 22:32:50 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2010-12-14 22:32:50 +0000
commit5b8de1070c1b966caa07075c4d6ea518d287ce37 (patch)
tree096ef11dae1b5c021323c38bd2a0a86328b8560a /kde-base/kopete
parentInitial version. (diff)
downloadgentoo-2-5b8de1070c1b966caa07075c4d6ea518d287ce37.tar.gz
gentoo-2-5b8de1070c1b966caa07075c4d6ea518d287ce37.tar.bz2
gentoo-2-5b8de1070c1b966caa07075c4d6ea518d287ce37.zip
Added upstream patch to fix ICQ server name (bug 346119). Version bump straight to stable.
(Portage version: 2.1.9.25/cvs/Linux i686, RepoMan options: --force)
Diffstat (limited to 'kde-base/kopete')
-rw-r--r--kde-base/kopete/ChangeLog9
-rw-r--r--kde-base/kopete/files/kopete-4.4.5-server.patch121
-rw-r--r--kde-base/kopete/kopete-4.4.5-r2.ebuild161
3 files changed, 290 insertions, 1 deletions
diff --git a/kde-base/kopete/ChangeLog b/kde-base/kopete/ChangeLog
index cc7b3df62161..63fd44f0cdc1 100644
--- a/kde-base/kopete/ChangeLog
+++ b/kde-base/kopete/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/kopete
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.269 2010/12/02 21:17:58 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.270 2010/12/14 22:32:50 dilfridge Exp $
+
+*kopete-4.4.5-r2 (14 Dec 2010)
+
+ 14 Dec 2010; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kopete-4.4.5-r2.ebuild, +files/kopete-4.4.5-server.patch:
+ Added upstream patch to fix ICQ server name (bug 346119). Version bump
+ straight to stable.
*kopete-4.5.4 (02 Dec 2010)
diff --git a/kde-base/kopete/files/kopete-4.4.5-server.patch b/kde-base/kopete/files/kopete-4.4.5-server.patch
new file mode 100644
index 000000000000..4eec67f78630
--- /dev/null
+++ b/kde-base/kopete/files/kopete-4.4.5-server.patch
@@ -0,0 +1,121 @@
+Index: kopete/protocols/oscar/icq/icqaccount.cpp
+===================================================================
+--- kopete/protocols/oscar/icq/icqaccount.cpp (Revision 1197798)
++++ kopete/protocols/oscar/icq/icqaccount.cpp (Revision 1197799)
+@@ -136,7 +136,7 @@
+ // Create actions
+ mEditInfoAction = new KAction( KIcon("user-properties"), i18n( "Edit User Info..." ), this );
+ QObject::connect( mEditInfoAction, SIGNAL(triggered(bool)), this, SLOT(slotUserInfo()) );
+-
++
+ mActionInvisible = new KToggleAction( i18n( "In&visible" ), this );
+ QObject::connect( mActionInvisible, SIGNAL(triggered(bool)), this, SLOT(slotToggleInvisible()) );
+
+@@ -188,7 +188,7 @@
+ */
+
+ KActionMenu *xtrazStatusMenu = new KActionMenu( i18n( "Set Xtraz Status" ), actionMenu );
+-
++
+ KAction* xtrazStatusSetAction = new KAction( i18n( "Set Status..." ), xtrazStatusMenu );
+ QObject::connect( xtrazStatusSetAction, SIGNAL(triggered(bool)), this, SLOT(setXtrazStatus()) );
+ xtrazStatusMenu->addAction( xtrazStatusSetAction );
+@@ -236,7 +236,7 @@
+ myself()->setOnlineStatus( protocol()->statusManager()->connectingStatus() );
+ QString icqNumber = accountId();
+ kDebug(14153) << "Logging in as " << icqNumber;
+- QString server = configGroup()->readEntry( "Server", QString::fromLatin1( "login.oscar.aol.com" ) );
++ QString server = configGroup()->readEntry( "Server", QString::fromLatin1( "login.icq.com" ) );
+ uint port = configGroup()->readEntry( "Port", 5190 );
+
+ //set up the settings for the account
+Index: kopete/protocols/oscar/icq/ui/icqeditaccountwidget.cpp
+===================================================================
+--- kopete/protocols/oscar/icq/ui/icqeditaccountwidget.cpp (Revision 1197798)
++++ kopete/protocols/oscar/icq/ui/icqeditaccountwidget.cpp (Revision 1197799)
+@@ -65,7 +65,7 @@
+
+ mProtocol->fillComboFromTable( mAccountSettings->encodingCombo, mProtocol->encodings() );
+
+- //Setup the edtAccountId
++ //Setup the edtAccountId
+ QRegExp rx("[0-9]{9}");
+ QValidator* validator = new QRegExpValidator( rx, this );
+ mAccountSettings->edtAccountId->setValidator(validator);
+@@ -80,9 +80,9 @@
+ mAccountSettings->mPasswordWidget->load(&mAccount->password());
+ mAccountSettings->chkAutoLogin->setChecked(mAccount->excludeConnect());
+
+- QString serverEntry = mAccount->configGroup()->readEntry("Server", "login.oscar.aol.com");
++ QString serverEntry = mAccount->configGroup()->readEntry("Server", "login.icq.com");
+ int portEntry = mAccount->configGroup()->readEntry("Port", 5190);
+- if ( serverEntry != "login.oscar.aol.com" || ( portEntry != 5190) )
++ if ( serverEntry != "login.icq.com" || ( portEntry != 5190) )
+ mAccountSettings->optionOverrideServer->setChecked( true );
+
+ mAccountSettings->edtServerAddress->setText( serverEntry );
+@@ -174,7 +174,7 @@
+ default:
+ encodingId=4;
+ }
+-
++
+ mProtocol->setComboFromTable( mAccountSettings->encodingCombo,
+ mProtocol->encodings(),
+ encodingId );
+@@ -203,13 +203,13 @@
+ {
+ if ( m_visibleEngine )
+ delete m_visibleEngine;
+-
++
+ if ( m_invisibleEngine )
+ delete m_invisibleEngine;
+-
++
+ if ( m_ignoreEngine )
+ delete m_ignoreEngine;
+-
++
+ delete mAccountSettings;
+ }
+
+@@ -254,7 +254,7 @@
+ }
+ else
+ {
+- mAccount->setServerAddress("login.oscar.aol.com");
++ mAccount->setServerAddress("login.icq.com");
+ mAccount->setServerPort(5190);
+ }
+
+@@ -279,17 +279,17 @@
+ {
+ if ( m_visibleEngine )
+ m_visibleEngine->storeChanges();
+-
++
+ if ( m_invisibleEngine )
+ m_invisibleEngine->storeChanges();
+-
++
+ if ( m_ignoreEngine )
+ m_ignoreEngine->storeChanges();
+
+ //Update Oscar settings
+ static_cast<ICQMyselfContact*>( mAccount->myself() )->fetchShortInfo();
+ }
+-
++
+ return mAccount;
+ }
+
+@@ -299,7 +299,7 @@
+ bool bOk;
+ QString userId = mAccountSettings->edtAccountId->text();
+ qulonglong uid = userId.toULongLong( &bOk );
+-
++
+ if( !bOk || uid == 0 || userId.isEmpty() )
+ { KMessageBox::queuedMessageBox(this, KMessageBox::Sorry,
+ i18n("<qt>You must enter a valid ICQ No.</qt>"), i18n("ICQ"));
diff --git a/kde-base/kopete/kopete-4.4.5-r2.ebuild b/kde-base/kopete/kopete-4.4.5-r2.ebuild
new file mode 100644
index 000000000000..ea7e5f2669e1
--- /dev/null
+++ b/kde-base/kopete/kopete-4.4.5-r2.ebuild
@@ -0,0 +1,161 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/kopete-4.4.5-r2.ebuild,v 1.1 2010/12/14 22:32:50 dilfridge Exp $
+
+EAPI="3"
+
+KMNAME="kdenetwork"
+inherit kde4-meta
+
+DESCRIPTION="KDE multi-protocol IM client"
+KEYWORDS="amd64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug +handbook ssl v4l2"
+
+# tests hang, last checked for 4.2.96
+RESTRICT=test
+
+# Available plugins
+#
+# addbookmarks: NO DEPS
+# alias: NO DEPS (disabled upstream)
+# autoreplace: NO DEPS
+# contactnotes: NO DEPS
+# highlight: NO DEPS
+# history: NO DEPS
+# latex: virtual/latex as RDEPEND
+# nowlistening: NO DEPS
+# otr: libotr
+# pipes: NO DEPS
+# privacy: NO DEPS
+# statistics: dev-db/sqlite:3
+# texteffect: NO DEPS
+# translator: NO DEPS
+# urlpicpreview: NO DEPS
+# webpresence: libxml2 libxslt
+# NOTE: By default we enable all plugins that don't have any dependencies
+PLUGINS="+addbookmarks +autoreplace +contactnotes +highlight +history latex
++nowlistening otr +pipes +privacy +statistics +texteffect +translator
++urlpicpreview webpresence"
+
+# Available protocols
+#
+# gadu: net-libs/libgadu @since 4.3
+# groupwise: app-crypt/qca:2
+# irc: NO DEPS, probably will fail so inform user about it
+# jabber: net-dns/libidn app-crypt/qca:2 ENABLED BY DEFAULT NETWORK
+# jingle: media-libs/speex net-libs/ortp DISABLED BY UPSTREAM
+# meanwhile: net-libs/meanwhile
+# msn: libmsn == this is wlm plugin, we disable msn one
+# oscar: NO DEPS
+# qq: NO DEPS
+# telepathy: net-libs/decibel
+# testbed: NO DEPS
+# winpopup: NO DEPS (we're adding samba as RDEPEND so it works)
+# yahoo: NO DEPS
+# zeroconf (bonjour): NO DEPS
+PROTOCOLS="gadu groupwise +jabber jingle meanwhile msn oscar qq skype
+sms testbed winpopup yahoo zeroconf"
+
+# disabled protocols
+# telepathy: net-libs/decibel
+# irc: NO DEPS
+
+IUSE="${IUSE} ${PLUGINS} ${PROTOCOLS}"
+
+COMMONDEPEND="
+ dev-libs/libpcre
+ $(add_kdebase_dep kdepimlibs)
+ media-libs/qimageblitz
+ >=x11-libs/qt-gui-4.4.0:4[mng]
+ !aqua? ( x11-libs/libXScrnSaver )
+ gadu? ( >=net-libs/libgadu-1.8.0[threads] )
+ groupwise? ( app-crypt/qca:2 )
+ jabber? (
+ app-crypt/qca:2
+ net-dns/libidn
+ )
+ jingle? (
+ >=media-libs/mediastreamer-2.3.0
+ media-libs/speex
+ net-libs/ortp
+ )
+ meanwhile? ( net-libs/meanwhile )
+ msn? ( >=net-libs/libmsn-4.1 )
+ otr? ( >=net-libs/libotr-3.2.0 )
+ statistics? ( dev-db/sqlite:3 )
+ webpresence? ( dev-libs/libxml2 dev-libs/libxslt )
+ v4l2? ( media-libs/libv4l )
+"
+RDEPEND="${COMMONDEPEND}
+ latex? (
+ media-gfx/imagemagick
+ virtual/latex-base
+ )
+ sms? ( app-mobilephone/smssend )
+ ssl? ( app-crypt/qca-ossl )
+ winpopup? ( net-fs/samba )
+"
+# telepathy? ( net-libs/decibel )"
+DEPEND="${COMMONDEPEND}
+ !aqua? ( x11-proto/scrnsaverproto )
+"
+
+PATCHES=( "${FILESDIR}/${P}-openssl-1.patch"
+ "${FILESDIR}/${P}-server.patch" )
+
+src_prepare() {
+ sed -e "s:lib/mozilla:$(get_libdir)/mozilla:" \
+ -i kopete/protocols/skype/skypebuttons/CMakeLists.txt || die "sed failed"
+ sed -e '/set (LIBV4L2_REQUIRED TRUE)/s/TRUE/FALSE/' \
+ -i kopete/CMakeLists.txt || die 'failed to make v4l2 optional'
+
+ kde4-meta_src_prepare
+}
+
+src_configure() {
+ local x x2
+ # Handle common stuff
+ mycmakeargs=(
+ $(cmake-utils_use_with jingle GOOGLETALK)
+ $(cmake-utils_use_with jingle LiboRTP)
+ $(cmake-utils_use_with jingle Mediastreamer)
+ $(cmake-utils_use_with jingle Speex)
+ $(cmake-utils_use_with v4l2 LibV4L2)
+ )
+ # enable protocols
+ for x in ${PROTOCOLS}; do
+ case ${x/+/} in
+ msn) x2=wlm ;;
+ zeroconf) x2=bonjour ;;
+ *) x2='' ;;
+ esac
+ mycmakeargs+=($(cmake-utils_use_with ${x/+/} ${x2}))
+ done
+
+ # enable plugins
+ for x in ${PLUGINS}; do
+ mycmakeargs+=($(cmake-utils_use_with ${x/+/}))
+ done
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ #if use telepathy; then
+ # elog "To use kopete telepathy plugins, you need to start gabble first:"
+ # elog "GABBLE_PERSIST=1 telepathy-gabble &"
+ # elog "export TELEPATHY_DATA_PATH='${EPREFIX}/usr/share/telepathy/managers/'"
+ #fi
+
+ if ! use ssl; then
+ if use jabber || use msn; then # || use irc; then
+ echo
+ #elog "In order to use ssl in jabber, msn and irc you'll need to"
+ elog "In order to use ssl in jabber and msn you'll need to"
+ elog "install app-crypt/qca-ossl package."
+ echo
+ fi
+ fi
+}