summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-04-28 14:17:24 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-04-28 14:17:24 +0000
commit6fb05a459daf60025c76934f3ce289ec5597560e (patch)
tree594b805d214167bc3193e74568a88456161ba5d3 /kde-base/kopete
parentVersion bump (diff)
downloadgentoo-2-6fb05a459daf60025c76934f3ce289ec5597560e.tar.gz
gentoo-2-6fb05a459daf60025c76934f3ce289ec5597560e.tar.bz2
gentoo-2-6fb05a459daf60025c76934f3ce289ec5597560e.zip
Update metadata.xml to reflect useflag changes.
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kopete')
-rw-r--r--kde-base/kopete/ChangeLog6
-rw-r--r--kde-base/kopete/kopete-4.2.2.ebuild144
-rw-r--r--kde-base/kopete/metadata.xml6
3 files changed, 8 insertions, 148 deletions
diff --git a/kde-base/kopete/ChangeLog b/kde-base/kopete/ChangeLog
index e90011477a22..ac84258d45ad 100644
--- a/kde-base/kopete/ChangeLog
+++ b/kde-base/kopete/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kopete
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.181 2009/04/17 07:55:28 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.182 2009/04/28 14:17:24 scarabeus Exp $
+
+ 28 Apr 2009; Tomas Chvatal <scarabeus@gentoo.org> metadata.xml,
+ -kopete-4.2.2.ebuild:
+ Update metadata.xml to reflect useflag changes.
17 Apr 2009; Alexey Shvetsov <alexxy@gentoo.org> -kopete-4.2.1.ebuild,
kopete-4.2.2, kopete-4.2.2-r1:
diff --git a/kde-base/kopete/kopete-4.2.2.ebuild b/kde-base/kopete/kopete-4.2.2.ebuild
deleted file mode 100644
index b6cf8da3e27e..000000000000
--- a/kde-base/kopete/kopete-4.2.2.ebuild
+++ /dev/null
@@ -1,144 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/kopete-4.2.2.ebuild,v 1.2 2009/04/17 07:55:28 alexxy Exp $
-
-EAPI="2"
-
-KMNAME="kdenetwork"
-inherit kde4-meta
-
-DESCRIPTION="KDE multi-protocol IM client"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
-IUSE="debug doc ssl"
-
-# Available plugins
-#
-# addbookmarks: NO DEPS
-# alias: NO DEPS
-# autoreplace: NO DEPS
-# contactnotes: NO DEPS
-# highlight: NO DEPS
-# history: NO DEPS
-# latex: virtual/latex as RDEPEND
-# nowlistening: NO DEPS
-# otr: libotr
-# pipes: NO DEPS
-# privacy: NO DEPS
-# statistics: dev-db/sqlite:3
-# texteffect: NO DEPS
-# translator: NO DEPS
-# urlpicpreview: NO DEPS
-# webpresence: libxml2 libxslt
-# NOTE: By default we enable all plugins that don't have any dependencies
-PLUGINS="+addbookmarks +alias +autoreplace +contactnotes +highlight +history latex
-+nowlistening otr +pipes +privacy +statistics +texteffect +translator +urlpicpreview webpresence"
-
-# Available protocols
-#
-# bonjour: NO DEPS
-# gadu: openssl
-# groupwise: app-crypt/qca:2
-# irc: NO DEPS, probably will fail so inform user about it
-# jabber: net-dns/libidn app-crypt/qca:2 ENABLED BY DEFAULT NETWORK
-# jingle: media-libs/speex net-libs/ortp
-# meanwhile: net-libs/meanwhile
-# msn: libmsn
-# oscar: NO DEPS
-# qq: NO DEPS
-# sms: NO DEPS
-# telepathy: net-libs/decibel
-# testbed: NO DEPS
-# winpopup: NO DEPS
-# wlm: libmsn
-# yahoo: NO DEPS
-PROTOCOLS="bonjour gadu groupwise +jabber jingle meanwhile msn oscar qq
-testbed winpopup wlm yahoo"
-
-# disabled protocols
-# telepathy: net-libs/decibel
-# irc: NO DEPS
-
-IUSE="${IUSE} ${PLUGINS} ${PROTOCOLS}"
-
-# Tests are KDE-ish.
-RESTRICT="test"
-
-COMMONDEPEND="
- dev-libs/libpcre
- x11-libs/libXScrnSaver
- >=x11-libs/qt-gui-4.4.0:4[mng]
- gadu? ( dev-libs/openssl )
- groupwise? ( app-crypt/qca:2 )
- jabber? (
- app-crypt/qca:2
- net-dns/libidn
- jingle? (
- >=media-libs/speex-1.2_rc1
- >=net-libs/ortp-0.13
- )
- )
- meanwhile? ( net-libs/meanwhile )
- msn? ( net-libs/libmsn )
- otr? ( >=net-libs/libotr-3.2.0 )
- statistics? ( dev-db/sqlite:3 )
- webpresence? ( dev-libs/libxml2 dev-libs/libxslt )
- wlm? ( net-libs/libmsn )
-"
-RDEPEND="${COMMONDEPEND}
- latex? (
- media-gfx/imagemagick
- virtual/latex-base
- )
-"
-# telepathy? ( net-libs/decibel )"
-DEPEND="${COMMONDEPEND}
- x11-proto/scrnsaverproto
-"
-PDEPEND="
- ssl? ( app-crypt/qca-ossl )
-"
-
-src_configure() {
- local x
- # Xmms isn't in portage, thus forcefully disabled.
- mycmakeargs="${mycmakeargs} -DWITH_Xmms=OFF"
- # enable protocols
- for x in ${PROTOCOLS}; do
- mycmakeargs="${mycmakeargs} $(cmake-utils_use_with ${x/+/})"
- done
- # enable plugins
- for x in ${PLUGINS}; do
- mycmakeargs="${mycmakeargs} $(cmake-utils_use_with ${x/+/})"
- done
- # additional defines
- if use jingle && ! use jabber; then
- elog "You enabled jingle but not jabber useflag. Jingle is integral part of"
- elog "jabber protocol."
- fi
- if use jabber; then
- mycmakeargs="${mycmakeargs} -DNO_JINGLE=$(use jingle && echo OFF || echo ON)"
- fi
-
- kde4-meta_src_configure
-}
-
-pkg_postinst() {
- kde4-meta_pkg_postinst
-
- #if use telepathy; then
- # elog "To use kopete telepathy plugins, you need to start gabble first:"
- # elog "GABBLE_PERSIST=1 telepathy-gabble &"
- # elog "export TELEPATHY_DATA_PATH=/usr/share/telepathy/managers/"
- #fi
-
- elog "The messenger plugin has been renamed to wlm - adjust your use flags accordingly."
-
- if ! use ssl; then
- if use jabber || use wlm; then # || use irc; then
- echo
- elog "In order to use ssl in jabber, wlm and irc you'll need to"
- elog "install app-crypt/qca-ossl package."
- echo
- fi
- fi
-}
diff --git a/kde-base/kopete/metadata.xml b/kde-base/kopete/metadata.xml
index 3dd3a92d4583..c2549a5d8186 100644
--- a/kde-base/kopete/metadata.xml
+++ b/kde-base/kopete/metadata.xml
@@ -27,15 +27,15 @@
<flag name="irc">Enable the IRC protocol handler.</flag>
<flag name="jabber">Enable XMPP protocol handler (this is also gmail).</flag>
<flag name="meanwhile">Enable the Sametime protocol handler.</flag>
- <flag name="msn">Enable support for MSN (old microsoft protocol).</flag>
+ <flag name="messenger">Enable support for MSN and Windows live protocols (old implementation).</flag>
+ <flag name="msn">Enable "Windows live messenger" protocol support.</flag>
<flag name="netmeeting">Builds netmeeting plugin (require gnomemeeting)</flag>
- <flag name="oscar">Enable support for AIM and ICQ protocols.</flag>
<flag name="qq">enable support for the chinese network protocol.</flag>
<flag name="sametime">Enables support for the Sametime protocol for instant messaging</flag>
<flag name="sms">Enable the sms sending plugin.</flag>
+ <flag name="telepathy">Enable support for the realtime communication framework telepathy.</flag>
<flag name="testbed">Enable the testbed protocol.</flag>
<flag name="winpopup">Enable pop-up messages sending on windows. (same as good old "net send" messages ;])</flag>
- <flag name="wlm">Enable "Windows live messenger" protocol support (New protocol from MS).</flag>
<flag name="yahoo">Enable yahoo protocol support.</flag>
</use>
<herd>kde</herd>