summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2014-11-16 12:21:35 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2014-11-16 12:21:35 +0000
commit3f801aa646c6bf1e1d60d310da2302c2bd9fef66 (patch)
tree6e50112a7a8405c97655dde74a1c9e8217de71bd /kde-base/korundum
parentremove old (diff)
downloadgentoo-2-3f801aa646c6bf1e1d60d310da2302c2bd9fef66.tar.gz
gentoo-2-3f801aa646c6bf1e1d60d310da2302c2bd9fef66.tar.bz2
gentoo-2-3f801aa646c6bf1e1d60d310da2302c2bd9fef66.zip
[kde-base] Add KDE SC 4.14.3
(Portage version: 2.2.14/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key F82F92E6)
Diffstat (limited to 'kde-base/korundum')
-rw-r--r--kde-base/korundum/ChangeLog7
-rw-r--r--kde-base/korundum/korundum-4.14.3.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/kde-base/korundum/ChangeLog b/kde-base/korundum/ChangeLog
index 6c029a281b71..24aaa339c984 100644
--- a/kde-base/korundum/ChangeLog
+++ b/kde-base/korundum/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/korundum
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/ChangeLog,v 1.226 2014/11/14 19:33:09 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/ChangeLog,v 1.227 2014/11/16 12:21:26 alexxy Exp $
+
+*korundum-4.14.3 (16 Nov 2014)
+
+ 16 Nov 2014; Alexey Shvetsov <alexxy@gentoo.org> +korundum-4.14.3.ebuild:
+ Version bump KDE SC 4.14.3
14 Nov 2014; Manuel Rüger <mrueg@gentoo.org> -korundum-4.13.3.ebuild,
-korundum-4.14.1.ebuild:
diff --git a/kde-base/korundum/korundum-4.14.3.ebuild b/kde-base/korundum/korundum-4.14.3.ebuild
new file mode 100644
index 000000000000..6695590de9fa
--- /dev/null
+++ b/kde-base/korundum/korundum-4.14.3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/korundum-4.14.3.ebuild,v 1.1 2014/11/16 12:21:26 alexxy Exp $
+
+EAPI=5
+
+OPENGL_REQUIRED="always"
+
+USE_RUBY="ruby19"
+# Only one ruby version is supported:
+# 1) cmake bails when configuring twice or more - solved with CMAKE_IN_SOURCE_BUILD=1
+# 2) the ebuild can only be installed for one ruby variant, otherwise the compiled
+# files with identical path+name will overwrite each other - difficult :(
+
+inherit kde4-base ruby-ng
+
+DESCRIPTION="KDE Ruby bindings"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="akonadi debug kate nepomuk okular"
+HOMEPAGE="http://techbase.kde.org/Development/Languages/Ruby"
+
+DEPEND="
+ $(add_kdebase_dep qtruby)
+ $(add_kdebase_dep smokekde 'akonadi?,kate?,okular?,nepomuk?')
+ $(add_kdebase_dep smokeqt)
+"
+RDEPEND="${DEPEND}
+"
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_unpack() {
+ local S="${WORKDIR}/${P}"
+ kde4-base_src_unpack
+
+ cd "${WORKDIR}"
+ mkdir all
+ mv ${P} all/ || die "Could not move sources"
+}
+
+all_ruby_prepare() {
+ kde4-base_src_prepare
+}
+
+each_ruby_configure() {
+ CMAKE_USE_DIR=${S}
+ local mycmakeargs=(
+ -DRUBY_LIBRARY=$(ruby_get_libruby)
+ -DRUBY_INCLUDE_PATH=$(ruby_get_hdrdir)
+ -DRUBY_EXECUTABLE=${RUBY}
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_with nepomuk)
+ $(cmake-utils_use_with nepomuk Soprano)
+ $(cmake-utils_use_disable kate)
+ $(cmake-utils_use_with okular)
+ )
+ kde4-base_src_configure
+}
+
+each_ruby_compile() {
+ CMAKE_USE_DIR=${S}
+ kde4-base_src_compile
+}
+
+each_ruby_install() {
+ CMAKE_USE_DIR=${S}
+ kde4-base_src_install
+}