summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2009-09-01 15:49:57 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2009-09-01 15:49:57 +0000
commit3dc523cdbacc604cb2223266159a1caa5ffecb47 (patch)
tree8b0ae9dcdc4124c5a5a3e2683cb88c6c3ef6f125 /kde-base/kpilot
parentVersion bump KDE 4.3.1 (diff)
downloadgentoo-2-3dc523cdbacc604cb2223266159a1caa5ffecb47.tar.gz
gentoo-2-3dc523cdbacc604cb2223266159a1caa5ffecb47.tar.bz2
gentoo-2-3dc523cdbacc604cb2223266159a1caa5ffecb47.zip
Version bump KDE 4.3.1
(Portage version: 2.2_rc38/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kpilot')
-rw-r--r--kde-base/kpilot/ChangeLog8
-rw-r--r--kde-base/kpilot/kpilot-4.3.1.ebuild37
2 files changed, 44 insertions, 1 deletions
diff --git a/kde-base/kpilot/ChangeLog b/kde-base/kpilot/ChangeLog
index 8cad7f7dd053..2f0889e5bf3f 100644
--- a/kde-base/kpilot/ChangeLog
+++ b/kde-base/kpilot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kpilot
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/ChangeLog,v 1.90 2009/08/04 00:55:20 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/ChangeLog,v 1.91 2009/09/01 15:49:57 tampakrap Exp $
+
+*kpilot-4.3.1 (01 Sep 2009)
+
+ 01 Sep 2009; Theo Chatzimichos <tampakrap@gentoo.org>
+ +kpilot-4.3.1.ebuild:
+ Version bump
*kpilot-4.3.0 (04 Aug 2009)
diff --git a/kde-base/kpilot/kpilot-4.3.1.ebuild b/kde-base/kpilot/kpilot-4.3.1.ebuild
new file mode 100644
index 000000000000..16ecc8e172a0
--- /dev/null
+++ b/kde-base/kpilot/kpilot-4.3.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/kpilot-4.3.1.ebuild,v 1.1 2009/09/01 15:49:57 tampakrap Exp $
+
+EAPI="2"
+
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="KPilot is software for syncing PalmOS based handhelds."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="avantgo crypt debug +handbook"
+
+DEPEND="
+ >=app-pda/pilot-link-0.12
+ >=kde-base/libkdepim-${PV}:${SLOT}[kdeprefix=]
+ avantgo? ( >=dev-libs/libmal-0.40 )
+ crypt? ( app-crypt/qca:2 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with avantgo Mal)
+ $(cmake-utils_use_with crypt QCA2)"
+
+ kde4-meta_src_configure
+}
+
+src_test() {
+ # disable broken test (as of 4.2.87)
+ sed -i -e '/keyringcategorysynctest/ s/^/#DO_NOT_RUN_TEST /' \
+ "${S}"/"${PN}"/conduits/keyringconduit/tests/CMakeLists.txt || \
+ die "sed to disable keyringcategorysynctest failed."
+
+ kde4-meta_src_test
+}