summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2012-06-21 21:55:08 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2012-06-21 21:55:08 +0000
commit34c78a7dee48cc1df1e35264ea7e2c682926f487 (patch)
treef8ccbed0c1c5eda4ad6795fb2d3a688f91bb62e1 /kde-base/ksplash
parentMark stable for amd64/x86 per bug #415255 (diff)
downloadgentoo-2-34c78a7dee48cc1df1e35264ea7e2c682926f487.tar.gz
gentoo-2-34c78a7dee48cc1df1e35264ea7e2c682926f487.tar.bz2
gentoo-2-34c78a7dee48cc1df1e35264ea7e2c682926f487.zip
KDE 4.8.4 version bump
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/ksplash')
-rw-r--r--kde-base/ksplash/ChangeLog7
-rw-r--r--kde-base/ksplash/ksplash-4.8.4.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/kde-base/ksplash/ChangeLog b/kde-base/ksplash/ChangeLog
index 34a1ad960f56..2fd42188b6fb 100644
--- a/kde-base/ksplash/ChangeLog
+++ b/kde-base/ksplash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksplash
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.127 2012/05/24 11:37:56 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.128 2012/06/21 21:54:50 dilfridge Exp $
+
+*ksplash-4.8.4 (21 Jun 2012)
+
+ 21 Jun 2012; Andreas K. Huettel <dilfridge@gentoo.org> +ksplash-4.8.4.ebuild:
+ Version bump KDE SC 4.8.4
24 May 2012; Johannes Huber <johu@gentoo.org> -ksplash-4.8.1.ebuild:
Remove KDE SC 4.8.1
diff --git a/kde-base/ksplash/ksplash-4.8.4.ebuild b/kde-base/ksplash/ksplash-4.8.4.ebuild
new file mode 100644
index 000000000000..d725c7c344d1
--- /dev/null
+++ b/kde-base/ksplash/ksplash-4.8.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ksplash-4.8.4.ebuild,v 1.1 2012/06/21 21:54:50 dilfridge Exp $
+
+EAPI=4
+
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="3dnow altivec debug mmx sse sse2 xinerama"
+
+COMMONDEPEND="
+ media-libs/libpng
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_has 3dnow X86_3DNOW)
+ $(cmake-utils_use_has altivec PPC_ALTIVEC)
+ $(cmake-utils_use_has mmx X86_MMX)
+ $(cmake-utils_use_has sse X86_SSE)
+ $(cmake-utils_use_has sse2 X86_SSE2)
+ $(cmake-utils_use_with xinerama)
+ )
+
+ kde4-meta_src_configure
+}