summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-11-05 22:23:23 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-11-05 22:23:23 +0000
commit3d71d92c727066f449accc1c2b7461faade152ef (patch)
tree76c3626fcc383e0dea8d20c1bf208a6e28044206 /kde-base/ksplash
parentupdated HOMEPAGE to http://www.ugetdm.com (diff)
downloadgentoo-2-3d71d92c727066f449accc1c2b7461faade152ef.tar.gz
gentoo-2-3d71d92c727066f449accc1c2b7461faade152ef.tar.bz2
gentoo-2-3d71d92c727066f449accc1c2b7461faade152ef.zip
Version bump KDE SC 4.11.3
(Portage version: 2.2.7/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'kde-base/ksplash')
-rw-r--r--kde-base/ksplash/ChangeLog8
-rw-r--r--kde-base/ksplash/ksplash-4.11.3.ebuild38
2 files changed, 45 insertions, 1 deletions
diff --git a/kde-base/ksplash/ChangeLog b/kde-base/ksplash/ChangeLog
index e2ead4dedcee..702faebdbacd 100644
--- a/kde-base/ksplash/ChangeLog
+++ b/kde-base/ksplash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/ksplash
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.194 2013/10/10 01:27:06 creffett Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.195 2013/11/05 22:23:03 dilfridge Exp $
+
+*ksplash-4.11.3 (05 Nov 2013)
+
+ 05 Nov 2013; Andreas K. Huettel <dilfridge@gentoo.org>
+ +ksplash-4.11.3.ebuild:
+ Version bump KDE SC 4.11.3
10 Oct 2013; Chris Reffett <creffett@gentoo.org> -ksplash-4.11.1.ebuild:
Drop KDE SC 4.11.1
diff --git a/kde-base/ksplash/ksplash-4.11.3.ebuild b/kde-base/ksplash/ksplash-4.11.3.ebuild
new file mode 100644
index 000000000000..a1eedda47cb8
--- /dev/null
+++ b/kde-base/ksplash/ksplash-4.11.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ksplash-4.11.3.ebuild,v 1.1 2013/11/05 22:23:03 dilfridge Exp $
+
+EAPI=5
+
+DECLARATIVE_REQUIRED="always"
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="3dnow altivec debug mmx sse sse2 xinerama"
+
+COMMONDEPEND="
+ media-libs/libpng:0=
+ virtual/jpeg:0
+ x11-libs/libX11
+ x11-libs/libXext
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_has 3dnow X86_3DNOW)
+ $(cmake-utils_use_has altivec PPC_ALTIVEC)
+ $(cmake-utils_use_has mmx X86_MMX)
+ $(cmake-utils_use_has sse X86_SSE)
+ $(cmake-utils_use_has sse2 X86_SSE2)
+ $(cmake-utils_use_with xinerama)
+ )
+
+ kde4-meta_src_configure
+}