summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2008-11-09 01:35:20 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2008-11-09 01:35:20 +0000
commitc0104396c9537ecf7188735df5c98636d0542bd3 (patch)
tree76c635b07d3a3ea73a1bba8e5364287f65e8d00c /kde-base/kstars
parentFull auto: Version bump for KDE-4.1.3 (diff)
downloadgentoo-2-c0104396c9537ecf7188735df5c98636d0542bd3.tar.gz
gentoo-2-c0104396c9537ecf7188735df5c98636d0542bd3.tar.bz2
gentoo-2-c0104396c9537ecf7188735df5c98636d0542bd3.zip
Full auto: Version bump for KDE-4.1.3
(Portage version: 2.2_rc12/cvs/Linux 2.6.26-gentoo i686)
Diffstat (limited to 'kde-base/kstars')
-rw-r--r--kde-base/kstars/ChangeLog7
-rw-r--r--kde-base/kstars/kstars-4.1.3.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/kde-base/kstars/ChangeLog b/kde-base/kstars/ChangeLog
index 33002b39f75f..e14d2bb4ffec 100644
--- a/kde-base/kstars/ChangeLog
+++ b/kde-base/kstars/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kstars
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/ChangeLog,v 1.103 2008/11/03 10:42:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/ChangeLog,v 1.104 2008/11/09 01:35:20 scarabeus Exp $
+
+*kstars-4.1.3 (08 Nov 2008)
+
+ 08 Nov 2008; Tomas Chvatal <scarabeus@gentoo.org> +kstars-4.1.3.ebuild:
+ Version bump.
03 Nov 2008; Mike Frysinger <vapier@gentoo.org> kstars-4.1.2.ebuild:
Add -mminimal-toc for ppc64 systems.
diff --git a/kde-base/kstars/kstars-4.1.3.ebuild b/kde-base/kstars/kstars-4.1.3.ebuild
new file mode 100644
index 000000000000..dc727815b529
--- /dev/null
+++ b/kde-base/kstars/kstars-4.1.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/kstars-4.1.3.ebuild,v 1.1 2008/11/09 01:35:20 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME=kdeedu
+inherit kde4-meta
+
+DESCRIPTION="KDE Desktop Planetarium"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug fits htmlhandbook nova sbig usb"
+
+DEPEND=">=kde-base/libkdeedu-${PV}:${SLOT}
+ fits? ( sci-libs/cfitsio )
+ nova? ( >=sci-libs/libnova-0.12.1 )
+ sbig? ( sci-libs/indilib
+ usb? ( dev-libs/libusb ) )"
+RDEPEND="${DEPEND}"
+
+PATCHES=("${FILESDIR}/${PN}-4.1.0-destdir.patch")
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with fits CFitsio)
+ $(cmake-utils_use_with nova Nova)
+ $(cmake-utils_use_with sbig SBIG)
+ $(cmake-utils_use_with usb USB)"
+
+ sed -i -e "s:add_subdirectory(cmake):#dontwantit:g" CMakeLists.txt \
+ || die "disabling cmake includes failed"
+ sed -i -e "s:add_subdirectory( cmake ):#dontwantit:g" CMakeLists.txt \
+ || die "disabling cmake includes failed"
+
+ kde4-meta_src_configure
+
+ # FIXME Unhandled arguments - added sbig but not sure about use descriptions or flag names...
+ # WITH_SBIG - Switch which controls the detection of the proprietary and binary only SBIG CCD universal library. No ebuild for this package
+ # are available at the moment.
+ # ssh_tunnel -> INDI Server binds locally. Remote clients may only connect
+ # via SSH Tunneling.
+}