summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-12-03 22:36:09 +0000
committerJohannes Huber <johu@gentoo.org>2013-12-03 22:36:09 +0000
commit318092ea225b3d6ad7192e8ae024a631e482b266 (patch)
tree91df8808be8c8389bc73293ff837135ae83c78e3 /kde-base/okular
parentUpdate init file /var/run/apcupsd directory > /run/apcupsd (diff)
downloadgentoo-2-318092ea225b3d6ad7192e8ae024a631e482b266.tar.gz
gentoo-2-318092ea225b3d6ad7192e8ae024a631e482b266.tar.bz2
gentoo-2-318092ea225b3d6ad7192e8ae024a631e482b266.zip
Version bump KDE SC 4.11.4
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/okular')
-rw-r--r--kde-base/okular/ChangeLog7
-rw-r--r--kde-base/okular/okular-4.11.4.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/kde-base/okular/ChangeLog b/kde-base/okular/ChangeLog
index 995a7d57585f..3e5eba2d1e9c 100644
--- a/kde-base/okular/ChangeLog
+++ b/kde-base/okular/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/okular
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/ChangeLog,v 1.212 2013/11/05 22:23:01 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/ChangeLog,v 1.213 2013/12/03 22:35:34 johu Exp $
+
+*okular-4.11.4 (03 Dec 2013)
+
+ 03 Dec 2013; Johannes Huber <johu@gentoo.org> +okular-4.11.4.ebuild:
+ Version bump KDE SC 4.11.4
*okular-4.11.3 (05 Nov 2013)
diff --git a/kde-base/okular/okular-4.11.4.ebuild b/kde-base/okular/okular-4.11.4.ebuild
new file mode 100644
index 000000000000..9b2d6921d906
--- /dev/null
+++ b/kde-base/okular/okular-4.11.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/okular-4.11.4.ebuild,v 1.1 2013/12/03 22:35:34 johu Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+
+#VIRTUALX_REQUIRED=test
+RESTRICT=test
+# test 2: parttest hangs
+
+inherit kde4-base
+
+DESCRIPTION="Okular is an universal document viewer based on KPDF for KDE 4."
+HOMEPAGE="http://okular.kde.org http://www.kde.org/applications/graphics/okular"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="chm crypt debug djvu ebook +jpeg +postscript +pdf +tiff"
+
+DEPEND="
+ media-libs/freetype
+ media-libs/qimageblitz
+ sys-libs/zlib
+ chm? ( dev-libs/chmlib )
+ crypt? ( app-crypt/qca:2 )
+ djvu? ( app-text/djvu )
+ ebook? ( app-text/ebook-tools )
+ jpeg? ( virtual/jpeg:0 )
+ pdf? ( >=app-text/poppler-0.20[qt4,-exceptions(-)] )
+ postscript? ( app-text/libspectre )
+ tiff? ( media-libs/tiff )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with chm)
+ $(cmake-utils_use_with crypt QCA2)
+ $(cmake-utils_use_with djvu DjVuLibre)
+ $(cmake-utils_use_with ebook EPub)
+ $(cmake-utils_use_with jpeg)
+ $(cmake-utils_use_with postscript LibSpectre)
+ $(cmake-utils_use_with pdf PopplerQt4)
+ $(cmake-utils_use_with pdf Poppler)
+ $(cmake-utils_use_with tiff)
+ )
+
+ kde4-base_src_configure
+}