summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-08-04 01:30:19 +0000
committerAlex Alexander <wired@gentoo.org>2009-08-04 01:30:19 +0000
commit9e5a0c813ad14972f3bfc0896392350a3575c339 (patch)
tree4fee2efb1ae6c1131329fc61d7d285c6df1aa14b /kde-base/phonon-kde
parentVersion bump KDE 4.3.0 (diff)
downloadgentoo-2-9e5a0c813ad14972f3bfc0896392350a3575c339.tar.gz
gentoo-2-9e5a0c813ad14972f3bfc0896392350a3575c339.tar.bz2
gentoo-2-9e5a0c813ad14972f3bfc0896392350a3575c339.zip
Version bump KDE 4.3.0
(Portage version: 2.2_rc33/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/phonon-kde')
-rw-r--r--kde-base/phonon-kde/ChangeLog7
-rw-r--r--kde-base/phonon-kde/phonon-kde-4.3.0.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/kde-base/phonon-kde/ChangeLog b/kde-base/phonon-kde/ChangeLog
index f833a075d3a8..4b46aab67dab 100644
--- a/kde-base/phonon-kde/ChangeLog
+++ b/kde-base/phonon-kde/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/phonon-kde
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.20 2009/07/31 14:20:52 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.21 2009/08/04 01:30:19 wired Exp $
+
+*phonon-kde-4.3.0 (04 Aug 2009)
+
+ 04 Aug 2009; Alex Alexander <wired@gentoo.org> +phonon-kde-4.3.0.ebuild:
+ Version bump
31 Jul 2009; Tomáš Chvátal <scarabeus@gentoo.org>
phonon-kde-4.2.4.ebuild:
diff --git a/kde-base/phonon-kde/phonon-kde-4.3.0.ebuild b/kde-base/phonon-kde/phonon-kde-4.3.0.ebuild
new file mode 100644
index 000000000000..73e08a1bfa36
--- /dev/null
+++ b/kde-base/phonon-kde/phonon-kde-4.3.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/phonon-kde-4.3.0.ebuild,v 1.1 2009/08/04 01:30:19 wired Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-runtime"
+KMMODULE="phonon"
+inherit kde4-meta
+
+DESCRIPTION="Phonon KDE Integration"
+HOMEPAGE="http://phonon.kde.org"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+LICENSE="GPL-2"
+IUSE="debug pulseaudio +xine"
+
+DEPEND="
+ media-libs/alsa-lib
+ media-sound/phonon[xine?]
+ pulseaudio? ( media-sound/pulseaudio )
+"
+RDEPEND="${DEPEND}
+ !kdeprefix? ( !kde-base/phonon-xine[-kdeprefix] )
+"
+
+src_prepare() {
+ # Don't build tests - they require OpenGL
+ sed -e 's/add_subdirectory(tests)//' \
+ -i phonon/CMakeLists.txt || die "Failed to disable tests"
+
+ # Disable automagic
+ sed -e 's/find_package(Xine)/macro_optional_find_package(Xine)/' \
+ -i phonon/kcm/xine/CMakeLists.txt || die "Failed to make xine optional"
+
+ kde4-meta_src_prepare
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with pulseaudio PulseAudio)
+ $(cmake-utils_use_with xine)"
+
+ kde4-meta_src_configure
+}