summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-07-04 18:00:40 +0000
committerJohannes Huber <johu@gentoo.org>2013-07-04 18:00:40 +0000
commitc6b2e1cc8a654b09fc1a9fefe3330561e50550d1 (patch)
tree48eea0ac163600522a3099d8b293b6bcc5c92144 /kde-base/qtruby
parentremove old packages (diff)
downloadgentoo-2-c6b2e1cc8a654b09fc1a9fefe3330561e50550d1.tar.gz
gentoo-2-c6b2e1cc8a654b09fc1a9fefe3330561e50550d1.tar.bz2
gentoo-2-c6b2e1cc8a654b09fc1a9fefe3330561e50550d1.zip
Add ruby19 support wrt bug #434076.
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/qtruby')
-rw-r--r--kde-base/qtruby/ChangeLog5
-rw-r--r--kde-base/qtruby/qtruby-4.10.5.ebuild11
2 files changed, 9 insertions, 7 deletions
diff --git a/kde-base/qtruby/ChangeLog b/kde-base/qtruby/ChangeLog
index 2a96bfbb934b..945ab09b952e 100644
--- a/kde-base/qtruby/ChangeLog
+++ b/kde-base/qtruby/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for kde-base/qtruby
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/ChangeLog,v 1.166 2013/07/02 16:47:46 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/ChangeLog,v 1.167 2013/07/04 18:00:40 johu Exp $
+
+ 04 Jul 2013; Johannes Huber <johu@gentoo.org> qtruby-4.10.5.ebuild:
+ Add ruby19 support wrt bug #434076.
*qtruby-4.10.5 (02 Jul 2013)
diff --git a/kde-base/qtruby/qtruby-4.10.5.ebuild b/kde-base/qtruby/qtruby-4.10.5.ebuild
index 6f1bf0ffe5bd..d5c72ae97c06 100644
--- a/kde-base/qtruby/qtruby-4.10.5.ebuild
+++ b/kde-base/qtruby/qtruby-4.10.5.ebuild
@@ -1,17 +1,16 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/qtruby-4.10.5.ebuild,v 1.1 2013/07/02 16:47:46 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/qtruby-4.10.5.ebuild,v 1.2 2013/07/04 18:00:40 johu Exp $
EAPI=5
OPENGL_REQUIRED="always"
DECLARATIVE_REQUIRED="optional"
KDE_REQUIRED="never"
-USE_RUBY="ruby18"
-# No ruby19 for three reasons:
-# 1) it does not build (yet) - will likely be solved soon
-# 2) cmake bails when configuring twice or more - solved with CMAKE_IN_SOURCE_BUILD=1
-# 3) the ebuild can only be installed for one ruby variant, otherwise the compiled
+USE_RUBY="ruby19"
+# Only one ruby version is supported:
+# 1) cmake bails when configuring twice or more - solved with CMAKE_IN_SOURCE_BUILD=1
+# 2) the ebuild can only be installed for one ruby variant, otherwise the compiled
# files with identical path+name will overwrite each other - difficult :(
inherit kde4-base ruby-ng