summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-05-06 20:18:53 +0000
committerJohannes Huber <johu@gentoo.org>2013-05-06 20:18:53 +0000
commit2371cce4f3cea5589c1c6d562a1fc6e5bdd25b51 (patch)
tree733e9e1acf77d4f47af78826e93c8cf4d670bf27 /kde-base/superkaramba
parentFix LICENSE, bug 447390. (diff)
downloadgentoo-2-2371cce4f3cea5589c1c6d562a1fc6e5bdd25b51.tar.gz
gentoo-2-2371cce4f3cea5589c1c6d562a1fc6e5bdd25b51.tar.bz2
gentoo-2-2371cce4f3cea5589c1c6d562a1fc6e5bdd25b51.zip
Version bump KDE SC 4.10.3.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, RepoMan options: --include-arches="amd64", signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/superkaramba')
-rw-r--r--kde-base/superkaramba/ChangeLog7
-rw-r--r--kde-base/superkaramba/superkaramba-4.10.3.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/kde-base/superkaramba/ChangeLog b/kde-base/superkaramba/ChangeLog
index 1fede0650c93..d2b3abb9b90e 100644
--- a/kde-base/superkaramba/ChangeLog
+++ b/kde-base/superkaramba/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/superkaramba
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/ChangeLog,v 1.243 2013/05/05 11:51:16 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/ChangeLog,v 1.244 2013/05/06 20:18:23 johu Exp $
+
+*superkaramba-4.10.3 (06 May 2013)
+
+ 06 May 2013; Johannes Huber <johu@gentoo.org> +superkaramba-4.10.3.ebuild:
+ Version bump KDE SC 4.10.3
05 May 2013; Agostino Sarubbo <ago@gentoo.org> -superkaramba-4.10.1.ebuild:
Remove old
diff --git a/kde-base/superkaramba/superkaramba-4.10.3.ebuild b/kde-base/superkaramba/superkaramba-4.10.3.ebuild
new file mode 100644
index 000000000000..da9ba394af40
--- /dev/null
+++ b/kde-base/superkaramba/superkaramba-4.10.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/superkaramba-4.10.3.ebuild,v 1.1 2013/05/06 20:18:23 johu Exp $
+
+EAPI=5
+
+PYTHON_DEPEND="python? 2"
+inherit python kde4-base
+
+DESCRIPTION="A tool to create interactive applets for the KDE desktop."
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug python"
+
+DEPEND="
+ media-libs/qimageblitz
+ python? ( $(add_kdebase_dep pykde4) )
+"
+RDEPEND="${DEPEND}
+ python? ( $(add_kdebase_dep krosspython) )
+"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with python PythonLibs)
+ )
+
+ kde4-base_src_configure
+}