summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-01-06 19:41:29 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-01-06 19:41:29 +0000
commit0deadc51c98ca70def850b3dedfce143c6d4e585 (patch)
treebb808976cd78fa6f4df7d6481e40b178251e4083 /kde-base
parentwhitespace (diff)
downloadgentoo-2-0deadc51c98ca70def850b3dedfce143c6d4e585.tar.gz
gentoo-2-0deadc51c98ca70def850b3dedfce143c6d4e585.tar.bz2
gentoo-2-0deadc51c98ca70def850b3dedfce143c6d4e585.zip
Added a check for app-crypt/pinentry having been built with either the gtk or qt3 USE flag as otherwise essential functionality of kgpg won't be accessible. Fixes bug 204139.
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kgpg/ChangeLog10
-rw-r--r--kde-base/kgpg/kgpg-3.5.7.ebuild17
-rw-r--r--kde-base/kgpg/kgpg-3.5.8.ebuild17
3 files changed, 36 insertions, 8 deletions
diff --git a/kde-base/kgpg/ChangeLog b/kde-base/kgpg/ChangeLog
index dce54137cce2..b12c005dc862 100644
--- a/kde-base/kgpg/ChangeLog
+++ b/kde-base/kgpg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kgpg
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kgpg/ChangeLog,v 1.72 2007/10/19 22:56:28 philantrop Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kgpg/ChangeLog,v 1.73 2008/01/06 19:41:29 philantrop Exp $
+
+ 06 Jan 2008; Wulf C. Krueger <philantrop@gentoo.org> kgpg-3.5.7.ebuild,
+ kgpg-3.5.8.ebuild:
+ Added a check for app-crypt/pinentry having been built with either the gtk
+ or qt3 USE flag as otherwise essential functionality of kgpg won't be
+ accessible. Fixes bug 204139.
*kgpg-3.5.8 (19 Oct 2007)
diff --git a/kde-base/kgpg/kgpg-3.5.7.ebuild b/kde-base/kgpg/kgpg-3.5.7.ebuild
index be6e3179c28f..8921c9df3e9b 100644
--- a/kde-base/kgpg/kgpg-3.5.7.ebuild
+++ b/kde-base/kgpg/kgpg-3.5.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kgpg/kgpg-3.5.7.ebuild,v 1.7 2007/08/11 15:16:34 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kgpg/kgpg-3.5.7.ebuild,v 1.8 2008/01/06 19:41:29 philantrop Exp $
KMNAME=kdeutils
MAXKDEVER=$PV
@@ -12,4 +12,15 @@ KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="kdehiddenvisibility"
RDEPEND="${RDEPEND}
- app-crypt/gnupg"
+ app-crypt/gnupg
+ app-crypt/pinentry"
+
+pkg_setup() {
+ if ! built_with_use app-crypt/pinentry gtk && ! built_with_use app-crypt/pinentry qt3 ; then
+ eerror "${PN} needs app-crypt/pinentry built with either the gtk or qt3 USE flag."
+ eerror "Please enable either USE flag and re-install app-crypt/pinentry."
+ die "app-crypt/pinentry needs to be rebuilt with gtk or qt3 support."
+ fi
+
+ kde_pkg_setup
+}
diff --git a/kde-base/kgpg/kgpg-3.5.8.ebuild b/kde-base/kgpg/kgpg-3.5.8.ebuild
index 79b54d9ba760..8d6cbf461a8c 100644
--- a/kde-base/kgpg/kgpg-3.5.8.ebuild
+++ b/kde-base/kgpg/kgpg-3.5.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kgpg/kgpg-3.5.8.ebuild,v 1.1 2007/10/19 22:56:28 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kgpg/kgpg-3.5.8.ebuild,v 1.2 2008/01/06 19:41:29 philantrop Exp $
KMNAME=kdeutils
MAXKDEVER=$PV
@@ -12,4 +12,15 @@ KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="kdehiddenvisibility"
RDEPEND="${RDEPEND}
- app-crypt/gnupg"
+ app-crypt/gnupg
+ app-crypt/pinentry"
+
+pkg_setup() {
+ if ! built_with_use app-crypt/pinentry gtk && ! built_with_use app-crypt/pinentry qt3 ; then
+ eerror "${PN} needs app-crypt/pinentry built with either the gtk or qt3 USE flag."
+ eerror "Please enable either USE flag and re-install app-crypt/pinentry."
+ die "app-crypt/pinentry needs to be rebuilt with gtk or qt3 support."
+ fi
+
+ kde_pkg_setup
+}