summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-22 13:19:46 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-06-22 13:19:46 +0000
commit205e7ce975fe184618e131cfc09ac0f30a6e0be4 (patch)
tree02ac1d3553dd917a143203bfaeb091d94490aa1c /kde-base
parentMove myconf population in src_compile rather than global scope. (diff)
downloadgentoo-2-205e7ce975fe184618e131cfc09ac0f30a6e0be4.tar.gz
gentoo-2-205e7ce975fe184618e131cfc09ac0f30a6e0be4.tar.bz2
gentoo-2-205e7ce975fe184618e131cfc09ac0f30a6e0be4.zip
Move myconf population in src_compile rather than global scope.
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdegraphics-kfile-plugins/ChangeLog8
-rw-r--r--kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.4.3.ebuild8
-rw-r--r--kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.2.ebuild7
-rw-r--r--kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.3.ebuild7
4 files changed, 23 insertions, 7 deletions
diff --git a/kde-base/kdegraphics-kfile-plugins/ChangeLog b/kde-base/kdegraphics-kfile-plugins/ChangeLog
index d90514a1e911..484602fd4299 100644
--- a/kde-base/kdegraphics-kfile-plugins/ChangeLog
+++ b/kde-base/kdegraphics-kfile-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdegraphics-kfile-plugins
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics-kfile-plugins/ChangeLog,v 1.50 2006/06/01 17:45:29 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics-kfile-plugins/ChangeLog,v 1.51 2006/06/22 13:19:46 flameeyes Exp $
+
+ 22 Jun 2006; Diego Pettenò <flameeyes@gentoo.org>
+ kdegraphics-kfile-plugins-3.4.3.ebuild,
+ kdegraphics-kfile-plugins-3.5.2.ebuild,
+ kdegraphics-kfile-plugins-3.5.3.ebuild:
+ Move myconf population in src_compile rather than global scope.
*kdegraphics-kfile-plugins-3.5.3 (01 Jun 2006)
diff --git a/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.4.3.ebuild b/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.4.3.ebuild
index 2fdbdf6320cc..f61eee10254e 100644
--- a/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.4.3.ebuild
+++ b/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.4.3.ebuild,v 1.9 2006/03/27 14:59:05 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.4.3.ebuild,v 1.10 2006/06/22 13:19:46 flameeyes Exp $
KMNAME=kdegraphics
KMMODULE=kfile-plugins
@@ -18,4 +18,8 @@ DEPEND="tiff? ( media-libs/tiff )
KMEXTRACTONLY="kfile-plugins/ps kfile-plugins/pdf"
PATCHES="$FILESDIR/configure-fix-kdegraphics-openexr.patch"
-myconf="$myconf $(use_with openexr)"
+
+src_compile() {
+ myconf="$myconf $(use_with openexr)"
+ kde-meta_src_compile
+}
diff --git a/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.2.ebuild b/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.2.ebuild
index a4a9da35463e..27cf30c8d227 100644
--- a/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.2.ebuild
+++ b/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.2.ebuild,v 1.10 2006/06/01 09:00:51 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.2.ebuild,v 1.11 2006/06/22 13:19:46 flameeyes Exp $
KMNAME=kdegraphics
KMMODULE=kfile-plugins
@@ -20,4 +20,7 @@ DEPEND="media-libs/tiff
# ps installed with kghostview, pdf installed with kpdf
KMEXTRACTONLY="kfile-plugins/ps kfile-plugins/pdf"
-myconf="$myconf $(use_with openexr)"
+src_compile() {
+ myconf="$myconf $(use_with openexr)"
+ kde-meta_src_compile
+}
diff --git a/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.3.ebuild b/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.3.ebuild
index 10947794997f..3ed3c19fd56c 100644
--- a/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.3.ebuild
+++ b/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.3.ebuild,v 1.1 2006/06/01 17:45:29 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.3.ebuild,v 1.2 2006/06/22 13:19:46 flameeyes Exp $
KMNAME=kdegraphics
KMMODULE=kfile-plugins
@@ -20,4 +20,7 @@ DEPEND="media-libs/tiff
# ps installed with kghostview, pdf installed with kpdf
KMEXTRACTONLY="kfile-plugins/ps kfile-plugins/pdf"
-myconf="$myconf $(use_with openexr)"
+src_compile() {
+ myconf="$myconf $(use_with openexr)"
+ kde-meta_src_compile
+}