summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-03-01 00:24:51 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-03-01 00:24:51 +0000
commit34ab87a4c4e998098cabebeb900675a92665d734 (patch)
treeb047d88767dc5fd8d55aa34a0ad8677d84a6b536 /kde-base
parentInitial commit (diff)
downloadgentoo-2-34ab87a4c4e998098cabebeb900675a92665d734.tar.gz
gentoo-2-34ab87a4c4e998098cabebeb900675a92665d734.tar.bz2
gentoo-2-34ab87a4c4e998098cabebeb900675a92665d734.zip
Fix missing backends with +kdeprefix. Per bug #257428.
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/phonon-kde/ChangeLog8
-rw-r--r--kde-base/phonon-kde/phonon-kde-4.2.0-r1.ebuild37
2 files changed, 44 insertions, 1 deletions
diff --git a/kde-base/phonon-kde/ChangeLog b/kde-base/phonon-kde/ChangeLog
index 2a485561d002..105c56f17f97 100644
--- a/kde-base/phonon-kde/ChangeLog
+++ b/kde-base/phonon-kde/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/phonon-kde
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.3 2009/02/06 00:02:22 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.4 2009/03/01 00:24:51 scarabeus Exp $
+
+*phonon-kde-4.2.0-r1 (01 Mar 2009)
+
+ 01 Mar 2009; Tomas Chvatal <scarabeus@gentoo.org>
+ +phonon-kde-4.2.0-r1.ebuild:
+ Fix missing backends with +kdeprefix. Per bug #257428.
05 Feb 2009; Brent Baude <ranger@gentoo.org> phonon-kde-4.2.0.ebuild:
Marking phonon-kde-4.2.0 ~ppc64 for bug 257421
diff --git a/kde-base/phonon-kde/phonon-kde-4.2.0-r1.ebuild b/kde-base/phonon-kde/phonon-kde-4.2.0-r1.ebuild
new file mode 100644
index 000000000000..ab1676a20992
--- /dev/null
+++ b/kde-base/phonon-kde/phonon-kde-4.2.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/phonon-kde-4.2.0-r1.ebuild,v 1.1 2009/03/01 00:24:51 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-runtime"
+KMMODULE="phonon"
+inherit kde4-meta
+
+DESCRIPTION="Phonon KDE Integration"
+HOMEPAGE="http://phonon.kde.org"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="debug"
+
+DEPEND="!kde-base/phonon:${SLOT}
+ !kdeprefix? ( !kde-base/phonon-xine )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Don't build tests - they require OpenGL
+ sed -i -e 's/add_subdirectory(tests)//'\
+ phonon/CMakeLists.txt || die "Failed to disable tests"
+
+ kde4-meta_src_prepare
+}
+
+src_install() {
+ kde4-meta_src_install
+
+ # fix missing backends
+ if use kdeprefix; then
+ dosym /usr/share/kde4/services/phononbackends \
+ "${KDEDIR}"/share/kde4/services/phononbackends || die
+ fi
+}