summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-11-20 13:40:02 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-11-20 13:40:02 +0000
commit5073c30d06fc53634159e82cb752a0ae15c85fe5 (patch)
tree843f0279b8288e06591b21d32054624d94d23309 /kde-base
parentAdd ~x86-fbsd; deal with arch which has "-" in its name; add FreeBSD patch. (diff)
downloadgentoo-2-5073c30d06fc53634159e82cb752a0ae15c85fe5.tar.gz
gentoo-2-5073c30d06fc53634159e82cb752a0ae15c85fe5.tar.bz2
gentoo-2-5073c30d06fc53634159e82cb752a0ae15c85fe5.zip
Add upstream patch to build using Boost exceptions, thanks Johu! Bug 390059
(Portage version: 2.1.10.34/cvs/Linux x86_64)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/rocs/ChangeLog6
-rw-r--r--kde-base/rocs/files/rocs-4.7.3-boost.patch29
-rw-r--r--kde-base/rocs/rocs-4.7.3.ebuild6
3 files changed, 39 insertions, 2 deletions
diff --git a/kde-base/rocs/ChangeLog b/kde-base/rocs/ChangeLog
index 0afef0ecec5c..0de5bcce2c07 100644
--- a/kde-base/rocs/ChangeLog
+++ b/kde-base/rocs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/rocs
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/rocs/ChangeLog,v 1.50 2011/11/02 20:48:23 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/rocs/ChangeLog,v 1.51 2011/11/20 13:40:02 dilfridge Exp $
+
+ 20 Nov 2011; Andreas K. Huettel <dilfridge@gentoo.org> rocs-4.7.3.ebuild,
+ +files/rocs-4.7.3-boost.patch:
+ Add upstream patch to build using Boost exceptions, thanks Johu! Bug 390059
*rocs-4.7.3 (02 Nov 2011)
diff --git a/kde-base/rocs/files/rocs-4.7.3-boost.patch b/kde-base/rocs/files/rocs-4.7.3-boost.patch
new file mode 100644
index 000000000000..9671e41b7d50
--- /dev/null
+++ b/kde-base/rocs/files/rocs-4.7.3-boost.patch
@@ -0,0 +1,29 @@
+commit 43b6ccf22174629ebec0a0579365c4269cf0fb58
+Author: Andreas Cord-Landwehr <cola@uni-paderborn.de>
+Date: Sat Oct 22 22:50:26 2011 +0200
+
+ Build Rocs by default with Boost Exceptions.
+
+ This solves the common build issues with many Boost releases.
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index b47ef0a..c636fd5 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -8,6 +8,8 @@ find_package(KDE4 REQUIRED)
+ include(KDE4Defaults)
+ remove_definitions(-DQT_NO_STL)
+
++set (CMAKE_CXX_FLAGS "${KDE4_ENABLE_EXCEPTIONS}" )
++
+ include_directories(
+ ${KDE4_INCLUDES}
+ ${QT_INCLUDES}
+@@ -15,7 +17,6 @@ include_directories(
+
+ if(${CMAKE_BUILD_TYPE} MATCHES coverage)
+ set (CMAKE_CXX_COMPILER cov++)
+- set (CMAKE_CXX_FLAGS "${KDE4_ENABLE_EXCEPTIONS}" )
+ endif()
+
+ find_package(Boost "1.39" REQUIRED)
diff --git a/kde-base/rocs/rocs-4.7.3.ebuild b/kde-base/rocs/rocs-4.7.3.ebuild
index 28aae683d964..95af72e11623 100644
--- a/kde-base/rocs/rocs-4.7.3.ebuild
+++ b/kde-base/rocs/rocs-4.7.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/rocs/rocs-4.7.3.ebuild,v 1.1 2011/11/02 20:48:23 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/rocs/rocs-4.7.3.ebuild,v 1.2 2011/11/20 13:40:02 dilfridge Exp $
EAPI=4
@@ -18,5 +18,9 @@ DEPEND="
>=dev-cpp/eigen-2.0.3:2
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.7.3-boost.patch
+)
+
RESTRICT="test"
# bug 376909