summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-02-27 22:48:45 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-02-27 22:48:45 +0000
commit5b4ac28e826f390b267a57958774b290af6a1b65 (patch)
tree1b9be36b9b903b83886a029c0985c05cddd5c2f9 /kde-base
parentNew flags for kde-3.4.0_rc1. (diff)
downloadgentoo-2-5b4ac28e826f390b267a57958774b290af6a1b65.tar.gz
gentoo-2-5b4ac28e826f390b267a57958774b290af6a1b65.tar.bz2
gentoo-2-5b4ac28e826f390b267a57958774b290af6a1b65.zip
Add support for zeroconf. Cleanup.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdelibs/ChangeLog8
-rw-r--r--kde-base/kdelibs/files/digest-kdelibs-3.4.0_rc11
-rw-r--r--kde-base/kdelibs/files/digest-kdelibs-3.4.0_rc1-r11
-rw-r--r--kde-base/kdelibs/kdelibs-3.4.0_rc1-r1.ebuild (renamed from kde-base/kdelibs/kdelibs-3.4.0_rc1.ebuild)46
4 files changed, 29 insertions, 27 deletions
diff --git a/kde-base/kdelibs/ChangeLog b/kde-base/kdelibs/ChangeLog
index 1aa750cf1575..a5c33c94a67e 100644
--- a/kde-base/kdelibs/ChangeLog
+++ b/kde-base/kdelibs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdelibs
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.196 2005/02/27 20:21:33 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.197 2005/02/27 22:48:45 greg_g Exp $
+
+*kdelibs-3.4.0_rc1-r1 (27 Feb 2005)
+
+ 27 Feb 2005; Gregorio Guidi <greg_g@gentoo.org>
+ +kdelibs-3.4.0_rc1-r1.ebuild, -kdelibs-3.4.0_rc1.ebuild:
+ Add support for zeroconf. Cleanup.
27 Feb 2005; Dan Armak <danarmak@gentoo.org> :
Ebuild for 3.4.0 RC1.
diff --git a/kde-base/kdelibs/files/digest-kdelibs-3.4.0_rc1 b/kde-base/kdelibs/files/digest-kdelibs-3.4.0_rc1
deleted file mode 100644
index 3f336bbd3737..000000000000
--- a/kde-base/kdelibs/files/digest-kdelibs-3.4.0_rc1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 f14bb378c1967df19919a9519e40fdcd kdelibs-3.4.0-rc1.tar.bz2 16859532
diff --git a/kde-base/kdelibs/files/digest-kdelibs-3.4.0_rc1-r1 b/kde-base/kdelibs/files/digest-kdelibs-3.4.0_rc1-r1
new file mode 100644
index 000000000000..228ace77d08c
--- /dev/null
+++ b/kde-base/kdelibs/files/digest-kdelibs-3.4.0_rc1-r1
@@ -0,0 +1 @@
+MD5 87c394ea9da775d2be7be7d3f7fd56ec kdelibs-3.4.0-rc1.tar.bz2 16823552
diff --git a/kde-base/kdelibs/kdelibs-3.4.0_rc1.ebuild b/kde-base/kdelibs/kdelibs-3.4.0_rc1-r1.ebuild
index b018679e4b63..37d855c9d401 100644
--- a/kde-base/kdelibs/kdelibs-3.4.0_rc1.ebuild
+++ b/kde-base/kdelibs/kdelibs-3.4.0_rc1-r1.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.4.0_rc1.ebuild,v 1.2 2005/02/26 16:48:23 motaboy Exp $
-inherit kde eutils flag-o-matic
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.4.0_rc1-r1.ebuild,v 1.1 2005/02/27 22:48:45 greg_g Exp $
+
+inherit kde eutils
set-kdedir 3.4
-MY_PV=3.4.0-rc1
+MY_PV=${PV/_/-}
S=${WORKDIR}/${PN}-3.4.0
DESCRIPTION="KDE libraries needed by all kde programs"
@@ -14,7 +15,7 @@ SRC_URI="mirror://kde/unstable/${MY_PV}/src/${PN}-${MY_PV}.tar.bz2"
LICENSE="GPL-2 LGPL-2"
SLOT="3.4"
KEYWORDS="~x86 ~amd64 ~sparc"
-IUSE="alsa arts cups doc jpeg2k kerberos openexr spell ssl tiff"
+IUSE="alsa arts cups doc jpeg2k kerberos openexr spell ssl tiff zeroconf"
# kde.eclass has kdelibs in DEPEND, and we can't have that in here.
# so we recreate the entire DEPEND from scratch.
@@ -24,47 +25,42 @@ RDEPEND="arts? ( ~kde-base/arts-${PV} )
>=dev-libs/libxslt-1.1.4
>=dev-libs/libxml2-2.6.6
>=dev-libs/libpcre-4.2
+ media-libs/libart_lgpl
+ net-dns/libidn
ssl? ( >=dev-libs/openssl-0.9.7d )
alsa? ( media-libs/alsa-lib )
cups? ( >=net-print/cups-1.1.19 )
tiff? ( media-libs/tiff )
kerberos? ( virtual/krb5 )
- jpeg2k? ( x86? ( media-libs/jasper ) )
+ jpeg2k? ( media-libs/jasper )
openexr? ( >=media-libs/openexr-1.2 )
spell? ( || ( app-text/aspell
app-text/ispell ) )
+ zeroconf? ( net-misc/mDNSResponder )
virtual/fam
- virtual/ghostscript
- media-libs/libart_lgpl
- net-dns/libidn"
-# TODO
-# - add dependency on mDNSResponder when it enters portage
-# ('dnssd' local USE flag?)
+ virtual/ghostscript"
DEPEND="${RDEPEND}
>=sys-devel/autoconf-2.58
>=sys-devel/automake-1.8
doc? ( app-doc/doxygen )
- sys-devel/gettext
- !kde-misc/kgamma"
+ sys-devel/gettext"
-PATCHES="$FILESDIR/$PN-3.4.0_beta2-export-kio-symbols.diff"
+PATCHES="${FILESDIR}/${PN}-3.4.0_beta2-export-kio-symbols.diff"
src_compile() {
- kde_src_compile myconf
+ myconf="--with-distribution=Gentoo --enable-libfam --enable-dnotify"
+ myconf="${myconf} $(use_with alsa) $(use_with arts)"
+ myconf="${myconf} $(use_with tiff) $(use_with jpeg2k jasper) $(use_with openexr)"
+ myconf="${myconf} $(use_enable cups) $(use_enable zeroconf dnssd)"
- myconf="$myconf --with-distribution=Gentoo --enable-libfam --enable-dnotify"
- myconf="$myconf $(use_with alsa) $(use_enable cups) $(use_with arts)"
- myconf="$myconf $(use_with tiff) $(use_with jpeg2k jasper) $(use_with openexr)"
+ use ssl && myconf="${myconf} --with-ssl-dir=/usr" || myconf="${myconf} --without-ssl"
- use ssl && myconf="$myconf --with-ssl-dir=/usr" || myconf="$myconf --without-ssl"
+ use kerberos || myconf="${myconf} --with-gssapi=no"
- use kerberos || myconf="$myconf --with-gssapi=no"
+ use x86 && myconf="${myconf} --enable-fast-malloc=full"
- use x86 && myconf="$myconf --enable-fast-malloc=full"
- use ppc64 && append-flags -mminimal-toc
-
- kde_src_compile configure make
+ kde_src_compile
use doc && make apidox
}
@@ -76,13 +72,13 @@ src_install() {
# needed to fix lib64 issues on amd64, see bug #45669
use amd64 && ln -s ${KDEDIR}/lib ${D}/${KDEDIR}/lib64
+
# Needed to create lib -> lib64 symlink for amd64 2005.0 profile
if [ "${SYMLINK_LIB}" = "yes" ]; then
dosym $(get_abi_LIBDIR ${DEFAULT_ABI}) ${KDEDIR}/lib
fi
if ! use arts ; then
-
dodir /etc/env.d
cat <<EOF > ${D}/etc/env.d/46kdepaths-${SLOT} # number goes down with version upgrade