summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-09-04 00:12:01 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-09-04 00:12:01 +0000
commitfe7a25036b0d9e7065cebd799921fda57fdd6ea8 (patch)
tree5a73729f18489c644ba3e1c176d5d594840dfa8b /kde-base
parentVersion bump. (diff)
downloadgentoo-2-fe7a25036b0d9e7065cebd799921fda57fdd6ea8.tar.gz
gentoo-2-fe7a25036b0d9e7065cebd799921fda57fdd6ea8.tar.bz2
gentoo-2-fe7a25036b0d9e7065cebd799921fda57fdd6ea8.zip
Fix clicking behaviour. See bug #483538.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/plasma-runtime/ChangeLog9
-rw-r--r--kde-base/plasma-runtime/files/plasma-runtime-4.11.1-clicking-behaviour.patch49
-rw-r--r--kde-base/plasma-runtime/plasma-runtime-4.11.1-r1.ebuild24
3 files changed, 81 insertions, 1 deletions
diff --git a/kde-base/plasma-runtime/ChangeLog b/kde-base/plasma-runtime/ChangeLog
index 7161464b816e..1462a9c6a522 100644
--- a/kde-base/plasma-runtime/ChangeLog
+++ b/kde-base/plasma-runtime/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/plasma-runtime
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/plasma-runtime/ChangeLog,v 1.162 2013/09/03 19:50:29 creffett Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/plasma-runtime/ChangeLog,v 1.163 2013/09/04 00:12:01 mrueg Exp $
+
+*plasma-runtime-4.11.1-r1 (04 Sep 2013)
+
+ 04 Sep 2013; Manuel Rüger <mrueg@gentoo.org>
+ +files/plasma-runtime-4.11.1-clicking-behaviour.patch,
+ +plasma-runtime-4.11.1-r1.ebuild:
+ Fix clicking behaviour. See bug #483538.
03 Sep 2013; Chris Reffett <creffett@gentoo.org>
-plasma-runtime-4.11.0.ebuild:
diff --git a/kde-base/plasma-runtime/files/plasma-runtime-4.11.1-clicking-behaviour.patch b/kde-base/plasma-runtime/files/plasma-runtime-4.11.1-clicking-behaviour.patch
new file mode 100644
index 000000000000..4269df82970b
--- /dev/null
+++ b/kde-base/plasma-runtime/files/plasma-runtime-4.11.1-clicking-behaviour.patch
@@ -0,0 +1,49 @@
+commit be1a5d484c70f4f6a383150810afbfbb367db2ac
+Author: Eike Hein <hein@kde.org>
+Date: Tue Sep 3 20:29:23 2013 +0200
+
+ Discard the recorded events in the item-local handlers.
+
+ Solves problems with identical events being ignored due to
+ QGraphicsView's reuse of QGraphicsSceneMouseEvent instances.
+
+ CCMAIL:rdieter@fedoraproject.org
+ BUG:324470
+ BUG:324471
+
+diff --git a/plasma/declarativeimports/qtextracomponents/mouseeventlistener.cpp b/plasma/declarativeimports/qtextracomponents/mouseeventlistener.cpp
+index b534845..36530e0 100644
+--- a/plasma/declarativeimports/qtextracomponents/mouseeventlistener.cpp
++++ b/plasma/declarativeimports/qtextracomponents/mouseeventlistener.cpp
+@@ -90,6 +90,7 @@ bool MouseEventListener::containsMouse() const
+ void MouseEventListener::mousePressEvent(QGraphicsSceneMouseEvent *me)
+ {
+ if (m_lastEvent == me) {
++ m_lastEvent = 0;
+ return;
+ }
+
+@@ -112,6 +113,7 @@ void MouseEventListener::mousePressEvent(QGraphicsSceneMouseEvent *me)
+ void MouseEventListener::mouseMoveEvent(QGraphicsSceneMouseEvent *me)
+ {
+ if (m_lastEvent == me) {
++ m_lastEvent = 0;
+ return;
+ }
+
+@@ -122,6 +124,7 @@ void MouseEventListener::mouseMoveEvent(QGraphicsSceneMouseEvent *me)
+ void MouseEventListener::mouseReleaseEvent(QGraphicsSceneMouseEvent *me)
+ {
+ if (m_lastEvent == me) {
++ m_lastEvent = 0;
+ return;
+ }
+
+@@ -138,6 +141,7 @@ void MouseEventListener::mouseReleaseEvent(QGraphicsSceneMouseEvent *me)
+ void MouseEventListener::wheelEvent(QGraphicsSceneWheelEvent *we)
+ {
+ if (m_lastEvent == we) {
++ m_lastEvent = 0;
+ return;
+ }
+
diff --git a/kde-base/plasma-runtime/plasma-runtime-4.11.1-r1.ebuild b/kde-base/plasma-runtime/plasma-runtime-4.11.1-r1.ebuild
new file mode 100644
index 000000000000..57a34b7d43bf
--- /dev/null
+++ b/kde-base/plasma-runtime/plasma-runtime-4.11.1-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/plasma-runtime/plasma-runtime-4.11.1-r1.ebuild,v 1.1 2013/09/04 00:12:01 mrueg Exp $
+
+EAPI=5
+
+KMNAME="kde-runtime"
+KMMODULE="plasma"
+DECLARATIVE_REQUIRED="always"
+inherit kde4-meta
+
+DESCRIPTION="Script engine and package tool for plasma"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdebase_dep kactivities)
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT=test
+# bug 443748
+
+PATCHES=( "${FILESDIR}"/${P}-clicking-behaviour.patch )