summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2015-07-16 20:33:16 +0000
committerJohannes Huber <johu@gentoo.org>2015-07-16 20:33:16 +0000
commite3f5fcb6e4e5cfc27c2222c8724fdea7f6f6e538 (patch)
tree399d438bcdd9b60161ca43ada7c1345d860db9fb /kde-frameworks/frameworkintegration
parentStable on alpha, bug 553738 (diff)
downloadgentoo-2-e3f5fcb6e4e5cfc27c2222c8724fdea7f6f6e538.tar.gz
gentoo-2-e3f5fcb6e4e5cfc27c2222c8724fdea7f6f6e538.tar.bz2
gentoo-2-e3f5fcb6e4e5cfc27c2222c8724fdea7f6f6e538.zip
Version bump KDE Frameworks 5.12.0
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xFDF4F788)
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/ChangeLog8
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.12.0.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/kde-frameworks/frameworkintegration/ChangeLog b/kde-frameworks/frameworkintegration/ChangeLog
index 653a12005d49..f0efd3dfa227 100644
--- a/kde-frameworks/frameworkintegration/ChangeLog
+++ b/kde-frameworks/frameworkintegration/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-frameworks/frameworkintegration
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-frameworks/frameworkintegration/ChangeLog,v 1.21 2015/06/26 20:06:31 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-frameworks/frameworkintegration/ChangeLog,v 1.22 2015/07/16 20:33:15 johu Exp $
+
+*frameworkintegration-5.12.0 (16 Jul 2015)
+
+ 16 Jul 2015; Johannes Huber <johu@gentoo.org>
+ +frameworkintegration-5.12.0.ebuild:
+ Version bump KDE Frameworks 5.12.0
26 Jun 2015; Johannes Huber <johu@gentoo.org>
-frameworkintegration-5.10.0.ebuild:
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.12.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.12.0.ebuild
new file mode 100644
index 000000000000..2656676b52ed
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.12.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-frameworks/frameworkintegration/frameworkintegration-5.12.0.ebuild,v 1.1 2015/07/16 20:33:15 johu Exp $
+
+EAPI=5
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for integrating Qt applications with KDE workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+
+RDEPEND="
+ $(add_plasma_dep oxygen-fonts)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ X? (
+ dev-qt/qtx11extras:5
+ x11-libs/libxcb
+ x11-libs/libXcursor
+ )
+"
+DEPEND="${RDEPEND}"
+
+# requires running kde environment
+RESTRICT="test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package X XCB)
+ )
+
+ kde5_src_configure
+}