summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2013-02-26 13:03:36 +0000
committerMichael Palimaka <kensington@gentoo.org>2013-02-26 13:03:36 +0000
commit2cd6a3f3709419e59eb0d8338e2672dbc0adb034 (patch)
treeb05fb1020c948034a74e3c3784ff337db4710a39 /kde-misc/kcm_touchpad
parentFix mistakenly removed ebuild, bug #459288. (diff)
downloadgentoo-2-2cd6a3f3709419e59eb0d8338e2672dbc0adb034.tar.gz
gentoo-2-2cd6a3f3709419e59eb0d8338e2672dbc0adb034.tar.bz2
gentoo-2-2cd6a3f3709419e59eb0d8338e2672dbc0adb034.zip
Migrate to EAPI 5. Add missing dependency.
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
Diffstat (limited to 'kde-misc/kcm_touchpad')
-rw-r--r--kde-misc/kcm_touchpad/ChangeLog11
-rw-r--r--kde-misc/kcm_touchpad/kcm_touchpad-0.3.1-r1.ebuild35
-rw-r--r--kde-misc/kcm_touchpad/metadata.xml5
3 files changed, 47 insertions, 4 deletions
diff --git a/kde-misc/kcm_touchpad/ChangeLog b/kde-misc/kcm_touchpad/ChangeLog
index bea433843634..1eb67f2353bd 100644
--- a/kde-misc/kcm_touchpad/ChangeLog
+++ b/kde-misc/kcm_touchpad/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-misc/kcm_touchpad
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/kcm_touchpad/ChangeLog,v 1.5 2011/01/31 03:44:39 tampakrap Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kcm_touchpad/ChangeLog,v 1.6 2013/02/26 13:03:36 kensington Exp $
+
+*kcm_touchpad-0.3.1-r1 (26 Feb 2013)
+
+ 26 Feb 2013; Michael Palimaka <kensington@gentoo.org>
+ +kcm_touchpad-0.3.1-r1.ebuild, metadata.xml:
+ Migrate to EAPI 5. Add missing dependency.
31 Jan 2011; Theo Chatzimichos <tampakrap@gentoo.org>
-kcm_touchpad-0.3.0.ebuild, kcm_touchpad-0.3.1.ebuild:
@@ -25,4 +31,3 @@
31 Oct 2009; Samuli Suominen <ssuominen@gentoo.org>
+kcm_touchpad-0.3.0.ebuild:
Initial commit wrt #289889, thanks to Andreis Vinogradovs for reporting.
-
diff --git a/kde-misc/kcm_touchpad/kcm_touchpad-0.3.1-r1.ebuild b/kde-misc/kcm_touchpad/kcm_touchpad-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..a489df0b299e
--- /dev/null
+++ b/kde-misc/kcm_touchpad/kcm_touchpad-0.3.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kcm_touchpad/kcm_touchpad-0.3.1-r1.ebuild,v 1.1 2013/02/26 13:03:36 kensington Exp $
+
+EAPI=5
+KDE_LINGUAS="de es nl pl"
+
+inherit kde4-base
+
+MY_P="mishaaq-${PN}-00370b5"
+
+DESCRIPTION="KControl module for xf86-input-synaptics"
+HOMEPAGE="http://www.kde-apps.org/content/show.php/kcm_touchpad?content=113335"
+SRC_URI="http://github.com/mishaaq/kcm_touchpad/tarball/${P} -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ x11-libs/libXi
+"
+DEPEND="${RDEPEND}
+ >=x11-proto/inputproto-2.0
+"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( AUTHORS README )
+
+src_prepare() {
+ sed -e "/^install( FILES AUTHORS/d" -i CMakeLists.txt || die
+ kde4-base_src_prepare
+}
diff --git a/kde-misc/kcm_touchpad/metadata.xml b/kde-misc/kcm_touchpad/metadata.xml
index 8d1e86a9cefb..f848d4e0ef3c 100644
--- a/kde-misc/kcm_touchpad/metadata.xml
+++ b/kde-misc/kcm_touchpad/metadata.xml
@@ -1,5 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>kde</herd>
+ <herd>kde</herd>
+ <upstream>
+ <remote-id type="github">mishaaq/kcm_touchpad</remote-id>
+ </upstream>
</pkgmetadata>