summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2013-08-22 11:16:24 +0000
committerFabio Erculiani <lxnay@gentoo.org>2013-08-22 11:16:24 +0000
commit942ffd2420c49c5ac1e3754e0c7dcee56475c3b9 (patch)
treeb293e7d6612be9d777718479494c2519a58d71b5 /kde-misc/magneto-kde
parentversion bump (diff)
downloadgentoo-2-942ffd2420c49c5ac1e3754e0c7dcee56475c3b9.tar.gz
gentoo-2-942ffd2420c49c5ac1e3754e0c7dcee56475c3b9.tar.bz2
gentoo-2-942ffd2420c49c5ac1e3754e0c7dcee56475c3b9.zip
version bump
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'kde-misc/magneto-kde')
-rw-r--r--kde-misc/magneto-kde/ChangeLog7
-rw-r--r--kde-misc/magneto-kde/magneto-kde-216.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/kde-misc/magneto-kde/ChangeLog b/kde-misc/magneto-kde/ChangeLog
index 1f42a1289e2a..3bdc87aaade5 100644
--- a/kde-misc/magneto-kde/ChangeLog
+++ b/kde-misc/magneto-kde/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-misc/magneto-kde
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/magneto-kde/ChangeLog,v 1.33 2013/04/02 09:38:30 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/magneto-kde/ChangeLog,v 1.34 2013/08/22 11:16:24 lxnay Exp $
+
+*magneto-kde-216 (22 Aug 2013)
+
+ 22 Aug 2013; Fabio Erculiani <lxnay@gentoo.org> +magneto-kde-216.ebuild:
+ version bump
*magneto-kde-189 (02 Apr 2013)
diff --git a/kde-misc/magneto-kde/magneto-kde-216.ebuild b/kde-misc/magneto-kde/magneto-kde-216.ebuild
new file mode 100644
index 000000000000..37f8492c51b0
--- /dev/null
+++ b/kde-misc/magneto-kde/magneto-kde-216.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/magneto-kde/magneto-kde-216.ebuild,v 1.1 2013/08/22 11:16:24 lxnay Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+inherit eutils python
+
+DESCRIPTION="Entropy Package Manager notification applet KDE frontend"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+S="${WORKDIR}/entropy-${PV}/magneto"
+
+RDEPEND="~app-misc/magneto-loader-${PV}
+ kde-base/pykde4
+ dev-python/PyQt4[dbus]"
+DEPEND=""
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/lib" magneto-kde-install || die "make install failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/lib/entropy/magneto/magneto/kde"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/entropy/magneto/magneto/kde"
+}