summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-08-10 14:22:12 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-08-10 14:22:12 +0000
commitc307656c1ea63a396ade61a51a6e3611d498464e (patch)
tree90a86a3d1503bac18649790760323232cda127bb /kde-misc
parentversion bump. (diff)
downloadgentoo-2-c307656c1ea63a396ade61a51a6e3611d498464e.tar.gz
gentoo-2-c307656c1ea63a396ade61a51a6e3611d498464e.tar.bz2
gentoo-2-c307656c1ea63a396ade61a51a6e3611d498464e.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/kanyremote/ChangeLog8
-rw-r--r--kde-misc/kanyremote/kanyremote-5.11.7.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/kde-misc/kanyremote/ChangeLog b/kde-misc/kanyremote/ChangeLog
index b6fa0f3421e6..6f9e5a20cf7d 100644
--- a/kde-misc/kanyremote/ChangeLog
+++ b/kde-misc/kanyremote/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-misc/kanyremote
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/ChangeLog,v 1.12 2010/07/02 08:05:54 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/ChangeLog,v 1.13 2010/08/10 14:22:12 hwoarang Exp $
+
+*kanyremote-5.11.7 (10 Aug 2010)
+
+ 10 Aug 2010; Markos Chandras <hwoarang@gentoo.org>
+ +kanyremote-5.11.7.ebuild:
+ Version bump
02 Jul 2010; Markos Chandras <hwoarang@gentoo.org>
-kanyremote-5.10.ebuild:
diff --git a/kde-misc/kanyremote/kanyremote-5.11.7.ebuild b/kde-misc/kanyremote/kanyremote-5.11.7.ebuild
new file mode 100644
index 000000000000..2e30f14154a4
--- /dev/null
+++ b/kde-misc/kanyremote/kanyremote-5.11.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/kanyremote-5.11.7.ebuild,v 1.1 2010/08/10 14:22:12 hwoarang Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+inherit autotools python base
+
+DESCRIPTION="KDE frontend to Anyremote"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/anyremote/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth"
+
+RDEPEND=">=app-mobilephone/anyremote-4.4[bluetooth?]
+ dev-python/PyQt4[X]
+ kde-base/pykde4
+ bluetooth? ( dev-python/pybluez )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+pkg_setup () {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ # using gettextize no-interactive example from dev-util/bless package
+ cp $(type -p gettextize) "${T}"/
+ sed -i -e 's:read dummy < /dev/tty::' "${T}/gettextize"
+ "${T}"/gettextize -f --no-changelog > /dev/null
+ #fix documentation directory wrt bug #316087
+ sed -i "s/doc\/${PN}/doc\/${PF}/g" Makefile.am
+ eautoreconf
+ # workaround to bluetooth check when bluetooth use flag is disabled
+ ! use bluetooth && epatch "${FILESDIR}/disable_bluetooth.patch"
+}