summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2009-08-06 11:34:45 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2009-08-06 11:34:45 +0000
commitd52a6e6866b7e7e4cae12ac327187d28245db04e (patch)
tree6bd2bd7e018f2d1efce9b8743f0f8a6b4789f91a /kde-misc
parentFix building with GLIBC 2.10+ wrt #277760. (diff)
downloadgentoo-2-d52a6e6866b7e7e4cae12ac327187d28245db04e.tar.gz
gentoo-2-d52a6e6866b7e7e4cae12ac327187d28245db04e.tar.bz2
gentoo-2-d52a6e6866b7e7e4cae12ac327187d28245db04e.zip
Version bump to 4.3.0
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/konq-plugins/ChangeLog8
-rw-r--r--kde-misc/konq-plugins/konq-plugins-4.3.0.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/kde-misc/konq-plugins/ChangeLog b/kde-misc/konq-plugins/ChangeLog
index fbb5d30d9faa..9b93cccf74f2 100644
--- a/kde-misc/konq-plugins/ChangeLog
+++ b/kde-misc/konq-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-misc/konq-plugins
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/konq-plugins/ChangeLog,v 1.4 2009/07/22 22:56:01 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/konq-plugins/ChangeLog,v 1.5 2009/08/06 11:34:45 tampakrap Exp $
+
+*konq-plugins-4.3.0 (06 Aug 2009)
+
+ 06 Aug 2009; Theo Chatzimichos <tampakrap@gentoo.org>
+ +konq-plugins-4.3.0.ebuild:
+ Version bump to 4.3.0
*konq-plugins-4.2.4-r1 (22 Jul 2009)
diff --git a/kde-misc/konq-plugins/konq-plugins-4.3.0.ebuild b/kde-misc/konq-plugins/konq-plugins-4.3.0.ebuild
new file mode 100644
index 000000000000..b200796deb10
--- /dev/null
+++ b/kde-misc/konq-plugins/konq-plugins-4.3.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/konq-plugins/konq-plugins-4.3.0.ebuild,v 1.1 2009/08/06 11:34:45 tampakrap Exp $
+
+EAPI="2"
+
+KDE_LINGUAS="af ar be bg bn br ca cs cy da de el en_GB eo es et eu fa fi fr fy ga
+ gl he hi hr hsb hu is it ja kk km ko ku lt lv mai mk ml ms nb nds ne nl nn oc pa
+ pl pt pt_BR ro ru se sk sl sr sv ta tg th tr uk uz uz@cyrillic vi xh zh_CN zh_TW"
+
+KDE_DOC_DIRS="doc doc-translations/%lingua_${PN}"
+
+KMNAME="extragear/base"
+inherit kde4-base
+
+DESCRIPTION="Various plugins for konqueror"
+HOMEPAGE="http://kde.org/"
+SRC_URI="mirror://kde/stable/${PV}/src/extragear/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+SLOT="4"
+IUSE="debug +handbook tidy"
+
+DEPEND="
+ >=kde-base/libkonq-${KDE_MINIMAL}
+ tidy? ( app-text/htmltidy )
+"
+RDEPEND="${DEPEND}
+ !kde-base/konq-plugins:4.1[-kdeprefix]
+ !kde-base/konq-plugins:4.2[-kdeprefix]
+ >=kde-base/kcmshell-${KDE_MINIMAL}
+ >=kde-base/konqueror-${KDE_MINIMAL}
+"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ -DKdeWebKit=OFF
+ -DWebKitPart=OFF
+ $(cmake-utils_use_with tidy LibTidy)"
+
+ kde4-base_src_configure
+}