summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2015-02-20 11:44:27 +0000
committerBen de Groot <yngwin@gentoo.org>2015-02-20 11:44:27 +0000
commitca0adaa7b6aaf0a7b7bf9b1f71c3319ae0465b25 (patch)
tree9993d624687635467771550871702635f2996c09 /lxqt-base/lxqt-common
parentVersion bumps (diff)
downloadgentoo-2-ca0adaa7b6aaf0a7b7bf9b1f71c3319ae0465b25.tar.gz
gentoo-2-ca0adaa7b6aaf0a7b7bf9b1f71c3319ae0465b25.tar.bz2
gentoo-2-ca0adaa7b6aaf0a7b7bf9b1f71c3319ae0465b25.zip
version bump (bug #540264)
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 0x4FDF9CFD2FAC514E!)
Diffstat (limited to 'lxqt-base/lxqt-common')
-rw-r--r--lxqt-base/lxqt-common/ChangeLog7
-rw-r--r--lxqt-base/lxqt-common/lxqt-common-0.9.1.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/lxqt-base/lxqt-common/ChangeLog b/lxqt-base/lxqt-common/ChangeLog
index 913740f0873f..535708381349 100644
--- a/lxqt-base/lxqt-common/ChangeLog
+++ b/lxqt-base/lxqt-common/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for lxqt-base/lxqt-common
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/lxqt-base/lxqt-common/ChangeLog,v 1.6 2015/02/10 17:08:51 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/lxqt-base/lxqt-common/ChangeLog,v 1.7 2015/02/20 11:44:27 yngwin Exp $
+
+*lxqt-common-0.9.1 (20 Feb 2015)
+
+ 20 Feb 2015; Ben de Groot <yngwin@gentoo.org> +lxqt-common-0.9.1.ebuild:
+ version bump (bug #540264)
*lxqt-common-0.9.0 (10 Feb 2015)
diff --git a/lxqt-base/lxqt-common/lxqt-common-0.9.1.ebuild b/lxqt-base/lxqt-common/lxqt-common-0.9.1.ebuild
new file mode 100644
index 000000000000..a3ad948c8093
--- /dev/null
+++ b/lxqt-base/lxqt-common/lxqt-common-0.9.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/lxqt-base/lxqt-common/lxqt-common-0.9.1.ebuild,v 1.1 2015/02/20 11:44:27 yngwin Exp $
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt common resources"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+DEPEND=">=lxqt-base/liblxqt-0.9.0"
+RDEPEND="${DEPEND}"
+PDEPEND=">=lxqt-base/lxqt-session-0.9.0"
+
+src_install() {
+ cmake-utils_src_install
+ dodir "/etc/X11/Sessions"
+ dosym "/usr/bin/startlxqt" "/etc/X11/Sessions/lxqt"
+}