summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2014-11-08 17:24:44 +0000
committerJauhien Piatlicki <jauhien@gentoo.org>2014-11-08 17:24:44 +0000
commit4526131d0e03b5b2e93941de21135fb2f80ff14f (patch)
tree1fd04f6666a40277e7605c8367695228a99f48ed /lxqt-base
parentdisable -Werror for live builds; minor cleanup (diff)
downloadgentoo-2-4526131d0e03b5b2e93941de21135fb2f80ff14f.tar.gz
gentoo-2-4526131d0e03b5b2e93941de21135fb2f80ff14f.tar.bz2
gentoo-2-4526131d0e03b5b2e93941de21135fb2f80ff14f.zip
version bump
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 0xB2EFA1D4)
Diffstat (limited to 'lxqt-base')
-rw-r--r--lxqt-base/lxqt-notificationd/ChangeLog8
-rw-r--r--lxqt-base/lxqt-notificationd/lxqt-notificationd-0.8.0.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/lxqt-base/lxqt-notificationd/ChangeLog b/lxqt-base/lxqt-notificationd/ChangeLog
index df55cd62ff36..8d8c3a7fda4d 100644
--- a/lxqt-base/lxqt-notificationd/ChangeLog
+++ b/lxqt-base/lxqt-notificationd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for lxqt-base/lxqt-notificationd
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/lxqt-base/lxqt-notificationd/ChangeLog,v 1.4 2014/11/08 06:41:55 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/lxqt-base/lxqt-notificationd/ChangeLog,v 1.5 2014/11/08 17:24:44 jauhien Exp $
+
+*lxqt-notificationd-0.8.0 (08 Nov 2014)
+
+ 08 Nov 2014; Jauhien Piatlicki <jauhien@gentoo.org>
+ +lxqt-notificationd-0.8.0.ebuild:
+ version bump
08 Nov 2014; Ben de Groot <yngwin@gentoo.org> lxqt-notificationd-0.7.0.ebuild:
Move libqtxdg to new category
diff --git a/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.8.0.ebuild b/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.8.0.ebuild
new file mode 100644
index 000000000000..7604a97dc084
--- /dev/null
+++ b/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.8.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/lxqt-base/lxqt-notificationd/lxqt-notificationd-0.8.0.ebuild,v 1.1 2014/11/08 17:24:44 jauhien Exp $
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt notification daemon and library"
+HOMEPAGE="http://www.lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="http://lxqt.org/downloads/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+DEPEND="
+ dev-qt/linguist-tools:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ ~lxqt-base/liblxqt-${PV}
+ >=dev-libs/libqtxdg-1.0.0
+ x11-libs/libX11
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT5=ON
+ )
+ cmake-utils_src_configure
+}