summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-06-30 12:22:37 +0000
committerPacho Ramos <pacho@gentoo.org>2012-06-30 12:22:37 +0000
commit27e4ac4150622dfdc12c32fdb478699a238b7001 (patch)
tree18f2a2314c7f7844cf55408666aa3aad732b6736 /mail-client/balsa
parenttemp mask to bump Claws Mail and plugins (diff)
downloadgentoo-2-27e4ac4150622dfdc12c32fdb478699a238b7001.tar.gz
gentoo-2-27e4ac4150622dfdc12c32fdb478699a238b7001.tar.bz2
gentoo-2-27e4ac4150622dfdc12c32fdb478699a238b7001.zip
Version bump.
(Portage version: 2.1.11.3/cvs/Linux x86_64)
Diffstat (limited to 'mail-client/balsa')
-rw-r--r--mail-client/balsa/ChangeLog7
-rw-r--r--mail-client/balsa/balsa-2.4.12.ebuild106
2 files changed, 112 insertions, 1 deletions
diff --git a/mail-client/balsa/ChangeLog b/mail-client/balsa/ChangeLog
index b2725e0beb5c..6418a0892ac1 100644
--- a/mail-client/balsa/ChangeLog
+++ b/mail-client/balsa/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/balsa
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/balsa/ChangeLog,v 1.115 2012/05/08 01:10:35 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/balsa/ChangeLog,v 1.116 2012/06/30 12:22:37 pacho Exp $
+
+*balsa-2.4.12 (30 Jun 2012)
+
+ 30 Jun 2012; Pacho Ramos <pacho@gentoo.org> +balsa-2.4.12.ebuild:
+ Version bump.
08 May 2012; Julian Ospald <hasufell@gentoo.org> metadata.xml:
webkit is now global wrt #285743
diff --git a/mail-client/balsa/balsa-2.4.12.ebuild b/mail-client/balsa/balsa-2.4.12.ebuild
new file mode 100644
index 000000000000..4b16e8238dca
--- /dev/null
+++ b/mail-client/balsa/balsa-2.4.12.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/balsa/balsa-2.4.12.ebuild,v 1.1 2012/06/30 12:22:37 pacho Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2
+
+DESCRIPTION="Email client for GNOME"
+HOMEPAGE="http://pawsa.fedorapeople.org/balsa/"
+SRC_URI="http://pawsa.fedorapeople.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+# Doesn't currently build with -gnome
+IUSE="crypt gnome gtkhtml +gtkspell kerberos ldap libnotify networkmanager rubrica sqlite ssl webkit xface"
+
+# TODO: esmtp can be optional
+RDEPEND=">=dev-libs/glib-2.16:2
+ >=x11-libs/gtk+-2.18:2
+ dev-libs/gmime:2.6
+ dev-libs/libunique:1
+ >=net-libs/libesmtp-1.0.3
+ net-mail/mailbase
+ media-libs/libcanberra[gtk]
+ x11-themes/hicolor-icon-theme
+ x11-themes/gnome-icon-theme
+ crypt? ( >=app-crypt/gpgme-1.0 )
+ gnome? (
+ >=gnome-base/orbit-2
+ >=gnome-base/libbonobo-2.0
+ >=gnome-base/libgnome-2.0
+ >=gnome-base/libgnomeui-2.0
+ >=gnome-base/gconf-2.0:2
+ >=gnome-base/gnome-keyring-2.20
+ >=x11-libs/gtksourceview-2.10:2.0 )
+ gtkhtml? ( >=gnome-extra/gtkhtml-3.14:3.14 )
+ sqlite? ( >=dev-db/sqlite-2.8 )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ gtkspell? (
+ app-text/gtkspell:2
+ app-text/enchant )
+ !gtkspell? ( app-text/aspell )
+ kerberos? ( app-crypt/mit-krb5 )
+ ldap? ( net-nds/openldap )
+ networkmanager? ( >=net-misc/networkmanager-0.7 )
+ rubrica? ( dev-libs/libxml2:2 )
+ ssl? ( dev-libs/openssl )
+ webkit? ( >=net-libs/webkit-gtk-1.5.1:2 )
+ xface? ( >=media-libs/compface-1.5.1 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext
+ >=app-text/scrollkeeper-0.1.4
+ app-text/gnome-doc-utils"
+
+REQUIRED_USE="gtkhtml? ( !webkit )"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README TODO docs/*"
+
+pkg_setup() {
+ if use crypt ; then
+ G2CONF="${G2CONF} --with-gpgme=gpgme-config"
+ else
+ G2CONF="${G2CONF} --without-gpgme"
+ fi
+
+ if use webkit || use gtkhtml; then
+ if use gtkhtml ; then
+ G2CONF="${G2CONF} --with-html-widget=gtkhtml3"
+ else
+ G2CONF="${G2CONF} --with-html-widget=webkit"
+ fi
+ else
+ G2CONF="${G2CONF} --with-html-widget=no"
+ fi
+
+ G2CONF="${G2CONF}
+ --disable-pcre
+ --enable-gregex
+ --enable-threads
+ --with-gmime=2.6
+ --with-unique
+ --with-canberra
+ $(use_with gnome)
+ $(use_with gnome gtksourceview)
+ $(use_with gtkspell)
+ $(use_with kerberos gss)
+ $(use_with ldap)
+ $(use_with libnotify)
+ $(use_with networkmanager nm)
+ $(use_with rubrica)
+ $(use_with sqlite)
+ $(use_with ssl)
+ $(use_with xface compface)"
+}
+
+src_prepare() {
+ # Fix documentation
+ epatch "${FILESDIR}/${PN}-2.4.11-doc-fixes.patch"
+
+ gnome2_src_prepare
+}