summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2010-11-15 02:37:54 +0000
committerTim Harder <radhermit@gentoo.org>2010-11-15 02:37:54 +0000
commit441af0d0e5b18c484513f2a65a11d40852168ec9 (patch)
tree8e022d617192fbd5b2f023d3f36a1a040c7c9a1a /mail-client/cone
parentFix building with Python 3.1.3 (bug #344823). (diff)
downloadgentoo-2-441af0d0e5b18c484513f2a65a11d40852168ec9.tar.gz
gentoo-2-441af0d0e5b18c484513f2a65a11d40852168ec9.tar.bz2
gentoo-2-441af0d0e5b18c484513f2a65a11d40852168ec9.zip
Fix the MIME testsuite for systems without the en_US.utf-8 locale.
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'mail-client/cone')
-rw-r--r--mail-client/cone/ChangeLog7
-rw-r--r--mail-client/cone/cone-0.84.20100819-r1.ebuild3
-rw-r--r--mail-client/cone/files/cone-0.84.20100819-rfc2045-tests-lang.patch41
3 files changed, 49 insertions, 2 deletions
diff --git a/mail-client/cone/ChangeLog b/mail-client/cone/ChangeLog
index 78b87d3c7093..a4a029fddb35 100644
--- a/mail-client/cone/ChangeLog
+++ b/mail-client/cone/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/cone
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/cone/ChangeLog,v 1.30 2010/11/12 08:37:00 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/cone/ChangeLog,v 1.31 2010/11/15 02:37:53 radhermit Exp $
+
+ 15 Nov 2010; Tim Harder <radhermit@gentoo.org>
+ cone-0.84.20100819-r1.ebuild,
+ +files/cone-0.84.20100819-rfc2045-tests-lang.patch:
+ Fix the MIME testsuite for systems without the en_US.utf-8 locale.
*cone-0.84.20100819-r1 (12 Nov 2010)
diff --git a/mail-client/cone/cone-0.84.20100819-r1.ebuild b/mail-client/cone/cone-0.84.20100819-r1.ebuild
index c877eab64ca6..cb4a94de77ef 100644
--- a/mail-client/cone/cone-0.84.20100819-r1.ebuild
+++ b/mail-client/cone/cone-0.84.20100819-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/cone/cone-0.84.20100819-r1.ebuild,v 1.1 2010/11/12 08:37:00 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/cone/cone-0.84.20100819-r1.ebuild,v 1.2 2010/11/15 02:37:53 radhermit Exp $
EAPI="2"
@@ -30,6 +30,7 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-aspell-automagic.patch
+ epatch "${FILESDIR}"/${P}-rfc2045-tests-lang.patch
cd cone
LIBTOOLIZE="true" eautoreconf
diff --git a/mail-client/cone/files/cone-0.84.20100819-rfc2045-tests-lang.patch b/mail-client/cone/files/cone-0.84.20100819-rfc2045-tests-lang.patch
new file mode 100644
index 000000000000..aa00d553b259
--- /dev/null
+++ b/mail-client/cone/files/cone-0.84.20100819-rfc2045-tests-lang.patch
@@ -0,0 +1,41 @@
+--- cone-0.84.20100819/rfc2045/testsuite.orig 2010-11-14 13:37:06.025969423 -0800
++++ cone-0.84.20100819/rfc2045/testsuite 2010-11-14 13:37:23.489105624 -0800
+@@ -56,7 +56,7 @@
+
+ --aaa---
+ EOF
+-LANG=en_US.utf-8 ./reformime -i <testsuite.dat | sed 's/^charset:.*/charset: iso-8859-1/'
++./reformime -i <testsuite.dat | sed 's/^charset:.*/charset: iso-8859-1/'
+
+ echo "foo" >confmdtest
+
+@@ -65,7 +65,7 @@
+ ./makemime -c application/octet-stream -C utf-8 -N footest:1 confmdtest
+ ./makemime -c application/octet-stream -C utf-8 -N f:::::::::::::::::::::::::1 confmdtest
+
+-LANG=en_US.utf-8 ./reformime -h '=?iso-8859-1?Q?H=F3la!?= test =?iso-8859-1?Q?H=F3la!_?= =?iso-8859-1?Q?H=F3la!?= test'
++./reformime -h '=?iso-8859-1?Q?H=F3la!?= test =?iso-8859-1?Q?H=F3la!_?= =?iso-8859-1?Q?H=F3la!?= test'
+ rm -f confmdtest
+
+ cat >testsuite.dat <<EOF
+@@ -77,13 +77,13 @@
+
+ testing
+ EOF
+-LANG=en_US.utf-8 ./reformime -i <./testsuite.dat
+-LANG=en_US.utf-8 ./reformime -H '=?iso-8859-1?Q?H=F3la!?= test <test1@example.com>'
+-LANG=en_US.utf-8 ./reformime -H '=?iso-8859-1?Q?H=F3la=22?= test <test1@example.com>'
+-LANG=en_US.utf-8 ./reformime -O 'Hóla <user@Hóla.example.com>, user@example.com (Hóla), John Smith <user@example.com>, user2@example.com, "John Smith (Accounting)" <user3@example.com>, "Hóla Smith (Accounting)" <user4@example.com>, john smith <user@hóla.example.com>'
++./reformime -i <./testsuite.dat
++./reformime -H '=?iso-8859-1?Q?H=F3la!?= test <test1@example.com>'
++./reformime -H '=?iso-8859-1?Q?H=F3la=22?= test <test1@example.com>'
++./reformime -O 'Hóla <user@Hóla.example.com>, user@example.com (Hóla), John Smith <user@example.com>, user2@example.com, "John Smith (Accounting)" <user3@example.com>, "Hóla Smith (Accounting)" <user4@example.com>, john smith <user@hóla.example.com>'
+
+-LANG=en_US.utf-8 ./reformime -H '=?UTF-8?B?SMOzbGE=?= <user@xn--hla-gna.example.com>, =?UTF-8?B?SMOzbGE=?= <user@example.com>, John Smith <user@example.com>, user2@example.com, "John Smith (Accounting)" <user3@example.com>, =?UTF-8?B?SMOzbGE=?= Smith =?UTF-8?B?KEFjY291bnRpbmcp?= <user4@example.com>, john smith <user@xn--hla-gna.example.com>'
++./reformime -H '=?UTF-8?B?SMOzbGE=?= <user@xn--hla-gna.example.com>, =?UTF-8?B?SMOzbGE=?= <user@example.com>, John Smith <user@example.com>, user2@example.com, "John Smith (Accounting)" <user3@example.com>, =?UTF-8?B?SMOzbGE=?= Smith =?UTF-8?B?KEFjY291bnRpbmcp?= <user4@example.com>, john smith <user@xn--hla-gna.example.com>'
+
+-LANG=en_US.utf-8 ./reformime -H 'list: address1 <address1@example.com>, address2 <address2@example.com>;'
++./reformime -H 'list: address1 <address1@example.com>, address2 <address2@example.com>;'
+
+-LANG=en_US.utf-8 ./reformime -O 'list: address1 <address1@example.com>, address2 <address2@example.com>;'
++./reformime -O 'list: address1 <address1@example.com>, address2 <address2@example.com>;'