summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2010-04-20 19:08:07 +0000
committerChristian Faulhammer <fauli@gentoo.org>2010-04-20 19:08:07 +0000
commit9b37171f7bede3e4f69ca61df0dde732c58ebc33 (patch)
tree3cc4e0c80a7ec536d292d102955d645434caf334 /mail-client/etpan-ng/etpan-ng-0.7.1-r1.ebuild
parentRDEPEND was incomplete. Fixed with kind permission from armin76. (diff)
downloadgentoo-2-9b37171f7bede3e4f69ca61df0dde732c58ebc33.tar.gz
gentoo-2-9b37171f7bede3e4f69ca61df0dde732c58ebc33.tar.bz2
gentoo-2-9b37171f7bede3e4f69ca61df0dde732c58ebc33.zip
respect LDFLAGS as reported in bug 247712, patch provided by Kacper Kowalik <xarthisius DOT kk AT gmail DOT com>
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'mail-client/etpan-ng/etpan-ng-0.7.1-r1.ebuild')
-rw-r--r--mail-client/etpan-ng/etpan-ng-0.7.1-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/mail-client/etpan-ng/etpan-ng-0.7.1-r1.ebuild b/mail-client/etpan-ng/etpan-ng-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..c149b5227087
--- /dev/null
+++ b/mail-client/etpan-ng/etpan-ng-0.7.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/etpan-ng/etpan-ng-0.7.1-r1.ebuild,v 1.1 2010/04/20 19:08:07 fauli Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="etPan is a console mail client that is based on libEtPan!"
+HOMEPAGE="http://libetpan.sourceforge.net/etpan/"
+SRC_URI="mirror://sourceforge/libetpan/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug ldap"
+
+DEPEND=">=net-libs/libetpan-0.35
+ sys-libs/ncurses
+ ldap? ( net-nds/openldap )
+ || ( sys-devel/bison dev-util/yacc dev-util/byacc )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-as-needed.patch"
+ eautoreconf
+}
+
+src_compile() {
+ sed -i -e "s:@bindir@:${D}/@bindir@:" src/Makefile.in
+
+ econf \
+ `use_enable debug` \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc Changelog NEWS README TODO contrib/etpan-make-vtree.pl doc/*
+}