summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-02-02 17:45:35 +0000
committerJeroen Roovers <jer@gentoo.org>2010-02-02 17:45:35 +0000
commit116d60d9b9ddb1b843a58c6cb24424e7d4c00760 (patch)
treec95e6f0f1eafd16a4462a8175bb6bdc562e32cfb /mail-client/nail/nail-12.4.ebuild
parentVersion bump (diff)
downloadgentoo-2-116d60d9b9ddb1b843a58c6cb24424e7d4c00760.tar.gz
gentoo-2-116d60d9b9ddb1b843a58c6cb24424e7d4c00760.tar.bz2
gentoo-2-116d60d9b9ddb1b843a58c6cb24424e7d4c00760.zip
Version bump thanks to Andreas Niederl and many others (bug #156878). Respect CC (bug #244132).
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'mail-client/nail/nail-12.4.ebuild')
-rw-r--r--mail-client/nail/nail-12.4.ebuild87
1 files changed, 87 insertions, 0 deletions
diff --git a/mail-client/nail/nail-12.4.ebuild b/mail-client/nail/nail-12.4.ebuild
new file mode 100644
index 000000000000..6d2784e83ea3
--- /dev/null
+++ b/mail-client/nail/nail-12.4.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/nail/nail-12.4.ebuild,v 1.1 2010/02/02 17:45:35 jer Exp $
+
+EAPI="2"
+
+inherit eutils
+
+HOMEPAGE="http://heirloom.sourceforge.net/"
+DESCRIPTION="an enhanced mailx-compatible mail client"
+LICENSE="BSD"
+
+MY_PN="mailx"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://sourceforge/project/heirloom/heirloom-${MY_PN}/${PV}/${MY_P}.tar.bz2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ssl net kerberos"
+
+PROVIDE="virtual/mailx"
+RDEPEND="
+ ssl? ( dev-libs/openssl )
+ kerberos? ( virtual/krb5 )
+ !virtual/mailx
+"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+remove_ssl() {
+ elog "Disabling SSL support"
+ sed -i -e 's~#define USE_\(OPEN\)\?SSL~#undef USE_\1SSL~' config.h
+ sed -i -e 's~-ssl~~' -e 's~-lcrypto~~' LIBS
+}
+
+remove_sockets() {
+ elog "Not enabling sockets (thus disabling IMAP, POP and SMTP)"
+ sed -i -e 's~#define HAVE_SOCKETS~#undef HAVE_SOCKETS~' config.h
+}
+
+src_prepare() {
+ # Do not strip the binary
+ sed -i -e '/STRIP/d' Makefile
+}
+
+src_configure() {
+ # Build config.h and LIBS, neccesary to tweak the config
+ make config.h LIBS
+
+ # Logic to 'configure' the package
+ if use net && ! use ssl ; then
+ remove_ssl
+ elif ! use net ; then
+ # Linking to ssl without net support is pointless
+ remove_ssl
+ remove_sockets
+ fi
+}
+
+src_compile() {
+ # No configure script to check for and set this
+ tc-export CC
+
+ emake \
+ PREFIX=/usr \
+ MAILSPOOL='/var/spool/mail' \
+ || die "emake failed"
+}
+
+src_install () {
+ # Use /usr/lib/sendmail by default and provide an example
+ cat <<- EOSMTP >> nail.rc
+
+ # Use the local sendmail (/usr/lib/sendmail) binary by default.
+ # (Uncomment the following line to use a SMTP server)
+ #set smtp=localhost
+ EOSMTP
+
+ make DESTDIR="${D}" \
+ UCBINSTALL=$(type -p install) \
+ PREFIX=/usr install || die "install failed"
+ dodoc AUTHORS INSTALL README
+ dodir /bin
+ dosym /usr/bin/mailx /bin/mail
+ dosym /usr/bin/mailx /usr/bin/mail
+ dosym /usr/bin/mailx /usr/bin/Mail
+}