summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-10-03 14:51:29 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-10-03 14:51:29 +0000
commit452d4c0ef4f939b3d00a926056e54b0452559c74 (patch)
tree4e62e1c7a893a5b7eda6d16656d6844c86229d6b /mail-client/nail
parentFix potential buffer overflow (bug #339541). Thanks Diego for reporting. (diff)
downloadgentoo-2-452d4c0ef4f939b3d00a926056e54b0452559c74.tar.gz
gentoo-2-452d4c0ef4f939b3d00a926056e54b0452559c74.tar.bz2
gentoo-2-452d4c0ef4f939b3d00a926056e54b0452559c74.zip
Change sendmail default path (bug #339308 by Joakim Tjernlund); link man pages like commends are; use emake for install; add die statements. Take over maintainership.
(Portage version: 2.2_rc88/cvs/Linux x86_64)
Diffstat (limited to 'mail-client/nail')
-rw-r--r--mail-client/nail/ChangeLog10
-rw-r--r--mail-client/nail/metadata.xml36
-rw-r--r--mail-client/nail/nail-12.4-r2.ebuild106
3 files changed, 135 insertions, 17 deletions
diff --git a/mail-client/nail/ChangeLog b/mail-client/nail/ChangeLog
index e69d2fdddf3f..3b6265ab411a 100644
--- a/mail-client/nail/ChangeLog
+++ b/mail-client/nail/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for mail-client/nail
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/nail/ChangeLog,v 1.74 2010/09/23 20:51:49 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/nail/ChangeLog,v 1.75 2010/10/03 14:51:29 flameeyes Exp $
+
+*nail-12.4-r2 (03 Oct 2010)
+
+ 03 Oct 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +nail-12.4-r2.ebuild, metadata.xml:
+ Change sendmail default path (bug #339308 by Joakim Tjernlund); link man
+ pages like commends are; use emake for install; add die statements. Take
+ over maintainership.
23 Sep 2010; Markus Meier <maekke@gentoo.org> nail-12.4-r1.ebuild:
add ~arm, bug #324129
diff --git a/mail-client/nail/metadata.xml b/mail-client/nail/metadata.xml
index e0b4a839f0a2..016708f88184 100644
--- a/mail-client/nail/metadata.xml
+++ b/mail-client/nail/metadata.xml
@@ -1,22 +1,26 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>net-mail</herd>
-<use>
- <flag name='net'>
- Enable support for network protocols (POP, IMAP and SMTP). If you
- only need to send mail with the local Transport Agent, disabling
- this will get you support for only /usr/sbin/sendmail call.
- </flag>
+ <herd>net-mail</herd>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
- <flag name='ssl'>
- If network is enabled, this adds support for S/MIME and
- SSL/TLS-powered protocols through <pkg>dev-libs/openssl</pkg>.
- </flag>
+ <use>
+ <flag name='net'>
+ Enable support for network protocols (POP, IMAP and SMTP). If you
+ only need to send mail with the local Transport Agent, disabling
+ this will get you support for only /usr/sbin/sendmail call.
+ </flag>
- <flag name='kerberos'>
- If network is enabled, this adds support for GSSAPI login on IMAP
- through <pkg>virtual/kerberos</pkg>.
- </flag>
-</use>
+ <flag name='ssl'>
+ If network is enabled, this adds support for S/MIME and
+ SSL/TLS-powered protocols through <pkg>dev-libs/openssl</pkg>.
+ </flag>
+
+ <flag name='kerberos'>
+ If network is enabled, this adds support for GSSAPI login on IMAP
+ through <pkg>virtual/kerberos</pkg>.
+ </flag>
+ </use>
</pkgmetadata>
diff --git a/mail-client/nail/nail-12.4-r2.ebuild b/mail-client/nail/nail-12.4-r2.ebuild
new file mode 100644
index 000000000000..8c2f5d33ba6b
--- /dev/null
+++ b/mail-client/nail/nail-12.4-r2.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/nail/nail-12.4-r2.ebuild,v 1.1 2010/10/03 14:51:29 flameeyes Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+HOMEPAGE="http://heirloom.sourceforge.net/"
+DESCRIPTION="an enhanced mailx-compatible mail client"
+LICENSE="BSD"
+
+MY_PN="mailx"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://sourceforge/project/heirloom/heirloom-${MY_PN}/${PV}/${MY_P}.tar.bz2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="ssl net kerberos"
+
+PROVIDE="virtual/mailx"
+RDEPEND="
+ net? (
+ ssl? ( dev-libs/openssl )
+ kerberos? ( virtual/krb5 )
+ )
+ !virtual/mailx
+"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+undef() {
+ sed -i -e "/$1/s:#define:#undef:" config.h || die
+}
+
+droplib() {
+ sed -i -e "/$1/s:^:#:" LIBS || die
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-debian.patch \
+ "${FILESDIR}"/${P}-openssl-1.patch
+ # Do not strip the binary
+ sed -i -e '/STRIP/d' Makefile
+}
+
+src_configure() {
+ # Build config.h and LIBS, neccesary to tweak the config
+ make config.h LIBS
+
+ # Logic to 'configure' the package
+
+ if ! use ssl || ! use net ; then
+ undef 'USE_\(OPEN\)\?SSL'
+ droplib -lssl
+ fi
+
+ if ! use kerberos || ! use net ; then
+ undef 'USE_GSSAPI'
+ droplib -lgssapi_krb5
+ fi
+
+ if ! use net ; then
+ undef 'HAVE_SOCKETS'
+ fi
+}
+
+src_compile() {
+ # No configure script to check for and set this
+ tc-export CC
+
+ emake \
+ CPPFLAGS="${CPPFLAGS} -D_GNU_SOURCE" \
+ PREFIX="${EPREFIX}"/usr SYSCONFDIR="${EPREFIX}"/etc \
+ SENDMAIL="${EPREFIX}/usr/sbin/sendmail" \
+ MAILSPOOL='/var/spool/mail' \
+ || die "emake failed"
+}
+
+src_install () {
+ # Use /usr/sbin/sendmail by default and provide an example
+ cat <<- EOSMTP >> nail.rc
+
+ # Use the local sendmail (/usr/sbin/sendmail) binary by default.
+ # (Uncomment the following line to use a SMTP server)
+ #set smtp=localhost
+
+ # Ask for CC: list too.
+ set askcc
+ EOSMTP
+
+ emake DESTDIR="${D}" \
+ UCBINSTALL=$(type -p install) \
+ PREFIX="${EPREFIX}"/usr SYSCONFDIR="${EPREFIX}"/etc install \
+ || die
+
+ dodoc AUTHORS README || die
+
+ dodir /bin
+ dosym ../usr/bin/mailx /bin/mail || die
+ dosym mailx /usr/bin/mail || die
+ dosym mailx /usr/bin/Mail || die
+
+ dosym mailx.1 /usr/share/man/man1/mail.1 || die
+ dosym mailx.1 /usr/share/man/man1/Mail.1 || die
+}