summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2004-12-17 23:58:21 +0000
committerSven Wegener <swegener@gentoo.org>2004-12-17 23:58:21 +0000
commit0c419d8b65f11a1c3b39fcc4b07e0de37e866d79 (patch)
tree4ef2e596741942813656070e272b421fa41607aa /mail-client/pine
parentmail-client/pine:largeterminal - Add support for large terminals by doubling ... (diff)
downloadgentoo-2-0c419d8b65f11a1c3b39fcc4b07e0de37e866d79.tar.gz
gentoo-2-0c419d8b65f11a1c3b39fcc4b07e0de37e866d79.tar.bz2
gentoo-2-0c419d8b65f11a1c3b39fcc4b07e0de37e866d79.zip
Revision bump. Support for the largeterminal USE flag that adds support for large terminals by doubling the size of pine's internal display buffer.
Diffstat (limited to 'mail-client/pine')
-rw-r--r--mail-client/pine/ChangeLog9
-rw-r--r--mail-client/pine/files/digest-pine-4.61-r52
-rw-r--r--mail-client/pine/files/pine-4.61-largeterminal.patch14
-rw-r--r--mail-client/pine/pine-4.61-r5.ebuild160
4 files changed, 184 insertions, 1 deletions
diff --git a/mail-client/pine/ChangeLog b/mail-client/pine/ChangeLog
index b2f46e122665..822ba5cb3fde 100644
--- a/mail-client/pine/ChangeLog
+++ b/mail-client/pine/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for mail-client/pine
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/pine/ChangeLog,v 1.29 2004/11/30 01:24:48 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/pine/ChangeLog,v 1.30 2004/12/17 23:58:21 swegener Exp $
+
+*pine-4.61-r5 (18 Dec 2004)
+
+ 18 Dec 2004; Sven Wegener <swegener@gentoo.org>
+ +files/pine-4.61-largeterminal.patch, +pine-4.61-r5.ebuild:
+ Revision bump. Support for the largeterminal USE flag that adds support for
+ large terminals by doubling the size of pine's internal display buffer.
30 Nov 2004; Andrej Kacian <ticho@gentoo.org>
-files/imap-4.7c2-flock+maildir.patch, -files/pine-4.21-fixhome.patch,
diff --git a/mail-client/pine/files/digest-pine-4.61-r5 b/mail-client/pine/files/digest-pine-4.61-r5
new file mode 100644
index 000000000000..d7429f16d1a9
--- /dev/null
+++ b/mail-client/pine/files/digest-pine-4.61-r5
@@ -0,0 +1,2 @@
+MD5 885c6aa4f4f16fcb83a49ef6c025307e pine4.61.tar.bz2 3032253
+MD5 f8a98b202010698fc680e1ff06b8e425 pine-4.61-r2-chappa-all.patch.gz 160672
diff --git a/mail-client/pine/files/pine-4.61-largeterminal.patch b/mail-client/pine/files/pine-4.61-largeterminal.patch
new file mode 100644
index 000000000000..c046546dba3c
--- /dev/null
+++ b/mail-client/pine/files/pine-4.61-largeterminal.patch
@@ -0,0 +1,14 @@
+diff -Nur pine4.61.orig/pine/osdep/os-lnx.h pine4.61/pine/osdep/os-lnx.h
+--- pine4.61.orig/pine/osdep/os-lnx.h 2004-12-18 00:33:46.162401405 +0100
++++ pine4.61/pine/osdep/os-lnx.h 2004-12-18 00:34:14.473012057 +0100
+@@ -247,8 +247,8 @@
+
+
+ /*-- Max screen pine will display on. Used to define some array sizes --*/
+-#define MAX_SCREEN_COLS (170)
+-#define MAX_SCREEN_ROWS (200)
++#define MAX_SCREEN_COLS (340)
++#define MAX_SCREEN_ROWS (400)
+
+
+ /*----------------------------------------------------------------------
diff --git a/mail-client/pine/pine-4.61-r5.ebuild b/mail-client/pine/pine-4.61-r5.ebuild
new file mode 100644
index 000000000000..51c0dd27977f
--- /dev/null
+++ b/mail-client/pine/pine-4.61-r5.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/pine/pine-4.61-r5.ebuild,v 1.1 2004/12/17 23:58:21 swegener Exp $
+
+inherit eutils
+
+# Using this ugly hack, since we're using chappa patch revision 1 (see #59573)
+CHAPPA_PF="${P}-r2"
+
+DESCRIPTION="A tool for reading, sending and managing electronic messages."
+HOMEPAGE="http://www.washington.edu/pine/
+ http://www.math.washington.edu/~chappa/pine/patches/"
+SRC_URI="ftp://ftp.cac.washington.edu/pine/${PN}${PV}.tar.bz2
+ mirror://gentoo/${CHAPPA_PF}-chappa-all.patch.gz"
+# ipv6? (
+# http://www.ngn.euro6ix.org/IPv6/${PN}/${P}-v6-20031001.diff
+# http://www.ngn.euro6ix.org/IPv6/${PN}/readme.${P}-v6-20031001
+# )"
+
+LICENSE="PICO"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64 ~ppc-macos"
+#IUSE="ipv6 maildir ssl ldap kerberos passfile"
+IUSE="ssl ldap kerberos largeterminal pam passfile debug"
+
+DEPEND="virtual/libc
+ >=sys-apps/sed-4
+ >=sys-libs/ncurses-5.1
+ pam? ( >=sys-libs/pam-0.72 )
+ ssl? ( dev-libs/openssl )
+ ldap? ( net-nds/openldap )
+ kerberos? ( app-crypt/mit-krb5 )"
+RDEPEND="${DEPEND} app-misc/mime-types"
+
+S="${WORKDIR}/${P/-/}"
+
+src_unpack() {
+ unpack ${A} && cd "${S}"
+
+ # Various fixes and features.
+ epatch "${WORKDIR}/${CHAPPA_PF}-chappa-all.patch"
+ # UTF8 support. Not ported. 4.60 has utf8 some conversion.
+ #epatch "${DISTDIR}/${PN}${PV}-utf8-to-singlebyte.patch"
+ # Fix flock() emulation.
+ cp "${FILESDIR}/flock.c" "${S}/imap/src/osdep/unix"
+ # Build the flock() emulation.
+ epatch "${FILESDIR}/imap-4.7c2-flock_4.60.patch"
+ if use ldap ; then
+ # Link to shared ldap libs instead of static.
+ epatch "${FILESDIR}/pine-4.30-ldap.patch"
+ mkdir "${S}/ldap"
+ ln -s /usr/lib "${S}/ldap/libraries"
+ ln -s /usr/include "${S}/ldap/include"
+ fi
+# if use ipv6 ; then
+# epatch "${DISTDIR}/${P}-v6-20031001.diff"
+# fi
+ if use passfile ; then
+ #Is this really the correct place to define it?
+ epatch "${FILESDIR}/pine-4.56-passfile.patch"
+ fi
+ if use largeterminal ; then
+ # Add support for large terminals by doubling the size of pine's internal display buffer
+ epatch "${FILESDIR}/pine-4.61-largeterminal.patch"
+ fi
+
+ # Something from RedHat.
+ epatch "${FILESDIR}/pine-4.31-segfix.patch"
+ # Create lockfiles with a mode of 0600 instead of 0666.
+ epatch "${FILESDIR}/pine-4.40-lockfile-perm.patch"
+ # Add missing time.h includes.
+ epatch "${FILESDIR}/imap-2000-time.patch"
+ # Bug #23336 - makes pine transparent in terms that support it.
+ epatch "${FILESDIR}/transparency.patch"
+
+ # Bug #72861 - relaxes subject length for base64-encoded subjects
+ epatch "${FILESDIR}/pine-4.61-subjectlength.patch"
+
+ if use debug ; then
+ sed -e "s:-g -DDEBUG -DDEBUGJOURNAL:${CFLAGS} -g -DDEBUG -DDEBUGJOURNAL:" \
+ -i "${S}/pine/makefile.lnx" || die "sed pine/makefile.lnx failed"
+ sed -e "s:-g -DDEBUG:${CFLAGS} -g -DDEBUG:" \
+ -i "${S}/pico/makefile.lnx" || die "sed pico/makefile.lnx failed"
+ else
+ sed -e "s:-g -DDEBUG -DDEBUGJOURNAL:${CFLAGS}:" \
+ -i "${S}/pine/makefile.lnx" || die "sed pine/makefile.lnx failed"
+ sed -e "s:-g -DDEBUG:${CFLAGS}:" \
+ -i "${S}/pico/makefile.lnx" || die "sed pico/makefile.lnx failed"
+ fi
+
+ sed -e "s:/usr/local/lib/pine.conf:/etc/pine.conf:" \
+ -i "${S}/pine/osdep/os-lnx.h" || die "sed os-lnx.h failed"
+}
+
+src_compile() {
+ local myconf
+ if use ssl ; then
+ myconf="${myconf} SSLDIR=/usr SSLTYPE=unix SSLCERTS=/etc/ssl/certs"
+ sed -e "s:\$(SSLDIR)/certs:/etc/ssl/certs:" \
+ -e "s:\$(SSLCERTS):/etc/ssl/certs:" \
+ -e "s:-I\$(SSLINCLUDE) ::" \
+ -i "${S}/imap/src/osdep/unix/Makefile" || die "sed Makefile failed"
+ else
+ myconf="${myconf} NOSSL"
+ fi
+ if use ldap ; then
+ ./contrib/ldap-setup lnp lnp
+ myconf="${myconf} LDAPCFLAGS=-DENABLE_LDAP"
+ else
+ myconf="${myconf} NOLDAP"
+ fi
+ if use kerberos ; then
+ myconf="${myconf} EXTRAAUTHENTICATORS=gss"
+ fi
+ if use pam ; then
+ target=lnp
+ else
+ target=slx
+ fi
+
+ ./build ${myconf} ${target} || die "compile problem"
+}
+
+src_install() {
+ dobin bin/pine bin/pico bin/pilot bin/mtest bin/rpdump bin/rpload \
+ mailutil/mailutil
+
+ # Only mailbase should install /etc/mailcap
+# donewins doc/mailcap.unx mailcap
+
+ doman doc/pine.1 doc/pico.1 doc/pilot.1 doc/rpdump.1 doc/rpload.1 \
+ imap/src/mailutil/mailutil.1
+ dodoc CPYRIGHT README doc/brochure.txt doc/tech-notes.txt
+# if use ipv6 ; then
+# dodoc "${DISTDIR}/readme.${P}-v6-20031001"
+# fi
+
+ docinto imap
+ dodoc imap/docs/*.txt imap/docs/CONFIG imap/docs/RELNOTES
+
+ docinto imap/rfc
+ dodoc imap/docs/rfc/*.txt
+
+ docinto html/tech-notes
+ dohtml -r doc/tech-notes/
+}
+
+pkg_postinst() {
+ einfo
+ einfo "This build of Pine has Maildir support built in as"
+ einfo "part of the chappa-all patch."
+ einfo
+ einfo "If you have a maildir at ~/Maildir it will be your"
+ einfo "default INBOX. The path may be changed with the"
+ einfo "\"maildir-location\" setting in Pine."
+ einfo
+ einfo "If you don't have any maildirs Pine works as before"
+ einfo "with the INBOX at /var/spool/mail/."
+ einfo
+}