summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2009-01-02 13:08:07 +0000
committerBenedikt Boehm <hollow@gentoo.org>2009-01-02 13:08:07 +0000
commitcb159ebe0d1cd96de97342dc46cca4c190b79359 (patch)
tree42410797b64e9e80b15af439935b127fdc07c138 /mail-client/roundcube
parentarm/s390/sh stable (diff)
downloadgentoo-2-cb159ebe0d1cd96de97342dc46cca4c190b79359.tar.gz
gentoo-2-cb159ebe0d1cd96de97342dc46cca4c190b79359.tar.bz2
gentoo-2-cb159ebe0d1cd96de97342dc46cca4c190b79359.zip
initial commit
(Portage version: 2.2_rc20/cvs/Linux 2.6.22-vs2.3.0.34-gentoo x86_64)
Diffstat (limited to 'mail-client/roundcube')
-rw-r--r--mail-client/roundcube/ChangeLog10
-rw-r--r--mail-client/roundcube/files/postinstall-en.txt77
-rw-r--r--mail-client/roundcube/metadata.xml5
-rw-r--r--mail-client/roundcube/roundcube-0.2.ebuild83
4 files changed, 175 insertions, 0 deletions
diff --git a/mail-client/roundcube/ChangeLog b/mail-client/roundcube/ChangeLog
new file mode 100644
index 000000000000..5dffda40909c
--- /dev/null
+++ b/mail-client/roundcube/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for mail-client/roundcube
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/ChangeLog,v 1.1 2009/01/02 13:08:07 hollow Exp $
+
+*roundcube-0.2 (02 Jan 2009)
+
+ 02 Jan 2009; Benedikt Böhm <hollow@gentoo.org> +files/postinstall-en.txt,
+ +metadata.xml, +roundcube-0.2.ebuild:
+ initial commit
+
diff --git a/mail-client/roundcube/files/postinstall-en.txt b/mail-client/roundcube/files/postinstall-en.txt
new file mode 100644
index 000000000000..d3d8138b62f8
--- /dev/null
+++ b/mail-client/roundcube/files/postinstall-en.txt
@@ -0,0 +1,77 @@
+0. DATABASE SETUP
+
+
+* MySQL 4.1.x/5.x
+-----------------
+For MySQL version 4.1 and up, it's recommended to create the database for
+RoundCube with utf-8 charset. Here's an example of the init procedure:
+
+# mysql
+> CREATE DATABASE roundcubemail DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci;
+> GRANT ALL PRIVILEGES ON roundcubemail.* TO roundcube@localhost
+ IDENTIFIED BY 'password';
+> quit
+
+# mysql roundcubemail < ${MY_INSTALLDIR}/SQL/mysql5.initial.sql
+
+* SQLite
+--------
+Sqlite requires specifically php5 (sqlite in php4 currently doesn't
+work with roundcube), and you need sqlite 2 (preferably 2.8) to setup
+the sqlite db (sqlite 3.x also doesn't work at the moment). Here is
+an example how you can setup the sqlite.db for roundcube:
+
+# sqlite -init SQL/sqlite.initial.sql sqlite.db
+
+Make sure your configuration points to the sqlite.db file and that the
+webserver can write to the file and the directory containing the file.
+
+* PostgreSQL
+------------
+To use RoundCube with PostgreSQL support you have to follow these
+simple steps, which have to be done as the postgres system user (or
+which ever is the database superuser):
+
+$ createuser roundcube
+$ createdb -O roundcube roundcubemail
+$ psql roundcubemail
+
+roundcubemail =# ALTER USER roundcube WITH PASSWORD 'the_new_password';
+roundcubemail =# \c - roundcube
+roundcubemail => \i ${MY_INSTALLDIR}/SQL/postgres.initial.sql
+
+All this has been tested with PostgreSQL 8.x and 7.4.x. Older
+versions don't have a -O option for the createdb, so if you are
+using that version you'll have to change ownership of the DB later.
+
+
+1. ROUNDCUBE CONFIGURATION
+
+Modify the files in ${MY_INSTALLDIR}/config/* to suit your local environment
+
+Details about the config parameters can be found in the config files.
+See http://trac.roundcube.net/wiki/Howto_Install for even more guidance.
+
+
+2. PHP CONFIGURATION
+
+ - error_reporting E_ALL & ~E_NOTICE (or lower)
+ - file_uploads On (for attachment upload features)
+ - session.auto_start Off
+ - magic_quotes_gpc Off
+ - memory_limit (increase as suitable to support large attachments)
+
+
+3. WEBSERVER CONFIGURATION
+
+Access through your webserver to at least the following directories should be denied:
+
+ * /conf
+ * /temp
+ * /logs
+
+Roundcube uses .htaccess files to protect these directories if you are using Apache;
+be sure to allow override of the Limit directives to get them taken into account.
+
+If you are NOT using Apache, it is your responsibility to take care of the above as
+needed by your webserver.
diff --git a/mail-client/roundcube/metadata.xml b/mail-client/roundcube/metadata.xml
new file mode 100644
index 000000000000..95c06f0095bb
--- /dev/null
+++ b/mail-client/roundcube/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>web-apps</herd>
+</pkgmetadata>
diff --git a/mail-client/roundcube/roundcube-0.2.ebuild b/mail-client/roundcube/roundcube-0.2.ebuild
new file mode 100644
index 000000000000..95f012205c4c
--- /dev/null
+++ b/mail-client/roundcube/roundcube-0.2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/roundcube-0.2.ebuild,v 1.1 2009/01/02 13:08:07 hollow Exp $
+
+MY_PN="${PN}mail"
+MY_P="${MY_PN}-${PV}-stable"
+
+inherit eutils webapp depend.php depend.apache
+
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="http://roundcube.net"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-2 BSD PHP-2.02 PHP-3 MIT public-domain"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap mysql postgres sqlite ssl spell"
+
+DEPEND=""
+RDEPEND="dev-php/PEAR-PEAR"
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ local flags="crypt iconv imap pcre session unicode"
+ use ldap && flags="${flags} ldap"
+ use ssl && flags="${flags} ssl"
+ use spell && flags="${flags} curl ssl"
+
+ # check for required PHP features
+ if ! use mysql && ! use postgres && ! use sqlite ; then
+ local dbflags="mysql mysqli postgres sqlite"
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} || \
+ ! PHPCHECKNODIE="yes" require_php_with_any_use ${dbflags} ; then
+ die "Re-install ${PHP_PKG} with ${flags} and at least one of ${dbflags} in USE."
+ fi
+ else
+ for db in postgres sqlite ; do
+ use ${db} && flags="${flags} ${db}"
+ done
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} || \
+ ( use mysql && ! PHPCHECKNODIE="yes" require_php_with_any_use mysql mysqli ) ; then
+ local diemsg="Re-install ${PHP_PKG} with ${flags}"
+ use mysql && diemsg="${diemsg} and at least one of mysql mysqli"
+ die "${diemsg} in USE"
+ fi
+ fi
+
+ # add some warnings about optional functionality
+ if ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ; then
+ ewarn "IMAP quota display will not work correctly without GD support in PHP."
+ ewarn "Recompile PHP with either gd or gd-external in USE if you want this feature."
+ ewarn
+ fi
+
+ webapp_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ mv config/db.inc.php{.dist,}
+ mv config/main.inc.php{.dist,}
+}
+
+src_install () {
+ webapp_src_preinst
+ dodoc CHANGELOG INSTALL README UPGRADING
+
+ cp -R [[:lower:]]* SQL "${D}/${MY_HTDOCSDIR}"
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/{db,main}.inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postupgrade_txt en UPGRADING
+ webapp_src_install
+}