summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2006-10-26 14:39:21 +0000
committerMarius Mauch <genone@gentoo.org>2006-10-26 14:39:21 +0000
commitd7235a0ef3dbe80d6698dcbefe476b990f3dae58 (patch)
treeef8ba792bffdc3bd3060b50ebf8b69c115f53d8e /mail-client/sylpheed-claws
parentMasked vdr-adzap for removal out of official portage-tree. (diff)
downloadgentoo-2-d7235a0ef3dbe80d6698dcbefe476b990f3dae58.tar.gz
gentoo-2-d7235a0ef3dbe80d6698dcbefe476b990f3dae58.tar.bz2
gentoo-2-d7235a0ef3dbe80d6698dcbefe476b990f3dae58.zip
Version bump, adding helper script to rebuild plugins
(Portage version: 2.1.2_pre2-r6)
Diffstat (limited to 'mail-client/sylpheed-claws')
-rw-r--r--mail-client/sylpheed-claws/ChangeLog8
-rw-r--r--mail-client/sylpheed-claws/files/digest-sylpheed-claws-2.5.63
-rw-r--r--mail-client/sylpheed-claws/files/plugins-rebuild.sh15
-rw-r--r--mail-client/sylpheed-claws/sylpheed-claws-2.5.6.ebuild145
4 files changed, 170 insertions, 1 deletions
diff --git a/mail-client/sylpheed-claws/ChangeLog b/mail-client/sylpheed-claws/ChangeLog
index f4bd68f6aee9..12ce3939b43c 100644
--- a/mail-client/sylpheed-claws/ChangeLog
+++ b/mail-client/sylpheed-claws/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/sylpheed-claws
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws/ChangeLog,v 1.113 2006/10/20 21:16:40 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws/ChangeLog,v 1.114 2006/10/26 14:39:20 genone Exp $
+
+*sylpheed-claws-2.5.6 (26 Oct 2006)
+
+ 26 Oct 2006; Marius Mauch <genone@gentoo.org> +files/plugins-rebuild.sh,
+ +sylpheed-claws-2.5.6.ebuild:
+ Version bump, adding helper script to rebuild plugins
20 Oct 2006; Bryan Østergaard <kloeri@gentoo.org>
sylpheed-claws-2.4.0.ebuild:
diff --git a/mail-client/sylpheed-claws/files/digest-sylpheed-claws-2.5.6 b/mail-client/sylpheed-claws/files/digest-sylpheed-claws-2.5.6
new file mode 100644
index 000000000000..897fa17b2eca
--- /dev/null
+++ b/mail-client/sylpheed-claws/files/digest-sylpheed-claws-2.5.6
@@ -0,0 +1,3 @@
+MD5 f342f7be46a3d2771f6aaad44838e513 sylpheed-claws-2.5.6.tar.bz2 5038633
+RMD160 08f60e1aeba911326993dde37b54b7dee2d5473f sylpheed-claws-2.5.6.tar.bz2 5038633
+SHA256 c4baf7107ba83b1a2546921cb8e04c886326d5c7e5946ceb1aaef87fcb9e41ea sylpheed-claws-2.5.6.tar.bz2 5038633
diff --git a/mail-client/sylpheed-claws/files/plugins-rebuild.sh b/mail-client/sylpheed-claws/files/plugins-rebuild.sh
new file mode 100644
index 000000000000..1f886c1d53d5
--- /dev/null
+++ b/mail-client/sylpheed-claws/files/plugins-rebuild.sh
@@ -0,0 +1,15 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws/files/plugins-rebuild.sh,v 1.1 2006/10/26 14:39:21 genone Exp $
+#!/bin/bash
+
+echo "Looking for sylpheed-claws plugins to rebuild ..."
+cd ${ROOT}/var/db/pkg
+PLUGINS=$(for d in mail-client/sylpheed-claws-[a-z]*; do /usr/lib/portage/bin/pkgname $d | cut -d' ' -f 1; done)
+echo
+echo "Found plugins:"
+echo "${PLUGINS}"
+echo
+echo "Rebuilding with given emerge options: $*"
+sleep 2
+emerge $* ${PLUGINS}
diff --git a/mail-client/sylpheed-claws/sylpheed-claws-2.5.6.ebuild b/mail-client/sylpheed-claws/sylpheed-claws-2.5.6.ebuild
new file mode 100644
index 000000000000..07c42b69cc62
--- /dev/null
+++ b/mail-client/sylpheed-claws/sylpheed-claws-2.5.6.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws/sylpheed-claws-2.5.6.ebuild,v 1.1 2006/10/26 14:39:20 genone Exp $
+
+IUSE="gnome dillo crypt spell ssl ldap ipv6 pda clamav xface kde imap spamassassin doc startup-notification bogofilter"
+
+inherit eutils
+
+DESCRIPTION="Sylpheed-Claws is an email client (and news reader) based on GTK+"
+HOMEPAGE="http://claws.sylpheed.org"
+
+if [ -n "${P/*_rc*/}" ]; then
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+else
+ MY_P="${P/_/-}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="http://claws.sylpheed.org/snapshots/${MY_P}.tar.bz2"
+fi
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+COMMONDEPEND=">=x11-libs/gtk+-2.6
+ pda? ( >=app-pda/jpilot-0.99 )
+ ssl? ( >=dev-libs/openssl-0.9.7 )
+ ldap? ( >=net-nds/openldap-2.0.7 )
+ crypt? ( >=app-crypt/gpgme-1.1.1 )
+ dillo? ( www-client/dillo )
+ spell? ( virtual/aspell-dict )
+ clamav? ( app-antivirus/clamav )
+ kde? ( kde-base/kdelibs )
+ imap? ( >=net-libs/libetpan-0.46 )
+ gnome? ( >=gnome-base/libgnomeprintui-2.2 )
+ startup-notification? ( x11-libs/startup-notification )
+ bogofilter? ( mail-filter/bogofilter )
+ !mail-client/sylpheed-claws-pgpinline" # included in the main package now
+
+DEPEND="${COMMONDEPEND}
+ xface? ( >=media-libs/compface-1.4 )
+ >=sys-apps/sed-4"
+
+RDEPEND="${COMMONDEPEND}
+ app-misc/mime-types
+ x11-misc/shared-mime-info"
+
+PROVIDE="virtual/sylpheed"
+
+PLUGIN_NAMES="acpi-notifier att-remover cachesaver etpan-privacy fetchinfo gtkhtml maildir mailmbox newmail notification perl rssyl smime synce vcalendar"
+
+src_compile() {
+ local myconf
+
+ # Optional features
+ myconf="${myconf} `use_enable gnome gnomeprint`"
+ myconf="${myconf} `use_enable imap libetpan`"
+ myconf="${myconf} `use_enable ipv6`"
+ myconf="${myconf} `use_enable ldap`"
+ myconf="${myconf} `use_enable pda jpilot`"
+ myconf="${myconf} `use_enable spell aspell`"
+ myconf="${myconf} `use_enable ssl openssl`"
+ myconf="${myconf} `use_enable xface compface`"
+ myconf="${myconf} `use_enable doc manual`"
+ myconf="${myconf} `use_enable startup-notification`"
+
+ # Optional plugins
+ myconf="${myconf} `use_enable clamav clamav-plugin`"
+ myconf="${myconf} `use_enable crypt pgpmime-plugin`"
+ myconf="${myconf} `use_enable crypt pgpinline-plugin`"
+ myconf="${myconf} `use_enable crypt pgpcore-plugin`"
+ myconf="${myconf} `use_enable dillo dillo-viewer-plugin`"
+ myconf="${myconf} `use_enable spamassassin spamassassin-plugin`"
+ myconf="${myconf} `use_enable bogofilter bogofilter-plugin`"
+
+ econf \
+ --enable-trayicon-plugin \
+ ${myconf} || die "./configure failed"
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ if [ -d ${D}/usr/share/gnome ]; then
+ dodir /usr/share/applications
+ mv ${D}/usr/share/{gnome/apps/Internet,applications}/sylpheed-claws.desktop
+ rm -rf ${D}/usr/share/gnome
+ fi
+
+ # Makefile install sylpheed-claws.png in /usr/share/icons/hicolor/48x48/apps
+ # => also install it in /usr/share/pixmaps for other desktop envs
+ # => also install higher resolution icons in /usr/share/icons/hicolor/...
+ insinto /usr/share/pixmaps
+ doins sylpheed-claws.png
+ local res resdir
+ for res in 64x64 128x128 ; do
+ resdir="/usr/share/icons/hicolor/${res}/apps"
+ insinto ${resdir}
+ newins sylpheed-claws-${res}.png sylpheed-claws.png
+ done
+
+ dodoc AUTHORS ChangeLog* INSTALL* NEWS README* TODO*
+ docinto tools
+ dodoc tools/README*
+
+ # install the extra tools
+ cd ${S}/tools
+ exeinto /usr/lib/${PN}/tools
+ doexe *.pl *.py *.rc *.conf *.sh
+ doexe tb2sylpheed update-po uudec
+
+ if use kde; then
+ local kdeprefix="$(kde-config --prefix)"
+ local servicescript="sylpheed-kdeservicemenu.pl"
+ cd ${S}/tools/kdeservicemenu
+ for f in sylpheed-attach-files.desktop sylpheed-compress-attach.desktop; do
+ sed -e "s:SCRIPT_PATH:${kdeprefix}/bin/${servicescript}:g" template_$f > $f
+ install -m 0644 $f ${D}/${kdeprefix}/share/apps/konqueror/servicemenus/$f
+ done
+ insinto ${kdeprefix}/bin
+ doexe ${servicescript}
+ fi
+
+ # kill useless plugin files
+ rm -f ${D}/usr/lib*/${PN}/plugins/*.{la,a}
+}
+
+pkg_postinst() {
+ UPDATE_PLUGINS=""
+ for x in ${PLUGIN_NAMES}; do
+ has_version mail-client/sylpheed-claws-$x && UPDATE_PLUGINS="${UPDATE_PLUGINS} $x"
+ done
+ if [ -n "${UPDATE_PLUGINS}" ]; then
+ ewarn
+ ewarn "You have to re-emerge or update the following plugins:"
+ ewarn
+ for x in ${UPDATE_PLUGINS}; do
+ ewarn " mail-client/sylpheed-claws-$x"
+ done
+ ewarn
+ epause 5
+ ebeep 3
+ fi
+}