summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2012-07-01 13:36:12 +0000
committerAkinori Hattori <hattya@gentoo.org>2012-07-01 13:36:12 +0000
commitc8fa4857e612f57e9c3d320faf71b500097062d0 (patch)
tree16b507c9aa0617f54ce4ed88379aa8aa0d1cca68 /mail-client/sylpheed
parentversion bump to 3.5 after quick functionality check (diff)
downloadgentoo-2-c8fa4857e612f57e9c3d320faf71b500097062d0.tar.gz
gentoo-2-c8fa4857e612f57e9c3d320faf71b500097062d0.tar.bz2
gentoo-2-c8fa4857e612f57e9c3d320faf71b500097062d0.zip
new upstream release.
(Portage version: 2.1.10.65/cvs/Linux i686)
Diffstat (limited to 'mail-client/sylpheed')
-rw-r--r--mail-client/sylpheed/ChangeLog7
-rw-r--r--mail-client/sylpheed/sylpheed-3.2.0.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/mail-client/sylpheed/ChangeLog b/mail-client/sylpheed/ChangeLog
index 8d2df240dee2..08ec69570180 100644
--- a/mail-client/sylpheed/ChangeLog
+++ b/mail-client/sylpheed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/sylpheed
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.305 2012/05/26 08:19:00 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.306 2012/07/01 13:36:12 hattya Exp $
+
+*sylpheed-3.2.0 (01 Jul 2012)
+
+ 01 Jul 2012; Akinori Hattori <hattya@gentoo.org> +sylpheed-3.2.0.ebuild:
+ new upstream release.
26 May 2012; Akinori Hattori <hattya@gentoo.org> +files/sylpheed-r3033.diff,
sylpheed-2.6.0.ebuild, sylpheed-3.1.2.ebuild, sylpheed-3.1.3.ebuild,
diff --git a/mail-client/sylpheed/sylpheed-3.2.0.ebuild b/mail-client/sylpheed/sylpheed-3.2.0.ebuild
new file mode 100644
index 000000000000..a2d7569f6861
--- /dev/null
+++ b/mail-client/sylpheed/sylpheed-3.2.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/sylpheed-3.2.0.ebuild,v 1.1 2012/07/01 13:36:12 hattya Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="A lightweight email client and newsreader"
+HOMEPAGE="http://sylpheed.sraoss.jp/"
+SRC_URI="http://sylpheed.sraoss.jp/${PN}/v${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="crypt ipv6 ldap nls oniguruma pda spell ssl xface"
+
+CDEPEND="x11-libs/gtk+:2
+ nls? ( sys-devel/gettext )
+ crypt? ( app-crypt/gpgme )
+ ldap? ( net-nds/openldap )
+ oniguruma? ( dev-libs/oniguruma )
+ pda? ( app-pda/jpilot )
+ spell? ( app-text/gtkspell:2 )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${CDEPEND}
+ app-misc/mime-types
+ net-misc/curl"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ xface? ( media-libs/compface )"
+
+src_configure() {
+ local htmldir=/usr/share/doc/${PF}/html
+ econf \
+ $(use_enable crypt gpgme) \
+ $(use_enable ipv6) \
+ $(use_enable ldap) \
+ $(use_enable oniguruma) \
+ $(use_enable pda jpilot) \
+ $(use_enable spell gtkspell) \
+ $(use_enable ssl) \
+ $(use_enable xface compface) \
+ --with-manualdir=${htmldir}/manual \
+ --with-faqdir=${htmldir}/faq \
+ --disable-updatecheck
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog* NEWS* README* TODO*
+
+ doicon *.png
+ domenu *.desktop
+}