summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2014-03-21 16:33:59 +0000
committerAgostino Sarubbo <ago@gentoo.org>2014-03-21 16:33:59 +0000
commitbdfe74d35a8e85ebfaf5ed1547779a3587e6d488 (patch)
tree2d0726240d41b80a163590041d457ff311ea126d /mail-client/trojita
parentUpdated Aaron's e-mail address. (diff)
downloadgentoo-2-bdfe74d35a8e85ebfaf5ed1547779a3587e6d488.tar.gz
gentoo-2-bdfe74d35a8e85ebfaf5ed1547779a3587e6d488.tar.bz2
gentoo-2-bdfe74d35a8e85ebfaf5ed1547779a3587e6d488.zip
Version bump to 0.4.1 to fix CVE-2014-2567, wrt bug #505146
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 7194459F)
Diffstat (limited to 'mail-client/trojita')
-rw-r--r--mail-client/trojita/ChangeLog7
-rw-r--r--mail-client/trojita/trojita-0.4.1.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/mail-client/trojita/ChangeLog b/mail-client/trojita/ChangeLog
index 0065a01c5f9e..067001e95db4 100644
--- a/mail-client/trojita/ChangeLog
+++ b/mail-client/trojita/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/trojita
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/trojita/ChangeLog,v 1.30 2014/03/06 12:13:48 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/trojita/ChangeLog,v 1.31 2014/03/21 16:33:59 ago Exp $
+
+*trojita-0.4.1 (21 Mar 2014)
+
+ 21 Mar 2014; Agostino Sarubbo <ago@gentoo.org> +trojita-0.4.1.ebuild:
+ Version bump to 0.4.1 to fix CVE-2014-2567, wrt bug #505146
*trojita-0.4 (06 Mar 2014)
diff --git a/mail-client/trojita/trojita-0.4.1.ebuild b/mail-client/trojita/trojita-0.4.1.ebuild
new file mode 100644
index 000000000000..796be9d59135
--- /dev/null
+++ b/mail-client/trojita/trojita-0.4.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/trojita/trojita-0.4.1.ebuild,v 1.1 2014/03/21 16:33:59 ago Exp $
+
+EAPI=5
+
+QT_REQUIRED="4.8.0"
+EGIT_REPO_URI="git://anongit.kde.org/${PN}.git"
+[[ ${PV} == "9999" ]] && GIT_ECLASS="git-2"
+
+inherit cmake-utils virtualx ${GIT_ECLASS}
+
+DESCRIPTION="A Qt IMAP e-mail client"
+HOMEPAGE="http://trojita.flaska.net/"
+if [[ ${PV} == "9999" ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~x86"
+ MY_LANGS="bs cs da de el es et fr ga gl hu ia it lt mr nb nl pl pt pt_BR ro sk sv tr ug uk zh_CN zh_TW"
+fi
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+IUSE="debug test +zlib"
+for MY_LANG in ${MY_LANGS} ; do
+ IUSE="${IUSE} linguas_${MY_LANG}"
+done
+
+RDEPEND="
+ >=dev-qt/qtbearer-${QT_REQUIRED}:4
+ >=dev-qt/qtgui-${QT_REQUIRED}:4
+ >=dev-qt/qtsql-${QT_REQUIRED}:4[sqlite]
+ >=dev-qt/qtwebkit-${QT_REQUIRED}:4
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qttest-${QT_REQUIRED}:4 )
+ zlib? (
+ virtual/pkgconfig
+ sys-libs/zlib
+ )
+"
+
+DOCS="README LICENSE"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with test TESTS)
+ $(cmake-utils_use_with zlib ZLIB)
+ )
+ if [[ ${MY_LANGS} ]]; then
+ rm po/trojita_common_x-test.po
+ for x in po/*.po; do
+ mylang=${x#po/trojita_common_}
+ mylang=${mylang%.po}
+ use linguas_$mylang || rm $x
+ done
+ fi
+
+ # the build system is taking a look at `git describe ... --dirty` and
+ # gentoo's modifications to CMakeLists.txt break these
+ sed -i "s/--dirty//" "${S}/cmake/TrojitaVersion.cmake" || die "Cannot fix the version check"
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ VIRTUALX_COMMAND=cmake-utils_src_test virtualmake
+}