summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-07 03:55:14 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-07 03:55:14 +0000
commita0fb1b5a95520f4d21fd9b4137acb37a00e1e52e (patch)
tree79657ad85a01592d89e173fc26ec446db8d254c6 /mail-client
parentQA - IUSE fix (Manifest recommit) (diff)
downloadgentoo-2-a0fb1b5a95520f4d21fd9b4137acb37a00e1e52e.tar.gz
gentoo-2-a0fb1b5a95520f4d21fd9b4137acb37a00e1e52e.tar.bz2
gentoo-2-a0fb1b5a95520f4d21fd9b4137acb37a00e1e52e.zip
Fix use invocation
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/pine/ChangeLog7
-rw-r--r--mail-client/pine/pine-4.50-r4.ebuild12
-rw-r--r--mail-client/pine/pine-4.58-r1.ebuild10
-rw-r--r--mail-client/pine/pine-4.58-r2.ebuild12
-rw-r--r--mail-client/pine/pine-4.58-r3.ebuild20
-rw-r--r--mail-client/pine/pine-4.58.ebuild10
6 files changed, 38 insertions, 33 deletions
diff --git a/mail-client/pine/ChangeLog b/mail-client/pine/ChangeLog
index 7be42c94f8d6..37d7dcd0ee81 100644
--- a/mail-client/pine/ChangeLog
+++ b/mail-client/pine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/pine
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/pine/ChangeLog,v 1.1 2004/05/30 02:56:38 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/pine/ChangeLog,v 1.2 2004/06/07 03:55:14 agriffis Exp $
+
+ 06 Jun 2004; Aron Griffis <agriffis@gentoo.org> pine-4.50-r4.ebuild,
+ pine-4.58-r1.ebuild, pine-4.58-r2.ebuild, pine-4.58-r3.ebuild,
+ pine-4.58.ebuild:
+ Fix use invocation
*pine-4.58-r2 (29 May 2004)
diff --git a/mail-client/pine/pine-4.50-r4.ebuild b/mail-client/pine/pine-4.50-r4.ebuild
index a628dad5140b..9c4e29769937 100644
--- a/mail-client/pine/pine-4.50-r4.ebuild
+++ b/mail-client/pine/pine-4.50-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/pine/pine-4.50-r4.ebuild,v 1.1 2004/05/30 02:56:38 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/pine/pine-4.50-r4.ebuild,v 1.2 2004/06/07 03:55:14 agriffis Exp $
inherit eutils
@@ -27,7 +27,7 @@ src_unpack() {
unpack pine-4.50-maildir.patch.gz
cd ${S}
- if [ "`use mbox`" ] ; then
+ if use mbox ; then
epatch ${FILESDIR}/imap-4.7c2-flock.patch
else
epatch ${FILESDIR}/pine-4.50-maildir.patch
@@ -43,7 +43,7 @@ src_unpack() {
# change /bin/passwd to /usr/bin/passwd
epatch ${FILESDIR}/pine-4.21-passwd.patch
- if [ "`use ldap`" ] ; then
+ if use ldap ; then
# link to shared ldap libs instead of static
epatch ${FILESDIR}/pine-4.30-ldap.patch
mkdir ${S}/ldap
@@ -66,7 +66,7 @@ src_unpack() {
# gets rid of a call to stripwhitespace()
epatch ${FILESDIR}/pine-4.33-whitespace.patch
- if [ `use debug` ]; then
+ if use debug; then
cd ${S}/pine
cp makefile.lnx makefile.orig
sed -e "s:-g -DDEBUG -DDEBUGJOURNAL:${CFLAGS} -g -DDEBUG -DDEBUGJOURNAL:" \
@@ -89,7 +89,7 @@ src_unpack() {
src_compile() {
BUILDOPTS=""
- if [ "`use ssl`" ]
+ if use ssl
then
BUILDOPTS="${BUILDOPTS} SSLDIR=/usr SSLTYPE=unix SSLCERTS=/etc/ssl/certs"
cd ${S}/imap/src/osdep/unix
@@ -103,7 +103,7 @@ src_compile() {
else
BUILDOPTS="${BUILDOPTS} NOSSL"
fi
- if [ "`use ldap`" ]
+ if use ldap
then
./contrib/ldap-setup lnp lnp
BUILDOPTS="${BUILDOPTS} LDAPCFLAGS=-DENABLE_LDAP"
diff --git a/mail-client/pine/pine-4.58-r1.ebuild b/mail-client/pine/pine-4.58-r1.ebuild
index 85f53bf85b43..ed6d26b947d5 100644
--- a/mail-client/pine/pine-4.58-r1.ebuild
+++ b/mail-client/pine/pine-4.58-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/pine/pine-4.58-r1.ebuild,v 1.2 2004/05/30 11:17:58 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/pine/pine-4.58-r1.ebuild,v 1.3 2004/06/07 03:55:14 agriffis Exp $
inherit eutils
@@ -36,7 +36,7 @@ src_unpack() {
epatch ${FILESDIR}/imap-4.7c2-flock.patch
cp ${FILESDIR}/flock.c ${S}/imap/src/osdep/unix
- if [ "`use ldap`" ] ; then
+ if use ldap ; then
# link to shared ldap libs instead of static
epatch ${FILESDIR}/pine-4.30-ldap.patch
mkdir ${S}/ldap
@@ -58,7 +58,7 @@ src_unpack() {
# bug #23336 - makes pine transparent in terms that support it
epatch ${FILESDIR}/transparency.patch
- if [ `use debug` ]; then
+ if use debug; then
cd ${S}/pine
sed -i \
-e "s:-g -DDEBUG -DDEBUGJOURNAL:${CFLAGS} -g -DDEBUG -DDEBUGJOURNAL:" \
@@ -86,7 +86,7 @@ src_unpack() {
src_compile() {
BUILDOPTS=""
- if [ "`use ssl`" ]
+ if use ssl
then
BUILDOPTS="${BUILDOPTS} SSLDIR=/usr SSLTYPE=unix SSLCERTS=/etc/ssl/certs"
cd ${S}/imap/src/osdep/unix
@@ -99,7 +99,7 @@ src_compile() {
else
BUILDOPTS="${BUILDOPTS} NOSSL"
fi
- if [ "`use ldap`" ]
+ if use ldap
then
./contrib/ldap-setup lnp lnp
BUILDOPTS="${BUILDOPTS} LDAPCFLAGS=-DENABLE_LDAP"
diff --git a/mail-client/pine/pine-4.58-r2.ebuild b/mail-client/pine/pine-4.58-r2.ebuild
index 6bea34ab1c05..0de771234e3b 100644
--- a/mail-client/pine/pine-4.58-r2.ebuild
+++ b/mail-client/pine/pine-4.58-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/pine/pine-4.58-r2.ebuild,v 1.2 2004/05/30 11:17:58 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/pine/pine-4.58-r2.ebuild,v 1.3 2004/06/07 03:55:14 agriffis Exp $
inherit eutils
@@ -33,7 +33,7 @@ src_unpack() {
epatch "${FILESDIR}/imap-4.7c2-flock.patch"
cp "${FILESDIR}/flock.c" "${S}/imap/src/osdep/unix"
- if [ "`use ldap`" ] ; then
+ if use ldap ; then
# link to shared ldap libs instead of static
epatch "${FILESDIR}/pine-4.30-ldap.patch"
mkdir "${S}/ldap"
@@ -41,7 +41,7 @@ src_unpack() {
ln -s /usr/include "${S}/ldap/include"
fi
- if [ "`use passfile`" ] ; then
+ if use passfile ; then
epatch "${FILESDIR}/pine-4.56-passfile.patch"
fi
@@ -52,7 +52,7 @@ src_unpack() {
# bug #23336 - makes pine transparent in terms that support it
epatch "${FILESDIR}/transparency.patch"
- if [ "`use debug`" ] ; then
+ if use debug ; then
sed -e "s:-g -DDEBUG -DDEBUGJOURNAL:${CFLAGS} -g -DDEBUG -DDEBUGJOURNAL:" \
-i "${S}/pine/makefile.lnx" || die "sed pine/makefile.lnx failed"
sed -e "s:-g -DDEBUG:${CFLAGS} -g -DDEBUG:" \
@@ -71,7 +71,7 @@ src_unpack() {
src_compile() {
local BUILDOPTS
- if [ "`use ssl`" ] ; then
+ if use ssl ; then
BUILDOPTS="${BUILDOPTS} SSLDIR=/usr SSLTYPE=unix SSLCERTS=/etc/ssl/certs"
sed -e "s:\$(SSLDIR)/certs:/etc/ssl/certs:" \
-e "s:\$(SSLCERTS):/etc/ssl/certs:" \
@@ -81,7 +81,7 @@ src_compile() {
BUILDOPTS="${BUILDOPTS} NOSSL"
fi
- if [ "`use ldap`" ] ; then
+ if use ldap ; then
./contrib/ldap-setup lnp lnp
BUILDOPTS="${BUILDOPTS} LDAPCFLAGS=-DENABLE_LDAP"
else
diff --git a/mail-client/pine/pine-4.58-r3.ebuild b/mail-client/pine/pine-4.58-r3.ebuild
index 9ebd941cb1b3..3d4cf172dde7 100644
--- a/mail-client/pine/pine-4.58-r3.ebuild
+++ b/mail-client/pine/pine-4.58-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/pine/pine-4.58-r3.ebuild,v 1.1 2004/05/30 02:56:38 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/pine/pine-4.58-r3.ebuild,v 1.2 2004/06/07 03:55:14 agriffis Exp $
inherit eutils
@@ -43,7 +43,7 @@ src_unpack() {
# Fix flock() emulation.
cp "${FILESDIR}/flock.c" "${S}/imap/src/osdep/unix"
- if [ "`use maildir`" ] ; then
+ if use maildir ; then
epatch "${DISTDIR}/${P}-maildir.patch"
# Build the flock() emulation.
epatch "${FILESDIR}/imap-4.7c2-flock+maildir.patch"
@@ -51,17 +51,17 @@ src_unpack() {
# Build the flock() emulation.
epatch "${FILESDIR}/imap-4.7c2-flock.patch"
fi
- if [ "`use ldap`" ] ; then
+ if use ldap ; then
# Link to shared ldap libs instead of static.
epatch "${FILESDIR}/pine-4.30-ldap.patch"
mkdir "${S}/ldap"
ln -s /usr/lib "${S}/ldap/libraries"
ln -s /usr/include "${S}/ldap/include"
fi
- if [ "`use ipv6`" ] ; then
+ if use ipv6 ; then
epatch "${DISTDIR}/${P}-v6-20031001.diff"
fi
- if [ "`use passfile`" ] ; then
+ if use passfile ; then
epatch "${FILESDIR}/pine-4.56-passfile.patch"
fi
@@ -76,7 +76,7 @@ src_unpack() {
# Bug #23336 - makes pine transparent in terms that support it.
epatch "${FILESDIR}/transparency.patch"
- if [ "`use debug`" ] ; then
+ if use debug ; then
sed -e "s:-g -DDEBUG -DDEBUGJOURNAL:${CFLAGS} -g -DDEBUG -DDEBUGJOURNAL:" \
-i "${S}/pine/makefile.lnx" || die "sed pine/makefile.lnx failed"
sed -e "s:-g -DDEBUG:${CFLAGS} -g -DDEBUG:" \
@@ -94,7 +94,7 @@ src_unpack() {
src_compile() {
local myconf
- if [ "`use ssl`" ] ; then
+ if use ssl ; then
myconf="${myconf} SSLDIR=/usr SSLTYPE=unix SSLCERTS=/etc/ssl/certs"
sed -e "s:\$(SSLDIR)/certs:/etc/ssl/certs:" \
-e "s:\$(SSLCERTS):/etc/ssl/certs:" \
@@ -103,13 +103,13 @@ src_compile() {
else
myconf="${myconf} NOSSL"
fi
- if [ "`use ldap`" ] ; then
+ if use ldap ; then
./contrib/ldap-setup lnp lnp
myconf="${myconf} LDAPCFLAGS=-DENABLE_LDAP"
else
myconf="${myconf} NOLDAP"
fi
- if [ "`use kerberos`" ] ; then
+ if use kerberos ; then
myconf="${myconf} EXTRAAUTHENTICATORS=gss"
fi
@@ -125,7 +125,7 @@ src_install() {
doman doc/pine.1 doc/pico.1 doc/pilot.1 doc/rpdump.1 doc/rpload.1
dodoc CPYRIGHT README doc/brochure.txt doc/tech-notes.txt
- if [ "`use ipv6`" ] ; then
+ if use ipv6 ; then
dodoc "${DISTDIR}/readme.${P}-v6-20031001"
fi
diff --git a/mail-client/pine/pine-4.58.ebuild b/mail-client/pine/pine-4.58.ebuild
index 20a17b093c53..7e98e1ab46d5 100644
--- a/mail-client/pine/pine-4.58.ebuild
+++ b/mail-client/pine/pine-4.58.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/pine/pine-4.58.ebuild,v 1.2 2004/05/30 11:17:58 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/pine/pine-4.58.ebuild,v 1.3 2004/06/07 03:55:14 agriffis Exp $
inherit eutils
@@ -33,7 +33,7 @@ src_unpack() {
epatch ${FILESDIR}/imap-4.7c2-flock.patch
cp ${FILESDIR}/flock.c ${S}/imap/src/osdep/unix
- if [ "`use ldap`" ] ; then
+ if use ldap ; then
# link to shared ldap libs instead of static
epatch ${FILESDIR}/pine-4.30-ldap.patch
mkdir ${S}/ldap
@@ -55,7 +55,7 @@ src_unpack() {
# bug #23336 - makes pine transparent in terms that support it
epatch ${FILESDIR}/transparency.patch
- if [ `use debug` ]; then
+ if use debug; then
cd ${S}/pine
sed -i \
-e "s:-g -DDEBUG -DDEBUGJOURNAL:${CFLAGS} -g -DDEBUG -DDEBUGJOURNAL:" \
@@ -83,7 +83,7 @@ src_unpack() {
src_compile() {
BUILDOPTS=""
- if [ "`use ssl`" ]
+ if use ssl
then
BUILDOPTS="${BUILDOPTS} SSLDIR=/usr SSLTYPE=unix SSLCERTS=/etc/ssl/certs"
cd ${S}/imap/src/osdep/unix
@@ -96,7 +96,7 @@ src_compile() {
else
BUILDOPTS="${BUILDOPTS} NOSSL"
fi
- if [ "`use ldap`" ]
+ if use ldap
then
./contrib/ldap-setup lnp lnp
BUILDOPTS="${BUILDOPTS} LDAPCFLAGS=-DENABLE_LDAP"